Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error "a device attached to the system is not functioning"


21 Aug 2011   #1

Dual booting: Ubuntu 10.10 & Windows 7 Ultimate 32bit
 
 
Error "a device attached to the system is not functioning"

Error "a device attached to the system is not functioning"

Hello, I am trying out different logon UI's and I was just about to replace my "authui" in system32 (I regular process when switching login screens) but this time when I tried to take ownership I now get this Error "a device attached to the system is not functioning", this a first for me, It did give me this error before when I tried an old logon theme for xp which didn't work even in compatibility mode, so thought nothing of this anyway I then tried the "take ownership" registry file again but I also get the same error.

So any ideas, I really would like to get back to trying out new and different logon screens.

***********************************EDITED***********************************

I think I'll have boot into ubuntu and rename the files as I please from there, It's the only way to get things moving from here, I've saved my windows partition many a time doing this, its just annoying in terms of time, I'm gonna have to go there copy the custom "authui file" to system32 then make sure the original is kosher and backed up there (I usually just rename it to "authui.backup.dll" or just .backup) I wish there was I quick way (and I thinking virtualization) to access the system32 folder using the linux filesystem but from within windows somehow, so I don't need to reboot every time.
Are you with me? It's really annoying if your changing the "authui" several times just to try out different logon styles, oh yes also because for example (you've renamed your systems default "authui" file to "authui.backup" and that's worked fine, but when go to change it back, you need to take ownership and so you can't, so your system is left with no "authui" file to load for the login screen, this also means without "authui" you can't reboot as fast, it's slowed because the system needs "authui" to function properly.)
I shouldn't have to reboot every time I want to rename system32 files, that's why I need take ownership working again, It will eliminate my need for a reboot and at least leave me with a usable system.

*********************************EDITED*************************************

Well I did end up rebooting but it was the only way I could move forward or else I would have had a system that wasn't operational, and for whatever reason "take ownership" now works again after the reboot, but I still think this thread is relevant, so please moderators don't delete it, it may still be useful for others in the future.

=/


- regards

- 4Foxtrot

My System SpecsSystem Spec
.

Reply

 Error "a device attached to the system is not functioning"




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:20 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33