Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Old Mobility x200 blank screen after driver install


26 Jul 2009   #1

W7 RTM x86
 
 
Old Mobility 200M blank screen after driver install

Hi, I recently installed Windows 7 x86 build 16385 on an old laptop with an ATI 200M xpress mobility graphics chipset, the basic VGA drivers work just fine, however after Windows install its drivers for this specific chipset it just gives me a blank screen on the next boot. However it works just fine when I hook the laptop up to an external monitor, I then found that it fails to detect the laptops screen at all!

For reference the laptop works perfectly in XP (which I am currently dual booting with).

I have attempted to install the 9.3 catalyst drivers (the last for legacy graphics) and those failed to do anything at all, Windows just installs the standard VGA drivers on next boot up. I also found that there was nothing in the ATI folders within Program Files (possible issue with permissions?). However installing outside Program Files again did absolutely nothing.

Any help would be greatly appreciated as I'm at my wits end with this.

My System SpecsSystem Spec
.

Reply

 Old Mobility x200 blank screen after driver install




Thread Tools



Similar help and support threads for2: Old Mobility x200 blank screen after driver install
Thread Forum
ATI Mobility Radeon x1300 Driver Download/Install Error Drivers
Grey blank screen when trying to install chrome Browsers & Mail
Windows 7 clean install blank screen Installation & Setup
Nvidia Drivers Install - Blank Screen Graphic Cards
Blank Screen after clean install of Win 7 Installation & Setup
Install Goes to blank screen BEFORE logo shows Installation & Setup
Radeon Mobility 9600 (MV 350) driver, how to install? Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:22 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33