Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: i think my brand new VIDEO CARD is broken

29 Jul 2009   #1
edrik

Windows 7 Home Premium SP1 64-bit
 
 
i think my brand new VIDEO CARD is broken

i just bought two 1gb Nvidia 9800 GT yesterday and now i think one of them is broke..

i was rendering (in Revit Architecture) when my monitor turned off.. (it says no signal) but my CPU was still on so I tried turning my monitor on & off to see if it helps, but to no avail.


so I restarted my computer but i still get no signal on my monitor...

so I connected my monitor to my other video card and it worked. I went to device manager but there's only 1 video card detected... is it broken or do i have to just remove it and place it back on the mother board ?
I really need the video card right now for my project since my deadline is due tomorrow


My System SpecsSystem Spec
.
29 Jul 2009   #2
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Test one at a time in the slot that has the working card in it and then you will know for sure.
My System SpecsSystem Spec
29 Jul 2009   #3
srq2625

Win7 Ultimate, x64
 
 

It would seem standard H/W troubleshooting procedures are in order here. You've already taken the first step to be sure that your monitor is still working - you plugged it into the other card.

Continue the process:
  • Move both cards
  • Re-insert the "broken" card
  • Does that work?
  • If not, swap cards. Does that work?
  • If both worked seperately, install both cards and try again.
  • Your results will point to the problem.
  • If the above don't provide definitive answers, installing the "broken" card in a different computer might help narrow down the problem.
  • You might also want to remove the device drivers and re-install the very most recent from the manufacturer.
My System SpecsSystem Spec
.

29 Jul 2009   #4
edrik

Windows 7 Home Premium SP1 64-bit
 
 

still no go.. now both vidcards does not work on my new unit

im using my old core duo unit at the moment.. since my i7 computer doesnt want to start... my monitor still gets no signal from my new rig..
i dont have any idea why this is happening..
maybe a defective motherboard is the problem ?
My System SpecsSystem Spec
29 Jul 2009   #5
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Defective Motherboard or maybe the PSU has gone South, did you make sure it was going to handle 2 9800GT's, how many Watts is it? Have you got another computer you can test the Video cards on, maybe a friends?
My System SpecsSystem Spec
29 Jul 2009   #6
edrik

Windows 7 Home Premium SP1 64-bit
 
 

my PSU is 1000watts


the specs of my new rig are as follows

6gb ddr3 ram
1tb + 250gb hdd
core i7 920 2.67Ghz
1gb Nvidia 9800GT x2
1000watts PSU
v10 coolermaster *cpu cooler*
haf 922 coolermaster *atx casing*
creative sbs a500 sound system
and a samsung dvd/rw with lightscribe


it worked well for about one day though *sigh*.. and it's too heavy to bring back for repairs..
My System SpecsSystem Spec
29 Jul 2009   #7
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Just had a look on the SLI Zone for a similar topic and people there state

Quote:
2x 9800 GT's would run on a 650w PSU but only if that PSU had a +12v rail that supplied 28 amps min
SLI Zone Forums > 9800 GT SLI and PSU requirements
My System SpecsSystem Spec
29 Jul 2009   #8
Antman

 

Kuya, complete system specs would be very helpful.
My System SpecsSystem Spec
29 Jul 2009   #9
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Quote   Quote: Originally Posted by edrik View Post
my PSU is 1000watts
That seems like it should be enough, how many 12v Rails is that split into?
My System SpecsSystem Spec
29 Jul 2009   #10
Mark

Windows 7 Ultimate Vista Ultimate x64
 
 

Is it possible for you to test the cards on your computer your using now, it seems like they aren't the problem but it's good to make sure, also have you been doing any overclocking, have you tried to reset the cmos?
My System SpecsSystem Spec
Reply

 i think my brand new VIDEO CARD is broken




Thread Tools




Similar help and support threads
Thread Forum
Is this a good graphics card brand.
Buy the VisionTek Radeon R9 270X Video Card at TigerDirect.ca I want this but im not sure about this brand.
Graphic Cards
network card getting broken ?
Hi. So as i am writing this message my network drops all the time and it is causing me issues which i jsut cant handle right now . I checked the router but it shows no problem, i have optic cable connection of 50mbps Speedtest.net by Ookla - My Results This is my current speed ( i barelly made...
Network & Sharing
Sign of a broken video card?
I was playing CSGO and my computer suddenly crashed on me. Second time it has happened. Upon reboot, i got these artifacts on the screen. It's not the monitor, my Xbox shows up fine. The BSOD won't even show up properly, can't read off the error code. Is this the sign of a broken video card? ...
Graphic Cards
Would the graphics card have to be the same brand as the motherboard?
Hello everyone, sorry for troubling you guys again, I'm a tech noob, so I need help. If I were to buy an ASUS motherboard. Am I required to buy an ASUS GPU with it or could I just buy one from MSI or EVGA to use on my ASUS motherboard?
Hardware & Devices
How Do I fix a broken SD Card Slot
On my sister's computer which is a Dell Inspiron 560 it has an SD Card Slot. The SD Card Slot stopped working a while ago and I was trying to help her fix it. The drive letter for it is S: and it says please insert a card. The reader itself is lighting up saying that there is a card in there. If i...
Hardware & Devices
Broken Graphics Card
Hey guys, just got a quick question Is a broken graphics card enough to make a computer turn itself off right after being turned on with no other hardware interaction?
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App