Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB's ports not working properly in Win 7

17 Sep 2011   #1

Windows 7 Home Premium x64
 
 
USB's ports not working properly in Win 7

Hi.
My system is Dell OptiPlex 740,‎‎ 2.50 GB RAM, Win 7 Ultimate 64bit.
All of a sudden - the USB ports (all 7 of them) stopped to function properly.
Each device I plugged into the port - got recognized as 'uknown device' and doesn't function at all.
One of the biggest problems that this cause me - I can't plug in the keyboard and the mice - I don't have PS/2 ports in this computer.
Thing is, even out of Windows, the USB doesn't work. I'm suspecting this because the PC giving me 'Keyboard fault' everytime I restart. So I can't got to BIOS either.
Right now I'm using special combination of USB hub attached to one of the ports, and the peripherals connected to the hub.

I'll be very happy to know what's the answer to my problems..

TY in advance.

My System SpecsSystem Spec
.

17 Sep 2011   #2

Windows 8.1 Pro x64
 
 

Quote   Quote: Originally Posted by Cheetah64d View Post
Hi.
My system is Dell OptiPlex 740,‎‎ 2.50 GB RAM, Win 7 Ultimate 64bit.
All of a sudden - the USB ports (all 7 of them) stopped to function properly.
Each device I plugged into the port - got recognized as 'uknown device' and doesn't function at all.
One of the biggest problems that this cause me - I can't plug in the keyboard and the mice - I don't have PS/2 ports in this computer.
Thing is, even out of Windows, the USB doesn't work. I'm suspecting this because the PC giving me 'Keyboard fault' everytime I restart. So I can't got to BIOS either.
Right now I'm using special combination of USB hub attached to one of the ports, and the peripherals connected to the hub.

I'll be very happy to know what's the answer to my problems..

TY in advance.
Then the problem lies in your hardware or its a bug in the BIOS, consider updating your BIOS, a newer version is available
Reset the CMOS battery
My System SpecsSystem Spec
17 Sep 2011   #3

Windows 7 Home Premium x64
 
 

Ok, but how can I update the BIOS if I can't get to it?
Pressing F2 doesn't do nothing, as expected..
My System SpecsSystem Spec
.


17 Sep 2011   #4

Windows 7 Home Premium 64 bit
 
 

Shut down your computer completely, unplug the power cord from the back for at least a minute. Then power back up.
My System SpecsSystem Spec
17 Sep 2011   #5
Microsoft MVP

Windows 8.1 Pro with Media Center 64 bit
 
 

Quote   Quote: Originally Posted by p5bdkw View Post
Shut down your computer completely, unplug the power cord from the back for at least a minute. Then power back up.
With the power cord unplugged, press the PC's power button to completely drain the power supply, then plug it back in and power up. < saves waiting that minute or two and guaranties that its completly discharged.
My System SpecsSystem Spec
17 Sep 2011   #6

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Are any of the Diagnostic Lights on (in the back)?

Do you have an internal memory card reader in that rig? If so, try:
  1. Disconnecting the reader inside the case, or
  2. Install a memory stick in the reader before you boot.
Also try unplugging everything USB except for the keyboard.
My System SpecsSystem Spec
18 Sep 2011   #7

Windows 7 Home Premium x64
 
 

Well, TY guys very much for the suggestions.
Will try them all and see what's working.
My System SpecsSystem Spec
Reply

 USB's ports not working properly in Win 7




Thread Tools



Similar help and support threads for2: USB's ports not working properly in Win 7
Thread Forum
Solved USB ports not working Hardware & Devices
Solved Front USB ports not working, but rear USB ports work Hardware & Devices
Solved 2 usb ports are not working?? Drivers
USB ports not working properly Hardware & Devices
USB ports not working properly after using external USB hub Hardware & Devices
usb ports not working properly Hardware & Devices
USB ports not working Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:37 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33