Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Upgraded my CPU now it shows up as AMD model unknown help

21 Sep 2011   #11
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Athlon II x2 245 which is actually a socket AM3 CPU,

Compare AMD Processors for Desktops: AMD Phenom

not the Athlon x2 which is socket AM2. The board does support some of the AM2+ CPU's, but no idea if AM3 support was ever added. And yes AM3 can run on an AM2 or AM2+ if the manufacturer added them in a bios update. Only way to really find out is to flash with the latest (if not installed already), or contact Sapphire directly and see what they have to say.


My System SpecsSystem Spec
.
21 Sep 2011   #12
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Thanks Stormy. I don't do much with AMD processors so I have not a clue on model numbers!

But an unsupported processor would certainly explain the odd errors, wouldn't it?
My System SpecsSystem Spec
21 Sep 2011   #13
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

It could. Usually when the correct speed and number of cores is detected properly though the name shown for the CPU is more cosmetic than anything. I get the feeling that something is disagreeing with an AM3 CPU in an AM2+ motherboard without proper AM3 support.

Adam could you please post a screen shot from CPUz,

CPUID - System & hardware benchmark, monitoring, reporting

on the Mainboard tab so we can see which bios version you currently have installed.
My System SpecsSystem Spec
.

22 Sep 2011   #14
adamwentzell82

Windows 7 Home Premium x64 SP1 retail
 
 

I just put back in the AMD Phenom x4 9500 2.2 GHZ Quad core AM2+ that was in this board before and started up the computer and got to the welcome screen then it locked up and had to restart.After restarting I got the same error after post but seems like it's working now but for how long not sure.(The file is possibly corrupt. The file header checksum does not match the computed checksum.)
When running CPU-Z everything showed up right even the model number.
My System SpecsSystem Spec
29 Sep 2011   #15
adamwentzell82

Windows 7 Home Premium x64 SP1 retail
 
 

Solved replaced motherboard, CPU and ram
My System SpecsSystem Spec
30 Sep 2011   #16
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Glad to hear you got it sorted.
My System SpecsSystem Spec
Reply

 Upgraded my CPU now it shows up as AMD model unknown help




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
External HDD shows Unknown, no size, Not Initialized
My external HDD has crashed after unplugging it accidentally while using it. I believe the directory structure has been corrupted. The external HDD shows Unknown, no size, and Not Initialized on the Disk Management screen: I have tried using MiniTool Partition Wizard as described in this...
Hardware & Devices
System info shows wrong model, how to remove grub?
I swear I'm never messing with linux again. It's a great operating system when it works, but when it doesn't, it will screw everything up. OK, so I removed the linux partition from inside windows. But it was still trying to boot into ubuntu, because of grub. Well, I used this recovery cd to try...
Installation & Setup
Need AOL help: upgraded from IE7 to IE9, but useragentstring shows IE7
I know, this problem is relevant to a Vista system. But I'm hoping any AOL experts here on SevenForums will not shun me and my question. I upgraded the Vista machine from Service Pack 2 to Service Pack 3. As a result the installed IE was upgraded from IE7 to IE8. I then further upgraded to...
Browsers & Mail
Windows Recovery disk shows operating system: Unknown on (Unknown)
I've been trolling the forums here for a while. Lots of great info but now I actually have an issue where I need some assistance. :D When I was booting one day last week I got a nasty BSOD when Windows was trying to load. Then on the next reboot Windows 7 said it couldn't load and needed to do...
BSOD Help and Support
Amd Athlon X2 BE 2350 from Acer Shows as Unknown CPU
I just built a trasher PC from cheap and or free parts, I got the cpu (Amd Athlon X2 BE 2350 2.1Ghz) from an old Acer and its now running in a PcChips A13G+ motherboard, when i check my WEI scores the CPU cranks out at a whopping 4.8 however its showing as just an "AMD Processor Model Unknown" so...
Hardware & Devices
Verifier shows drivers from unknown provider
The driver verifier program, Verifier.exe, shows 4 drivers from "unknown provider". The Drivers tab of Autoruns.exe does not show these. Neither PowerShell nor Windows Explorer finds them and yes, I even specifically looked in Windows\system32\drivers. The quick Malware Bytes scan and...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App