Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Strange USB device issue

21 Sep 2011   #1
swervr1

Windows 7 Ultimate 32 bit
 
 
Strange USB device issue

Hi,

I have spent quite a while checking through the "safely remove USB device" issues here in the forum but I cannot find an example quite like mine.

If I connect a USB device it will work correctly. It appears correctly under "Computer". The "Safely remove hardware and eject media" icon appears in the taskbar ok. However when you click on this icon to remove the device all that shows is 3 dots (...) instead of the device name. If you open Devices and Printers nothing shows there either.

Any help would be greatly appreciated.

Regards
Mervyn


My System SpecsSystem Spec
.
21 Sep 2011   #2
bassfisher6522

Windows 7 Ultimate 64 bit
 
 

What type of usb device is this? Do you have the latest driver/firmware, software for said usb device?
My System SpecsSystem Spec
21 Sep 2011   #3
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

You can try entering a name for it in Computer with the device(s) connected.
My System SpecsSystem Spec
.

22 Sep 2011   #4
swervr1

Windows 7 Ultimate 32 bit
 
 

Thanks for the replies, but this is the weird thing. It is not limited to one device. Anything I plug in now shows as (...) where as all devices worked correctly before.

Looking under "Computer" the device appears correctly, but does not show at all in "Devices and Printers" and so doesn't offer a "safely remove" option.

Regards
Mervyn
My System SpecsSystem Spec
23 Sep 2011   #5
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

You're welcome. Have a look in Control Panel\All Control Panel Items\Device Manager and see if anything shows a yellow triangle beside it.

Have you installed any new software or done any "optimizing" before which you didn't have this issue?
you can run SFC /SCANNOW Command - System File Checker to see if you have some files corrupted.
My System SpecsSystem Spec
24 Sep 2011   #6
swervr1

Windows 7 Ultimate 32 bit
 
 

Hi Britton30,

I looked in Device Manager and there are no items with a yellow triangle.

I then ran SFC /Scannow and it found and repaired a number of corrupted files, mainly to do with Internet Explorer it seems. I have uploaded the txt file in case it helps.

I rebooted the PC but the problem remains with any device plugged in showing as (...)

I have not completed any optimizing of C:/ drive, I have a separate drive D:/ solely for Flight Sim and this has been defragmented. I do run Spyware Doctor, Panda Antivirus and Registry Mechanic regularly but have never had an issue previously.

Regards
Mervyn
My System SpecsSystem Spec
24 Sep 2011   #7
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

I don't recommend Registry Mechanic for Windows 7 although it was good for XP. In my sig are some links for toher security programs and CCleaner. CCleaner has a Registry cleaner option that seems safe with Win 7, I use it.

Could you post a screenshot of the USB device shown as (...)?
My System SpecsSystem Spec
24 Sep 2011   #8
swervr1

Windows 7 Ultimate 32 bit
 
 

I have downloaded CCleaner and will use that moving forward.

I have also attached the screenshot you asked for. This particular device is a 4Gb memory stick.

Regards
Mervyn

Strange USB device issue-usb-issue.jpg


My System SpecsSystem Spec
24 Sep 2011   #9
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Two more ideas and I'm stumped if they don't work.
1. Use system restore to a point before the problem occurred.

2. While rebooting, hit F8 repeatedly and you'll get the Advanced Boot Options screen. Scroll and choose Last Known Good Configuration, enter.

Well one more. If you didn't reboot after the SFC run, run it again and reboot. If you still see it fixed something, run again. A clean one will say No Integrity Violations found.
My System SpecsSystem Spec
25 Sep 2011   #10
swervr1

Windows 7 Ultimate 32 bit
 
 

Hi Britton30,

Thanks for your assistance with this but I have been unable to resolve it.

I did reboot after running SFC, but I did it again and nothing was found this time. I then tried last known good configuration without success and system restore is my last try I guess. I will report how that goes but I dont have the time to run it right at the moment.

If that doesn't help do you think I should do a repair install of W7?

Regards
Mervyn
My System SpecsSystem Spec
Reply

 Strange USB device issue




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Strange USB Drive Showing in Device Manager
I was just farting around earlier doing a bit of maintenance and the usual checks when I expanded Disk drives in Device Manager. My SSD, Caviar Black, Caviar Green and Hitachi USB external drive all showed up fine, but I also have a weird 'ghost' drive showing up in there too which has a very...
Hardware & Devices
A strange conflict between USB input device and digital receiver
Hello, I am facing some kind of strange problem which had been happening for months and it took me this long to identify the problem but the solution is still unknown. Of note, other than this problem rest all attachments works fine. Please help me on this. I do use a online USB foot pedal...
Hardware & Devices
Strange issue
Here is a very strange issue that I would value some help with if possible. About a month ago my PC was prone to freezes on bootup. When I eventually got into Windows, the PC would often freeze again resulting in several bootups and system startup repairs etc. I ran several free and paid-for...
General Discussion
Very strange issue.
I have two HDD attached to my PC. Here is my HDD with my C:\Documents and settings\Momchil folder which is my user name on the computer. http://i51.tinypic.com/mlia9c.jpg And here is the exact same folder and directory in the other HDD G:\ which I NEVER attached to my computer!!! NEVER! ...
General Discussion
Have strange diveces not working in device!!manager
what should I do guys?:sarc:
Drivers
Strange device icone !
Hey, look the picture attached ! It's my usb key... i think it's a little strange, don't you ? :confused: How do you think this can happen ?!
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App