Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Huawei E1750 3 Dongle problem

23 Sep 2011   #1
oxenholme

Windows 7 Home Premium
 
 
Huawei E1750 3 Dongle problem

I have a Dell Inspiron laptop Windows 7 Home Premium 64bit

I use Kencomp Radnet Radio broadband - unfortunately after one of the never ending updates from Microsoft this will no longer work as the PPPoE connection gives a 651 timeout error.

As an interim measure I have tried to use 3 Broadband via a Huawei E1750 dongle.

It is problematic - I have to uninstall and reinstall the 3 software every time I want to use the internet.

Is there a way round this?

There is a further problem - it works quite quickly when it works - HSDPA giving good results.
Unfortunately 3 try to force an update to the driver software that results in 3G on the connection dialog box, but it won't connect.


My System SpecsSystem Spec
.
23 Sep 2011   #2
xxxdannyxxx

Windows 7 Home Premium x64 SP1
 
 

Hello oxenholme

This has always been an issue with 3 dongles unless you get it installed correctly first time. Firstly remove 3 connect and the Huawei driver from programs and features list and re-boot.Wait until the pc has fully loaded and insert the modem.If you have autoplay enabled the install dialogue will appear follow the instructions to install, if not open by right clicking the 3 icon on the my computer page and run autoplay.
Now at the end of the installation the three dashboard will appear waiting for you to press connect. Don't, instead remove the modem wait a few seconds then insert again. The drivers will install for a second time, wait for this to finish then click the 3 icon on the desktop to fire it up and press connect.
For some reason the first time you install, windows sees it as a CD drive, don't know why but its always been like that.
As for the update it probably best to download it direct from here and flash the update onto the modem direct - Three - Help & Support - Mobile Broadband.

Once its set up you can set it to start on boot and minimised and it shouldn't bother you again

Danny
My System SpecsSystem Spec
Reply

 Huawei E1750 3 Dongle problem




Thread Tools




Similar help and support threads
Thread Forum
BSOD When Huawei 3G Dongle Plugged in
I have a laptop with Windows 7 Home Premium 64 bit. It gives BSOD when I try to use Huawei data card. The error comes exactly when I click on "Connect" button. I have attached all the files. Please help. Colosalvictor
BSOD Help and Support
BSOD When Huawei 3G Dongle Plugged in
I have a laptop with Windows 7 Home Premium 64 bit. It gives BSOD when I try to use Huawei data card. The error comes exactly when I click on "Connect" button. I have attached all the files. Please help. Ishan
BSOD Help and Support
Problem with USB Wireless dongle
Updated issues: USB Wireless dongle/adapter (Tenda W322U v2.0) Struggles to connect on boot, and extends shutdown time Performs poorly at lower varying speeds (30mb connection: 0.2-7mb/s) when connected Struggles to connect, displaying no/missing wireless access points When connecting to...
Network & Sharing
BSOD When connecting with tmobile huawei e1750
Is Windows 7 . . . - x86 (32-bit) or x64 ? x64 - the original installed OS on the system? zes w7 - an OEM or full retail version? oem vaio - OEM = came pre-installed on system - Full Retail = you purchased it from retailer - What is the age of system (hardware)? unknown, not brand new -...
BSOD Help and Support
compatibility problem between Huawei and win7
I am using window 7 ultimate on my dell notebook. I just purchased broadband data card of Huawei from tata indicom. The system get hanged after using it for 5 to 15 minutes and respond only on doing system switch off. Do we have any solution as the firm's technical person just waisted my time...
Software
Problem with my Huawei modem
Hi,guys ! I've got really serious problem with my Huawei SmartAX MT810 modem on Windows7. I had Windows7 since it's first release in public beta,my modem was working just fine,until these last weeks when it started to turn off by itself :confused:. I formatted my PC to Windows Vista SP1,and it...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App