Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: iomega 1tb external hd wont install

26 Sep 2011   #1
gopher1

windows home 32bit
 
 
iomega 1tb external hd wont install

hi
this is my first post
#i have a iomega external 1tb hd that wont install, ita bout 3 years old.
the 12v power lead lights up the light in the hd but on the pc desktop
my computer it does not now boot up. it worked for the first 2 years and then stopped.
my ac power lead is 12v but maybe not the iomega one that came with it( there all look the same except volts)
can anyone help me to get this working?
rod


My System SpecsSystem Spec
26 Sep 2011   #2
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Hi and welcome to sevenforums gopher1,
so there is nothing showing in "computer"
and nothing showing as installing drivers when first plugged in?

try this....click start button, Right click on Computer and select Manage. On the following screen, click on Disk Management. In the tool bar, click on Action and then Rescan Disks.
My System SpecsSystem Spec
26 Sep 2011   #3
gopher1

windows home 32bit
 
 

hi
i tryed that , thanks
no luck
rescan sees the other hd but not the iomega

rod
My System SpecsSystem Spec
26 Sep 2011   #4
Borg 386

Win 7 32 Home Premium, Win 7 64 Pro, Win 8.1 Pro
 
 

Start with the basic hookup, I'm assuming it hooks up via USB, try switching the USB cord to one you know works & see what happens. Or switch it to another USB port on your PC and see what happens. I have a USB port on mine that "has problems".

If that's not the problem, I found this link, there are several suggestions on this thread you might want to try:

Iomega External Harddrive not found - Hard-Disks - Storage
My System SpecsSystem Spec
26 Sep 2011   #5
rraod

MS Windows 7 Ultimate 64-bit SP1
 
 

Sometimes the USB cable connecting the HDD to the computer gets damaged with excessive usage. It happened to me before.

Try with another USB cable.
My System SpecsSystem Spec
26 Sep 2011   #6
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

have you another computer you can try it out on.
My System SpecsSystem Spec
26 Sep 2011   #7
gopher1

windows home 32bit
 
 
iomega hd not in my computer

hi
yes i have tryed it in pc and laptop no go. the same lead works on other external hds, but i will try another lead tomorrow.

the link you gave have the same problem

rod
My System SpecsSystem Spec
26 Sep 2011   #8
gopher1

windows home 32bit
 
 
iomega hd

hi
i will try a different usb port tomorrow

rod





Quote   Quote: Originally Posted by Borg 386 View Post
Start with the basic hookup, I'm assuming it hooks up via USB, try switching the USB cord to one you know works & see what happens. Or switch it to another USB port on your PC and see what happens. I have a USB port on mine that "has problems".

If that's not the problem, I found this link, there are several suggestions on this thread you might want to try:

Iomega External Harddrive not found - Hard-Disks - Storage
My System SpecsSystem Spec
27 Sep 2011   #9
gopher1

windows home 32bit
 
 

hi
thanks ive found this by quik links ok no probkem

i have tried anoteher lead , anorther power ac cord and another usb socket.

i think i need a driver but wherever i go 4 a iomega external hd driver , im asked to, scan, join, become a memeber and general mucked about with selling stuff
is the w website fro drivers which is hassle free and truely free
iomegm.com only carries new model drivers

rod
My System SpecsSystem Spec
27 Sep 2011   #10
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

rod, i have a 1T iomega also and it didnt have any driver software with it , it was simply plug in and play .im not sure why its not showing but i dont think its driver related.
in fact upon checking i see it has a microsoft driver, which i assume it installed the first time the iomega was plugged in.

-2011-09-27_1801.png


My System SpecsSystem Spec
Reply

 iomega 1tb external hd wont install




Thread Tools





Similar help and support threads
Thread Forum
External Hard disk Iomega 2 Tb recognized by pc but can't be formatted
Hi everyone I'm new here and even though i have been reading a lot of usueful threads , i couldn't solve my problem at all. Well i have an external HDD Iomega 2Tb , that after a while stopped to work entirely. At first i would get "corrupted data " messages on windows 7, but now i can't access...
Hardware & Devices
How to run chkdsk on Iomega networked external hard drive
I tried to run a system image to the "Backup" folder of my Iomega external hard drive three times, without success. The error message asked me to run chkdsk on both the source (my desktop) hard drive and the destination (Iomega) drive. How can I run chkdsk on this external drive? I am willing...
Backup and Restore
Iomega external HD not detected by any computer
Hi! I have an external hard drive of 500Gb from iomega, and it stopped working recentely. It is not detected in Windows 7 and from what I know so far this is what I realised: - It appears on "Device Management" and it says to be working properly - No message of windows on the bottom-left...
Hardware & Devices
iomega eGo External drive and Windows Seven compatibility
Hi, I am thinking about getting an 'iomega (#34836) 1TB eGo USB 2.0 External Hard Drive to replace a much smaller one from a different manufacturer. However, I have read a few reviews where some folks running Windows 7 had some problems getting it to recognize the iomega eGo External Drive....
Hardware & Devices
Windows 7 will not let me access Iomega external HDD
Hi all, I currently have Windows Home Premium 64-bit and seems to be working quite well. However, when I tried to connect my Iomega eGo external HDD to *every single USB port I have on the computer* the computer would "see" the HDD but not register as a HDD that I can access. It will not...
Hardware & Devices
Iomega ego 320 GB external HD not recognized
ok heres the sitch, my iomega hd was working for almost 3 months until last wik my brother borrowed it and plugged it in on a windows xp PC in their school and he said it doesnt work because there was a ballon pop up saying usb device cannot be recognized so i called him to bring it back home to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App