Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WD Internal HD showing as unknown drive

27 Sep 2011   #1
Rick Deckard

Windows 7 Professional 64 bit
 
 
WD Internal HD showing as unknown drive

First post on the windows 7 forums. I recently built my own PC from the ground up and everything was running fine for the past month without any problems. I received a windows 7 professional x64 key through my grad school and decided to upgrade my OS (Windows 7 home x64) and shortly after that I encountered issues with my hard drive. Things ran really slow and then my hard drive just stopped booting and in the RAID configuration screen during bootup it shows the drive as an unknown device. I've tried reformatting the drive or just reinstalling windows and in both cases even with my motherboard's driver disc in, it can't seem to find a driver to read the HD. My system build: CPU: Intel i5 2500k w/ stock fan Motherboard: Gigabyte GA-Z68XP-UD3-iSSD RAM: CORSAIR Vengeance 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Video card: ATI HD Radeon 6870 1GB 256-bit DDR5 PCI Express 2.1 x16 PSU:CORSAIR Enthusiast Series TX650 V2 650W Hard Drives: Western Digital Caviar Black WD1002FAEX 1TB 7200 RPM SATA 6.0Gb/s Intel 20gb onboard SSD Case: NZXT Phantom I've tried searching for fixes to this issue on google and on WD site, but I've never encountered a problem like this before and could appreciate the help. Thanks.


My System SpecsSystem Spec
.
27 Sep 2011   #2
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

I would Check the hard drive with the manufacturer's diagnostic tools.
Hard Drive Diagnostics Tools and Utilities (Storage) - TACKtech Corp.
HD Diagnostic

I personally would stay away from RAID & dynamic partition, as it seems to more problems than it is worth.
My System SpecsSystem Spec
27 Sep 2011   #3
Rick Deckard

Windows 7 Professional 64 bit
 
 

It I'll try out the WD lifeline tool and respond with my results later tonight. Do you think Spinrite could also potentially see/fix any issues?
My System SpecsSystem Spec
.

28 Sep 2011   #4
Rick Deckard

Windows 7 Professional 64 bit
 
 

WD Lifeguard could see the drive but was unable to test it (Multiple SMART errors). I slotted in SpinRite and its currently zero-ing out the entire drive over the next few days. Any thoughts on what could have caused my hard drive to fail in this way so soon after installation? When I upgraded to windows 7 Pro I didn't reformat the disc through bios, but through the windows install disc. Could that have done a bad format/erasure and set up my drive for corruption?
My System SpecsSystem Spec
28 Sep 2011   #5
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

S.M.A.R.T. - Wikipedia, the free encyclopedia
Looks like you need to replace the HD Drive.
My System SpecsSystem Spec
28 Sep 2011   #6
Rick Deckard

Windows 7 Professional 64 bit
 
 

Yep, I'd agree seeing how even if SpinRite fixes it, it will likely fail again soon after. Luckily the drive is under warranty. Thanks for your help theog.
My System SpecsSystem Spec
29 Sep 2011   #7
Mark Phelps

Win7 Pro 32-bit, Win8 Pro 32-bit
 
 

Don't rely on Spinrite to do anything other than buy you some time to backoff the drive contents before it fails for good. Despite Spinrite's claims, it can't actually "repair" a drive; instead, all it can do is migrate data from sectors that perform marginally in testing to other sectors.

Your problem is ironic, in a way, because I've been using WD drives for years, and then a few days ago, one of my WD drives in my home server started failing. I ran the WDC utilities against it -- and they failed, saying they were unable to repair it. I've since replaced it with a Seagate drive.
My System SpecsSystem Spec
Reply

 WD Internal HD showing as unknown drive




Thread Tools




Similar help and support threads
Thread Forum
WD Internal Hard Drive (Partitioned) showing 'Directory Corrupted'
HI Ladies and Gents, I have had this issue with the WD Internal HD and it seems its on its way out. I have taken some screen shots below to help you see the problem, but it is basically saying 'Directory Corrupted or unreadable'. I have A LOT of information (personal/ work) on there that I...
Hardware & Devices
Help Upgrading 1 TB Internal to 2 TB Internal Hard Drive
So my 1 TB internal hard drive has less than 30 GB of space and I want to upgrade to a 2 TB internal so I can hold more of my games on it. How would I be able to transfer every single thing from the 1 TB to the 2 TB?
Hardware & Devices
Adding Internal Hard drive, Not showing
I have a dead laptop, I believe it was the hard drive, anyway. I took the hard drive out, connected it to my Network computer, all looks well, I heard it spinning (Good sign?) and then I booted the computer, it didn't actually load windows 7, it spent like a good 10-15mins saying "Loading windows...
Hardware & Devices
Unknown Drive showing up in My Computer -- Hot Swap bay error?
Hey guys, I've had this issue before, and the only way I was able to resolve it in the past was when I reinstalled Win7 when I got my new SSD. I just noticed it today, but there is an extra drive in the My Computer window, I use TrueCrypt as well as a hot swap bay for a SATA drive. When I try...
Hardware & Devices
Internal SATA drive showing as "ejectable"
I have the "Safely Remove Hardware and Eject Media" icon in my system tray. One of my drives, a WD20EARS (WD Green 2TB) is listed there. I want the icon to go away since I obviously have no need to eject the drive. How can I stop Windows from thinking it's a drive that's ejectable?
Hardware & Devices
Second internal drive not showing up
I have two internal drives the C drive as my system drive and another I named M (for music) which is basically a backup drive. A year ago when I installed Windows 7 Home Premium is also the time I set up the M drive (both drives are about a year old). I haven't had a bit of trouble until I just...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App