Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External hard drive won't eject

03 Oct 2011   #1

7 x128 biz
 
 
External hard drive won't eject

Hello all,

I've got a Seagate Free Agent Pro external drive (currently connected via eSATA), which solidly refuses to disconnect from the system, using the "safe disconnect" dance.

Whenever I try, after a pause I get the error message: "This device is currently in use. Close any programs or windows that might be using the device, and then try again." I have tried closing just about everything down, but the message still appears.

My question to all the MS gurus out there is as follows:

1) Is there a way to tell if my drive is actually in use? Can I tell which program is using the drive?
2) Can I force-disconnect the drive in such a way that any pending writes are completed? (i.e., not just disconnecting the cable and hoping for the best)

Before you ask, I did look for device-specific drivers on Seagate's web site. No luck. There's some disk management utilities to help manage backups and/or syncs, but no drivers.

Thanks for your help and time,
~ Paul

My System SpecsSystem Spec
.

03 Oct 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Hello paulprogrammer. Welcome to the forum.

The 'easy' way is to simply restart or shut down the computer. All proccess and handles will be terminated during shutdown.

The better way is to fix it as described here:
Problem Ejecting USB Mass Storage Device

Hope that helps
My System SpecsSystem Spec
Reply

 External hard drive won't eject




Thread Tools



Similar help and support threads for2: External hard drive won't eject
Thread Forum
How to eject an external eSata drive? Hardware & Devices
Solved unable to 'safely eject' my new external drive. Hardware & Devices
Unable to eject WD portable hard-drive Hardware & Devices
My external drive is missing when I try to remove or eject Hardware & Devices
Solved Can't eject USB connect external hard drive Hardware & Devices
Cannot eject hard drive. Hardware & Devices
External USB HDDs being treated as internal drive (cannot eject) Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:30 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33