Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow SSD Boot with long OtherKernelInitDuration delay

01 Nov 2011   #101
nyto

Windows 7 Home Professional 64 bit
 
 

Last night I decided to defrag my HDD with Smart Defrag 2 and it apparently did something to fix my boot times.

BootTsVersion 2
BootStartTime 2011-11-01T15:00:58.687500000Z
BootEndTime 2011-11-01T15:02:45.402343700Z
SystemBootInstance 717
UserBootInstance 702
BootTime 29322
MainPathBootTime 10922
BootKernelInitTime 19
BootDriverInitTime 440
BootDevicesInitTime 911
BootPrefetchInitTime 0
BootPrefetchBytes 0
BootAutoChkTime 0
BootSmssInitTime 3169
BootCriticalServicesInitTime 631
BootUserProfileProcessingTime 480
BootMachineProfileProcessingTime 1026
BootExplorerInitTime 1143
BootNumStartupApps 21
BootPostBootTime 18400
BootIsRebootAfterInstall false
BootRootCauseStepImprovementBits 0
BootRootCauseGradualImprovementBits 0
BootRootCauseStepDegradationBits 0
BootRootCauseGradualDegradationBits 0
BootIsDegradation false
BootIsStepDegradation false
BootIsGradualDegradation false
BootImprovementDelta 0
BootDegradationDelta 0
BootIsRootCauseIdentified false
OSLoaderDuration 3074
BootPNPInitStartTimeMS 19
BootPNPInitDuration 1002
OtherKernelInitDuration 84
SystemPNPInitStartTimeMS 1077
SystemPNPInitDuration 349
SessionInitStartTimeMS 1436
Session0InitDuration 1516
Session1InitDuration 247
SessionInitOtherDuration 1405
WinLogonStartTimeMS 4605
OtherLogonInitActivityDuration 3666
UserLogonWaitDuration 4764

I don't know what it did but it worked so I'm not complaining.


My System SpecsSystem Spec
.
15 Feb 2012   #102
Gantless

Windows 7 Professional 64-bit
 
 

I realize this is an old thread, but I had a similar problem to Raillex's. I noticed a boot delay with an SSD boot drive and a Seagate HDD for data. I was seeing boot times around 17 seconds at first. Because I was setting up a new system, I didn't pay attention when the boot times increased to about 40 seconds because there were many reboots required for updating drivers and such. But the boot time remained over 40 seconds after the setup, so something was wrong. After searching off and on for months, I finally found this forum. I looked back at my Event Viewer's performance logs from August 2011 (when I assembled the computer) and saw the SessionInitOtherDuration during boot took about 25 seconds.

I had also performed an image of the SSD using Windows Backup after everything was configured and stored this on the Seagate HDD data drive. The time stamp on that backup folder is Aug 26, 10:20pm. The boot at 10:09pm (before creating the image) shows SessionInitOtherDuration at less than 1 second. Starting with the next reboot at 11:45pm, I had a 25 second delay with SessionInitOtherDuration. In my opinion, this is a pretty good implication that Windows Backup is doing something to cause this problem.

I was going to try the Clean with Diskpart Command solution mentioned earlier in the thread but decided first to try removing the "System Volume Information" folder and the folder where my image backup was stored from the HDD. I had to move the HDD to a different machine. Then I had to play with permissions and run a command prompt as an administrator to delete the folders. But, after reinstalling the HDD in my main system, the boot delay is gone! SessionInitOtherDuration is back to around 1 second without having to copy all the data off the drive first.
My System SpecsSystem Spec
16 Feb 2012   #103
Raillex

Windows 7 Home 64bit
 
 

Either both of us committed the exact same "user error," or maybe, just maybe, there's something to our theory regarding Microsoft Backup. What I do know is that I've used the free Acronis True Image program several times since my last post and never experienced a boot delay issue.
My System SpecsSystem Spec
.

16 Feb 2012   #104
gregrocker

 

Add it to the list of other problems with Win7 Backup Imaging. It definitely needs improvement.

Acronis is a good alternative with a free version available if your have any WD or Seagate HD's in the mix. Otherwise Macrium Reflect seems to be the top choice around here.
My System SpecsSystem Spec
Reply

 Slow SSD Boot with long OtherKernelInitDuration delay




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Long delay during boot on Dell Dimension 9200 with RAID set to SATA ON
History: Two Dell Dimension 9200 Desktops: Machine 1 BIOS set to "SATA ON" and thus benefitting from AHCI Machine 2 BIOS set to "RAID Autodetect / ATA" I want both machines to use "SATA ON" so on Machine 2 have made appropriate change in BIOS and done a clean install of Windows 7 64...
Performance & Maintenance
Slow boot - long OSLoaderDuration
I started having excessively long boot times ~ 4 months ago. Using Event Viewer, I noticed that the OSLoaderDuration went from ~6 seconds to ~63 seconds. I made no hardware changes around this time frame. OS: Windows 7 Professional 64bit CPU: AMD FX8350 RAM: 16 GB Disk: Intel 335 240GB...
Performance & Maintenance
How Can I Fix Long Monitor Startup Delay
My monitor remains in powersaver mode until windows logon screen comes up. This started happening a while ago and i have been putting off asking baout it. I have searched google but have found no answers. I am unable to browse bios or anything and it is really annoying. Primary Monitor (Monitor...
Hardware & Devices
Win 7 x64, Long delay in launching All Applications
Problem solved, caused by Avast 7, fixed by installing latest Avast 7 RC(Beta 7.0.1412) Hi, I am using Windows 7 x64 on a pretty fast machine(2600k, 8GB RAM, GTX580), and suffering from a very weird problem, this problem appears only on a fresh install of Win 7, it was fine on my previous...
Performance & Maintenance
Long Delay Between POST and OS Integration
This is probably an Intel problem but since Intel no longer supports my MoBo, here goes. Intel 82801GH I/O Controller Hub (ICH7DH) SATA Controller in IDE mode. W7, SP1, Home Premium, 32 bit. Plextor DVDR PX-L890A ATA Device. HD and CD-ROM both connected to black connectors on Intel D975XBX2 MoBo....
Hardware & Devices
Incredibly long delay from long on to desktop
I just installed a clean version of Win 7 Pro on my Thinkpad X200. Everything is great except for one small problem: there is a 25-30 second wait between the time i enter my logon pw and the time my desktop appears. This is highly unusual for several reasons. First, it doesn't "appear" as though...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:05.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App