Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB keyboard and mouse do not work once Windows starts


20 Oct 2011   #1

windows 7 64 bit Home Premium
 
 
USB keyboard and mouse do not work once Windows starts

Were working fine yesterday. Today I return home and find computer had mysteriously turned itself on. Mouse not working but keyboard allows me to try to shut down. Taking very long time so shut down with power button.

Now my keyboard and mouse both do not work on Windows login screen. Same for safe mode. Before this, in BIOS, other screens can get to by holding down keys as computer starts, keyboard works.

As Windows loads, can see keyboard illumination switches off. Same for mouse laser. My other USB peripherals (extra HD and wireless thingy) still have lights on. Fairly new computer. Cost me £300 new about 6 months ago.

I tried to 'roll back' Windows - there was only one option - for when I installed Itunes maybe a week ago, but that failed.

I chacked inside and outside the case to see if there's any sockets for PS/2 keyboards, but there aren't any.

Any idea what's going on? Thanks for any help.


My System SpecsSystem Spec
.

20 Oct 2011   #2

MS Windows 7 Ultimate 64-bit SP1
 
 

If you can not open the BIOS screen with USB keyboard, use a PS/2 keyboard for the setting.

Open the BIOS screen and enable Legacy support for USB keyboard and mouse. This should do the trick.
My System SpecsSystem Spec
20 Oct 2011   #3

windows 7 64 bit Home Premium
 
 

Thanks. The keyboard works fine in BIOS though. It stops working once Windows loads. I have tested 2 USB keyboards. With illuminated keyboard, can see lights go out when Windows loads too.

Looking in BIOS, I can see no option to toggle legacy keyboard support, but if I go to Advanced->USB Ports, I can see that it says "The USB keyboard connected to a disabled USB port can still be used for <F10=Setup> entry if no PS/2 keyboard is available.

In the list of USB ports, 0-9 are enabled. I did have a USB adapter plugged into 1 of the 7 ports on my computer, with 4 outputs, taking me up to 10 ports. This has been in my computer for ages and worked fine. Is this likely to be a problem?
My System SpecsSystem Spec
.


21 Oct 2011   #4

windows 7 64 bit Home Premium
 
 

I've got some ideas to try. Please say if they are stupid or if you have better ideas. If not I'll probably go buy the stuff tomorrow and have a bash.

1) Get an adaptor USB to internal hard drive, take out my drive, plug it into my netbook, copy all my important stuff across.

Then try, assuming that such cards exist at Maplin:

2) Get a card to give me ps/2 slots, and get some ps/2 to usb adaptors to plug my keyboard and mouse in bypassing the usb ports, then hopefully get into Windows and do something to fix the drivers! Perhaps this way i can burn some recovery discs and do a repair install.

failing 2) maybe

3) Reset to factory settings (there is an option to do this if i press f11 at startup), then set up my computer all over again. This will probably be a massive pain the the ass and I don't want to do it unless i really have to.


Secret option 4) Repair install. Not sure how to do this. I hear this might require disks, which I don't have. Is it possible to repair install from the recovery partition?

Secret option 5) something to do with linux. I heard you can get a disc that will load linux, and you can then mess around with your windows files. If I knew which bits to delete maybe I could do that. I don't really know which bits i should be messing with so maybe i should skip this.

If I don't let you know how I got on tomorrow, assume I've screwed up my netbook too!
My System SpecsSystem Spec
21 Oct 2011   #5

Windows 7 Professional SP1 32-bit
 
 

What kind of BIOS do you have? See if you can find an option called EHCI Hand-Off or similar; it's related to the USB port controller settings so you'd find it in that same area.

If you find this setting, is it enabled or disabled? Try changing that setting and rebooting. (If that has no effect, change it back to what it was before just to avoid introducing another unknown variable into your repair efforts.)
My System SpecsSystem Spec
22 Oct 2011   #6

windows 7 64 bit Home Premium
 
 

The nearest I can find to "ECHI hand off" is SATA1 Controller Mode, which is set to [ACHI] and can be set to [IDE]. I think this has something to do with the hard disk and am wary of messing with it. The options in the "USB Ports" menu don't give any option to switch to USB 1.

Learned how to put Ubuntu on a pen drive, boot that and access my files. I have backed my important files up now, so if I break it it's not the end of the world. Next I'm going to have a stab at changing the Windows USB drivers using Ubuntu.

UPDATE 24/10/11
I went with a factory reinstall in the end.

I tried copying some drivers from my good computer and that failed.
I made a bootable USB drive with Windows on it, but it turned out to give the same options as pressing F11 whilst loading - i read somewhere to actually do a "repair install" you have to be in Windows.

Maybe there is a way to get out of my predicament by changing the right files, but I've already spent a weekend on this. Still need to reinstall everything, (and uninstall a lot of crapware) but in the grand scheme of things, that's not a massive hardship.

WHY MANY POSTS IN THIS POST?
When I tried to post, got message: "Quick Reply The following errors occurred with your submission
    1. Your submission could not be processed because the token has expired.

      Please reload the window.
"
I reloaded but still did not work.
My System SpecsSystem Spec
29 Jul 2012   #7

Windows 7 Home Premium
 
 

Re: USB keyboard and mouse do not work once Windows starts

Hello,

I just wanted to let u know, I had this same issue for about 2 weeks. Basically what happened was a bad install of my AMD Chipset drivers. When I attempted to upgrade, the install didn't go all the way through.
I then restarted my system, and BAM! No Mouse or Keyboard functionality thru USB.

Even when I went into SAFE MODE the Mouse and Keyboard were not functional. The only time they worked was when the computer first attempted to start, BEFORE windows loaded.
So, this means that your issue is a software problem.

I thought it was some other software that I installed, and ran a restore session, but that wasn't the issue. Still no functionality.

I even tried removing my CMOS battery, to reset it, since some people said that had solved their problems...Still nothing.

I then read other forums around the web using my Android phone to try and find a solution, only those solutions were no help.

I was also advised to run: MSCONFIG and Hide all Windows programs and then stop every other driver, source from loading (of course if my mouse and kb worked, I would have tried that).

I had even read that because I was using USB, that I should try using a PS/2 Mouse and Keyboard connection.

It took me 2 weeks to get the correct PS2 adapter that worked, which would essentially allow me access to my system again...

I Purchased a USB A Female to PS2 (MDIN6) Male Adapter (for Mouse) from SFCable.com

This my friends, was a lifesaver. I only have one PS2 port on my system, so I used my mouse to try every option I had previously read about. Of course you cannot type because the keyboard doesn't work, so you need to know the location of the folder where the programs you are trying to run are.

So, a little after I got back into my system, and I closed down all programs, the warning screen came up that ALL of my USB Ports failed and could not be updated. I even Uninstalled every last USB port from the System Properties and restarted, and still that didn't work.

I had forgotten that during the time when this problem arose, there was a failed install of my AMD chipset drivers, so luckily I had not deleted the source file and I tried to reinstall, and VIOLA! I'm back up and running and my USB ports are restored and everything is working!


I hope this solution is able to help other people out there.

Thanks,
JE - Gemini365@GMAIL.COM
My System SpecsSystem Spec
10 Apr 2014   #8

Window 7 Home Premium - 64bits
 
 
"Mouse and Keyboard work in Bios, wont work in Windows"

SOLUTION YOU WOULDN'T EVEN CONSIDERED IN A MILLION YEARS, BUT IT WORKS PERFECTLY!

This same problem got me crazy while i was installing Window 7 at a new 4TB HDD. If I had a gun on hand, I probably would have shot someone just to feel a little bit better. I was so frustrated I have tried everything and anything that you could possibly imagine, plunging & unplugging million times, setting BIOS USB legacy "ON" / "OFF" million times, restarting the computer two million times, updating BIOS, using PS2 mouse / keyboard, using brand new mouse and keyboard, re-installing Window. THEY ALL FAIL!

I read every forum that I could possibility find on the internet, same suggestions over and over again, some even go extra length to remotely control their PC and change or delete some software setting or coding, so complex that I don't even know what they are doing, I doubt if they do either. And somehow after hours of reading those forum, NO ONE - I MEAN NO ONE ON THIS PLANET EARTH could possibly answer this seemingly simple enough question directly, just for the malfunction of a little mouse and a keyboard. (which may be the simplest component on a desktop except for the little CPU fan or LED light i guess Not even those computer geeks or IT engineering, everybody just "Guess", guessing what the problem was and making suggestions.

This so often asked question found on the internet and no one have ever solved it and gave a directly answer ?
I don't even need an explanation, just a solution to this stupid problem, still but i can't find one!

Frustrated enough, I stared at the light of the mother board which was still on while I had already given up and switched off the computer. Something suddenly hit my mind, an idea, a strange idea that probably not even making any sense to anybody, but it came up. " What if I turn off the POWER of the power adapter as well, wait until the light of the mother board goes out and restart to see what happen? But lets be honest, it doesn't matter right? What difference does that make between keeping the adapter power on or off with the malfunction USB port or mouse or keyboard ? On top of that, it wasn't even a hardware problem anyway, those mouse and keyboard just work perfectly fine with other laptops or desktop except this stupid one ! As the title already said "Mouse and Keyboard work in Bios, wont work in Windows" The malfunction must has everything to do with bugs of window or software or BIOS or anything beside this ! "

Well, it doesn't cost me anything to try, fxxk it, lets do it ! At that time, the installation process of Window 7 was almost completed except the last step - entering the key. But you know, after (but not before) the stupid BIOS screen, when it hit the Window screen, everything stopped working, every time, every single time BUT NOT THIS TIME. Holy cow ! What the heck is going on ? After all those logical and reasonable trials suggested by everyone, it all came down to THIS ONE ? Are you kidding me ? Trust me, both the mouse and keyboard did not work during million times of trial and it worked right away after this one. I was like discovering the ultimate formula to cue Cancer you know. It is just amazing!

Frankly speaking, I just have basic PC knowledge and I don't know why this works or how this works, BUT IT WORKS! My "guess" is: the power adapter and the mother board seems to have some sort of voltage or current problem which makes the USB ports not working with any USB devices. Power supply is fine, but those device just do not work properly, maybe the current is too large or something which interfere with the programs or common softwares which pre-installed at Window for basic components like mouse or keyboard to work. Another guess is: the mother board seems to have some kind of memory of something, once those mouse and keyboard malfunction for the first time, it doesn't matter how many time you plug or unplug them, the problem just stay put. I noticed that the light of the keyboard is still on after the Window screen, and one time, i continuously pressing the "Cabs" button again and again during those switching screen to see when it failed. After the Window screen started, the Cabs LED light had been switched on just in time so it didn't go off. After I unplugged the keyboard and plugged in again, the Cabs LED light was still on, as if I haven't unplug it at all, time and time again. Logically, it should have turned off after I unplugged and plugged in again, maybe just the "Num" LED light on, but not the "Cabs" LED light. It's as if there is a memory of the same error somewhere saved within the desktop.

There you go, THIS IS IT ! THIS IS THE ANSWER ! If you do enjoy this story, I know you are pretty messed up and frustrated by this problem too. That's why I am here right now, just to release the pain and also help any one who is tortured by this stupid problem and looking for AN ANSWER.

If some IT or computer genius could tell me what is really happening underneath, I would be very much appreciated!

Sincerely,
Little Joey from Hong Kong
My System SpecsSystem Spec
Reply

 USB keyboard and mouse do not work once Windows starts




Thread Tools



Similar help and support threads for2: USB keyboard and mouse do not work once Windows starts
Thread Forum
Solved Mouse and Keyboard do not work at start up, takes 1-2 mins Hardware & Devices
Keyboard and mouse won't work on welcome screen Hardware & Devices
After messing with msonfig, my mouse and keyboard won't work! Performance & Maintenance
Keyboard and Mouse Drivers do not work on Image Deployment Drivers
keyboard and mouse don't work Hardware & Devices
KeyBoard & Mouse doesnt work Hardware & Devices
mouse & keyboard wont work Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:11 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33