Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WD external HD recognised as

30 Oct 2011   #1
amrius13

Windows 7 Ultimate x64
 
 
WD external HD recognised as

Hi everybody,

I have a weird situation on an w7 x64 OS. I have 2 Western Digital My book essential external hard disk (1TB each) and they are not both correctly recognised by the OS. They are both detected but one of them is recognised as CD Drive.

I have another 2 internal hard disk - one is partitioned in 2 partitions (C & D), the other has one single partition (E). One of the external HD is correctly recognised as HDD (letter assigned J), but the other external HDD (which has 2 partitions - H & I) is recognised as CD Drive - please see attached screenshot.

It is not a problem related to formatting as both external HDD have been formatted in NTFS. Actually, if I disconnect the external drive that is correctly assigned (J), the other external HDD becomes available as HDD with both its partitions.

Please advise if it has to do with letter assignment or w7 has a maximum no. of partitions recognised as HDD?

TKS.




Attached Thumbnails
WD external HD recognised as-w7-ext-hdd-error.png  
My System SpecsSystem Spec
.
30 Oct 2011   #2
seavixen32

Windows 7 Ultimate SP1 64-Bit
 
 

Welcome to Windows Seven Forums.

Please post a screenshot of your Disk Management layout so that we can see how your partitions are configured.

You can have up to four primary partitions on each hard drive, and then create logical partitions within the fourth primary partition if you need more.

As for your WD external drives, you could try changing their drive letters to say, X and Y, so that they are well away from your internal hard drives.
My System SpecsSystem Spec
30 Oct 2011   #3
amrius13

Windows 7 Ultimate x64
 
 

Hi, thanks for reply. Changing the drive letters doesn't help.
I attach a print scr. from the disk management page.


Attached Thumbnails
WD external HD recognised as-disk-management-1.png  
My System SpecsSystem Spec
.

30 Oct 2011   #4
SledgeDG

Windows 7 Ultimate x86
 
 

it's not about any drive letter limit it goes from A to Z (beginning with C for harddrives)
I would say only one drive is recognized. Unplug them and try to plug them back in, in the opposite order one at a time.

BTW: Did you ever open one of those "CD drives" to see what's in there?
It has( amongst others) a file called "What is this.html" which starts out like this:

Quote:
About the Western Digital® SmartWare™ Virtual CD


The WD SmartWare Virtual CD (VCD) included on your WD hard drive mimics an ordinary physical CD that is indistinguishable to your hard drive. The WD SmartWare VCD contains the software you need to start using the WD SmartWare software to organize, back up, retrieve, and secure your files as well as other essential information, and has the additional benefit of avoiding wear and tear, damage, or loss of a physical CD.

In addition, updates to the WD SmartWare VCD, when available, are automatically downloaded from the web to your drive so you don’t have to wait for the arrival of a physical replacement CD.
-DG

Edit: Oh we cross-posted you just posted the screen print and see drive 2 is shown as offline
try the replugging (directly into the computer if you can)
-DG
My System SpecsSystem Spec
30 Oct 2011   #5
amrius13

Windows 7 Ultimate x64
 
 

Hi, on the "false CD Drives" there is the file you mentioned.

However I managed to get the external HDD online by right clicking it - so this has fixed the problem, everything is showing as it should except the 2 WD CD drives which are still present in My Computer drives list. However this is not actually an issue, as I managed to get the 2 external drives to work simultaneously. Thanks a lot for help !
My System SpecsSystem Spec
Reply

 WD external HD recognised as




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
External IDE HDD not recognised by OS.
I have an old IDE 100gb HDD which was installed in an external enclosure. Everything was fine till I cloned the OS from a new SSD to it for backup using the EaseUS Todo Backup Free 7.5 programe. When complete the following messages showed. "Failed-Partition Clone-)x1760E077"; Partition Clone...
Hardware & Devices
External HDD not recognised by comouter
Hi, I just had an upgrade to my computer. I had a HDD installed replacing 3 older drives. I need some of the information on the older drives so instead of purchasing 3 sata enclosures I purchased a docking station. But my problem is the computer does not see any of the drives in the docking...
Hardware & Devices
OS in external harddrive not recognised
hello! folks! straight to the point, my computer was f'ed up last week.boot mgr is missing in my hard drive and what i did was installed a new OS into an external harddrive with my laptop by this process How To Install Windows 7 On USB Flash Drive or External Hard Drive and everyhting was...
Installation & Setup
Buffalo HD-PET640U2/R-EU external HDD not recognised
Buffalo HD-PET640U2/R-EU Hello. I've been having problems with the above drive (similar to this previous thread). I've had the drive for about a year & a half. It worked fine (on Win XP Home) up until a few days ago, when I connected it to my new laptop (Win 7). On connecting, a...
General Discussion
External Hard drive not recognised
Hello everyone, Once again i need your help. I have an external hard drive, and a lot of data saved on it. My laptop recognises it, but i can't access it. When i go to device manager and try intialize, it says it is not ready. Thanks for ur help
Hardware & Devices
External Hard Disc not recognised
I have 2 external hard discs which I use for back up purposes. Both are on the hardware compatibility list: Iomega 1 Tb drive connected via usb (no lights and completely dead) Seagate 160 Mg Freeagent classic (power seems to come on when connected via usb) After installing Windows 7...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 20:03.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App