Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: How do I change the name that shows up as the device name in autoplay?

13 Nov 2011   #1
HowardWoodard

Windows 7 Professional 64 bit
 
 
How do I change the name that shows up as the device name in autoplay?

Yesterday I updated my and my wife's iPhones to 5.01 -- now that is a nightmare story in itself. I could never get it to work on my PC -- simply would not install the mobile device drivers no matter what I tried. I was able to update both phones on another Windows 7 PC we have.

Now, when the original PC detects my iPhone and pops up autoplay it has the device name for my wife's phone. The phone itself shows that it is configured with the correct name.

Where does Windows 7 pull the device name from? It has the wrong name in the device properties General tab but even though I can select the field and select the text in it I cannot change it.

Thanks in advance,

Howard


My System SpecsSystem Spec
.

13 Nov 2011   #2
badger906

Windows 7 Ultimate x64, & Mac OS X 10.9.2
 
 

should be able to right click on it in my computer and change it under properties.

my 16gb usb stick is still called "adamspoosti" my friend she tried to end it with stick, but ran out of letters lol
My System SpecsSystem Spec
14 Nov 2011   #3
HowardWoodard

Windows 7 Professional 64 bit
 
 

Hi and thanks for your reply. I didn't make it clear in my first post but I'm unable to change the device name in properties. The field show up, I can place the cursor in it, I can select the text, but nothing happens when I type. It will not let me change the contents. I can change the name of all other devices just as you say.
My System SpecsSystem Spec
.


14 Nov 2011   #4
badger906

Windows 7 Ultimate x64, & Mac OS X 10.9.2
 
 

Maybe its another one of IOS's restrictions.

Unless its showing the same name in itunes? As you can name the phone there.

My System SpecsSystem Spec
01 Jan 2012   #5
diek

Windows 7 Ultimate 32bit
 
 
Following

I am having the same problem.
My System SpecsSystem Spec
01 Jan 2012   #6
diek

Windows 7 Ultimate 32bit
 
 

The fix can be found at the following link, wrong-iphone-name-showing-my-computer-4.html
"Type regedit into your search bar and bring up Registry editor. Go to the the very top with My Computer. Now go to Edit and Find. Type in the whole offending name that is bugging you, i.e. Soandso's iPhone and hit find. After it searches your registry and finds the first name select it and Edit the Name. I copy/pasted it for all the next steps. After you have found the first name don't stop there. Use F3 to find next Name in registry and So on and so fourth until you have replaced every offending name in your whole registry with the Name you want to show up i.e. Tom's iPhone or whatever? Repeat all of these steps if you have more than one name showing up in your devices? Worked 100% for me. Close regedit and reboot (very important for changes.) Plug your iPhone back in and enjoy all your names back to normal."
My System SpecsSystem Spec
28 Jun 2012   #7
HowardWoodard

Windows 7 Professional 64 bit
 
 

Sorry. Even though I followed this advice I failed to provide feedback or an update.

It worked. ...but I don't know why. Doesn't it get these names from the phone itself and doesn't it associate that name with the phone's specific hardware ID?


Sent from my iPhone using SevenForums app
My System SpecsSystem Spec
28 Jun 2012   #8
UnknownReverent

MS Windows 7 Professional 64-bit SP1
 
 

It should get the name of the phone from what you set it in iTunes when you hook it to the computer.
My System SpecsSystem Spec
Reply

 How do I change the name that shows up as the device name in autoplay?




Thread Tools





Similar help and support threads
Thread Forum
Autoplay device not found
Inserting a CD/DVD pops up with E\ not found But the CD/DVD drive E shows the complete list with contents. In the Configurationscreen Autoplay for all devices is put to autoplay standard settings WMP (for audio) A CD/DVD with for instance programs or random data shows correct the list with...
Hardware & Devices
Autoplay....how to change default photo download location
Hi, I wonder if anyone could help me with an issue that is driving me a bit bonkers? When I first plugged in our camera into the wife's laptop (Windows 7 Home Premium x86), and it started downloading photo's, I was able to temporarily cancel the process and nominate a new location to which...
Hardware & Devices
Portable devices not listed in Autoplay option . Won't pop autoplay.
Hi I have protable device that won't autoplay when plugged , but it is shown in my computer and it's fully functional , it is not visible in the Autoplay option in the control panel , I tried reinstalling the device , but same thing , I followed Shawn's topic , how to set autoplay for...
Hardware & Devices
NAS shows up as media device?
Ok I have a NAS from airlink and it was working fine on my laptop with windows 7. Then at some point it stop showing up on my laptop, but I was still able to access my NAS from my XP Pro desktop. I used the config utility to change the network name on the NAS from HOMEGROUP to MSHOME and now I can...
Network & Sharing
wd green1.5tb shows up in device manager, but nowre els
Installed a 1.5tb wd caviar green i bought on boxing day today hd is detected in bios Started up windows, windows automatically detected and installed the driver, but i dont see the drive in explorer. I can see the drive in the device manager but it is not even detected by the westerm...
Hardware & Devices
printer shows up as Unspecified device??
hi all, just installed win 7 on the new HD. epson printer installed fine. my okidata, using the latest downloaded 64 bit driver, shows up in the "unspecified" devices category instead of in printers. unusable as it will not show when i try to print. tried multiple install/uninstalls. how to get...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App