Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Western Digital drive showing up with Unallocated in disc management

24 Nov 2011   #1

Windows ultimate x64
 
 
Western Digital drive showing up with Unallocated in disc management

Hi Guys,

So it was working fine until one of the latest windows auto update, i turned off my computer and went to bed, when turned it on the next morning the drive was no longer showing up so i checked disc management and it was in there as unallocated, the only options that are there when i right click are: Offline, Properties and help.

Im running Windows 7 ultimate x64 on a sony vaio VPCL118FG and the External Hard Drive is a Western Digital 2TB Model WDBAAU0020HBK

I really don't want to reformat it as i have all my invoices for work along with everything else on it.

Thanx for the help in Advance.

My System SpecsSystem Spec
.

24 Nov 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 SP1, Home Premium, 64-bit
 
 

Go to Western Digital website and download their disk utilities for that particular hard drive.

Run the utility and see if it reports any problems.
My System SpecsSystem Spec
24 Nov 2011   #3

Windows ultimate x64
 
 

I did that last night and it gave me the green tick that the disc was ok
My System SpecsSystem Spec
.


24 Nov 2011   #4

Windows 7 32 bit
 
 

I would run the restore point to roll back the update. It either messed up your system or it's one hell of a coincidence. If it doesn't fix it you can always update again.

edit: before that though try unplugging and plugging the external. It's not uncommon for a USB socket to get a flaky connection.
My System SpecsSystem Spec
24 Nov 2011   #5

Windows ultimate x64
 
 

Ye I'll try the restore tonight when I get home from work, I tried it on my laptop also and same thing.
My System SpecsSystem Spec
24 Nov 2011   #6

Windows 7 Home Premium 32 bit
 
 

When nothing else helps, have a look at my post and thread Regain a lost drive using Test Disk - An Illustrated Guide where I had actually made my external HDD "unallocated" and then recovered the partitions with Test Disk.

Also check before that whether some other OS can see your external drive. Not very difficult. Lucid Puppy way to recover files from a non-bootable computer Run Lucid Puppy from the pendrive and check.
My System SpecsSystem Spec
24 Nov 2011   #7

Windows ultimate x64
 
 

so far test drive is going good but because it hasnt been partitioned once the search is done it just gives me the options to add partition or load back up
My System SpecsSystem Spec
24 Nov 2011   #8

Windows 7 Home Premium 32 bit
 
 

You need not have two partitions. ( I had two and hence it showed two) If you had followed the steps correctly TestDisk should show the full drive (one single partition in your case) - the seventh Window in Part 1 of my write up. You will select that only partition press Enter and in the eighth Window select write and enter. That will write the partition table.

Other than that do not enter any command like add partition etc.,. You could have gone astray somewhere. Press Quit, Quit and Quit till you get out, or close the window, start again and repeat the steps carefully.

Fiirst, second, third and fourth Window in Part 1, fifth, sixth, and seventh Window in part 2 should be the sequence.

For the sake of clarity, I shall list the screens again in brief - which itself is going to be long and I had to rerun Test Disk many times to get a grip again. :

Run Test Disk as an administrator

First Screen: No Log > Enter

Second Screen: Select your external drive > Proceed > Enter

Third Screen : INTEL > Enter

Fourth Screen: Analyse > Enter

Fifth Screen: Here I envisage three possibilities.

a. Your single partition is shown with an * prefix (Test Disk has already found a bootable
partition)

b. Your single partition is shown (without any prefix ) and the message No partition is bootable

c. Only the message No partition is bootable

Irrespective of what is shown on this screen, (select the partition if shown) Quick Search > Enter

Sixth Screen: If you do get this screen it will be "Partition created by Vista or Later?" Press Y

If you do not get this screen, you will straight away get the seventh screen.

Seventh Screen: Your single partition should show up with an * prefixed. It should also say "Structure OK .............. Keys: A - add partition L- load backup...... P - list files Enter to continue."

You will only press Enter.

Eighth Screen: Write > Enter.

This will write the partition table and you will be asked to reboot. Hopefully your drive should be readable in Windows.

If in the seventh screen you type P then it will list all the files in the partition which you may be able to copy to another external drive. ( For this you must have connected another external drive before you started this process. Rerun Test Disk and do it.) I had done this when I did the trial, but cannot recollect the screens now. It is very hard to remember. You have to read each screen and do accordingly. If you have any doubts read the documentation on the Test Disk website and try to understand as much as possible.

You can repeat this procedure any number of times as long as you take care not to give any other write command except the Write Partition table command in the seventh screen.
My System SpecsSystem Spec
02 Jul 2012   #9

windows 7 ultimate 32 bit
 
 

hi every body
Ive the same problem with my WD passport
but at the fifte screen check disk shows: "partition: Read error"
I enter search to find partition but after a long long time it finds nothing!
I dont know what to do
My System SpecsSystem Spec
09 Nov 2012   #10

Windows 7 Ultimate x64
 
 

Thanks for the solution,
but unfortunately I have the same problem that "payman" has..

it shows me "partition: read error"

please help I have very important data
My System SpecsSystem Spec
Reply

 Western Digital drive showing up with Unallocated in disc management





Thread Tools



Similar help and support threads for2: Western Digital drive showing up with Unallocated in disc management
Thread Forum
Western Digital 2TB internal drive prices Chillout Room
WD Passport drive showing up with Unallocated in disc management Hardware & Devices
DROPPED my Western Digital External drive!! Hardware & Devices
Solved Western Digital 1TB Drive not showing up in My Computer Hardware & Devices
western digital portable hard drive Hardware & Devices
western digital my book external drive Hardware & Devices
Western Digital External Hard Drive Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:46 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33