Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Razer Lachesis Middle button problem

27 Nov 2011   #1
AlexRD

Windows 7 Professional x64
 
 
Razer Lachesis Middle button problem

Hi,

I have a Razer Lachesis 4000 that i bought one year ago.

I started having a very, very annoying problem. The middle button sometimes won't work, the clicking at least, the scrolling works just fine. It's like, i press the link five times and it won't open, so i try again ten more times and it works ten times.

I tried changing some settings in the razer control panel, but no luck so far. I was thinking on removing the razer driver and seeing if thats the problem.

What should i do?


Thanks,
Alex.


My System SpecsSystem Spec
.
27 Nov 2011   #2
smarteyeball

 
 

Quote   Quote: Originally Posted by AlexRD View Post
Hi,

I have a Razer Lachesis 4000 that i bought one year ago.

I was thinking on removing the razer driver and seeing if thats the problem.

What should i do?


I haven't used the Razer driver with my Lachesis for a long while. It certainly won't hurt.




You could also try reseting the mouse to factory defaults (hold the profile button for 10secs). *nb it will remove all macros, assignments, poll rate settings etc

or the whole hog: uninstall Rzaer control panel, driver and do a factory reset.

If it still doesn't work - It could simply be the mouse is on it's way out.
My System SpecsSystem Spec
27 Nov 2011   #3
AlexRD

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by smarteyeball View Post
Quote   Quote: Originally Posted by AlexRD View Post
Hi,

I have a Razer Lachesis 4000 that i bought one year ago.

I was thinking on removing the razer driver and seeing if thats the problem.

What should i do?


I haven't used the Razer driver with my Lachesis for a long while. It certainly won't hurt.




You could also try reseting the mouse to factory defaults (hold the profile button for 10secs). *nb it will remove all macros, assignments, poll rate settings etc

or the whole hog: uninstall Rzaer control panel, driver and do a factory reset.

If it still doesn't work - It could simply be the mouse is on it's way out.
That seems to have worked! So far, no errors.

But now i want to disable disable the Profile Up and Down, and DPI Up and Down to my taste. How do i do that without a driver?

EDIT: Nope, the problem is still there. It seems that after a while the problem gets worse.
My System SpecsSystem Spec
.

28 Nov 2011   #4
smarteyeball

 
 

Hmm.

Strangely enough I impulse bought a Razer Imperator for my sister today and the middle button is misbehaving like your lachesis

(no drivers, straight plug n' play. Aside from dodgy Razer quality, I'm wondering if it's a firmware issue.)

Have you updated the Lachesis's firmware? (If not - be careful if you do. Their updating software leaves a lot to be desired. A bad flash can brick your mouse completely.)

Other than that... I don't know what the deal is with these middle buttons yet
My System SpecsSystem Spec
28 Nov 2011   #5
AlexRD

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by smarteyeball View Post
Hmm.

Strangely enough I impulse bought a Razer Imperator for my sister today and the middle button is misbehaving like your lachesis

(no drivers, straight plug n' play. Aside from dodgy Razer quality, I'm wondering if it's a firmware issue.)

Have you updated the Lachesis's firmware? (If not - be careful if you do. Their updating software leaves a lot to be desired. A bad flash can brick your mouse completely.)

Other than that... I don't know what the deal is with these middle buttons yet
Yep, i have the latest firmware on my mouse, the 1.94. I e-mailed razer today, i'm just waiting for a new reply. Maybe they have something.
My System SpecsSystem Spec
30 Nov 2011   #6
smarteyeball

 
 

Fingers crossed they've got something to help you mate.

Sorry I couldn't be any more help. best of luck.
My System SpecsSystem Spec
Reply

 Razer Lachesis Middle button problem




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Middle Click Mouse Function Stopped Working (Razer Deathadder)
Hi there, As described I my middle click function has stopped working on my mouse, at first I assumed it was a Chrome update and that I could no longer use it to "Open link in new tab" however it seems that it now does absolutely nothing and I am unable to reassign it. I used CAD software...
Hardware & Devices
Razer Lycosa and Lachesis + Windows 7
Greetings. Ive got a problem with my Razer mouse and keyboard. Ive just downloaded Windows 7 compatible driver but it doesnt work for me at all. If i tryed to change dpi on my mouse it wrote me that no usb mouse found. It seems that driver for USB doesnt support this configurators. It seems that...
Drivers
Razer Lachesis 1.91 driver
I am having trouble upgrading my razer Lachesis mouse driver I have the latest driver (1.10) but I have the old firmware installed (1.64) and I downloaded the upgrade and try to install it but it keep failing I took off driver signature protection when i started up and try to install it again but...
Drivers
Razer Lachesis mouse
My Razer Lachesis mouse is not working properly under 7 (jumping cursor). The system cant find the mouse via firmware and also for firmware and mouseware it`s impossible to upgrade.. Anyone knows when razer is releasing new win seven drivers?
Drivers
Razer Diamondback 3G - button 5 doesn't work
hey ! my razer mouse button 5 (side button) don't work on win 7... i installed the razer driver (1.00) ... any idea ? EDIT : NVM , i was in WINDOWS UPDATE , then there was a facultative update for the razer mice, now all work fine :geek:
Drivers
Razer death adder + lachesis
I have both these mice and currently running windows 7 build 7600. anyways i can get both mice to work in windows although while in a game (warcraft 3) neither games let the side buttons work. the side buttons work to what i program them to in windows but when i start war3 the buttons dont work...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App