Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Nothing showing up on screen

29 Nov 2011   #1
geezafrombrum

Windows 7 Professional 64bit
 
 
Nothing showing up on screen

Since my new comp has been built, about a month ago, every now and then when I power up the computer it fails to display anything on my monitor. I look into the case and see that the red VGA LED is lit up on the motherboard. Whenever this happens, I take my GPU out and reinsert it, close up the case, power up and it works again.

You've guessed right, it gets very tiring so I am wondering if anyone knows the possible cause and how to fix it?

Motherboard is Asus P8P67 Pro B3 Rev
GPU is Gigabyte Nvidia GeForce GTX 570 SO

If you need to know my other specs, they can be viewed here:Windows 7 Forums - View Profile: geezafrombrum


My System SpecsSystem Spec
.
29 Nov 2011   #2
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

First question
have you looked into bios updates for that motherboard.
I had an asus board that was having off/on video and there turned out to be a bios update specifically addressing the problem.
Assuming that corsair power supply is pushing it's rated voltages that's about the only thought I have.
My System SpecsSystem Spec
29 Nov 2011   #3
geezafrombrum

Windows 7 Professional 64bit
 
 

Hi, I've checked the BIOS and have the latest version.

Any other ideas? Could it possibly have anything to do with GPU drivers?
My System SpecsSystem Spec
.

02 Dec 2011   #4
geezafrombrum

Windows 7 Professional 64bit
 
 

I have got more info. Although I cannot see anything on the screen, after waiting a minute I typed my password and I can hear the sound of Windows 7 successfully logged in.
My System SpecsSystem Spec
02 Dec 2011   #5
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Well that points to the graphics or the display itself (with a small chance of it being the actual cable from the computer to the monitor)

Speaking of which, have you assured that cable is connected properly at both ends?
Sometimes the most simple solution ... occam's razor and all that.
My System SpecsSystem Spec
02 Dec 2011   #6
geezafrombrum

Windows 7 Professional 64bit
 
 

Checked the cable plenty of times. I guess my only option now is to try a different GPU.
My System SpecsSystem Spec
02 Dec 2011   #7
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Just keep in mind this is a problem that happens with some flat screen displays.
A capacitor going bad can cause it to fail to initialize at all. (hp monitors specifically are known for this)
It can be fixed if you have enough knowledge of the internal parts but it's generally easier just to replace the display.
I would try both a alternate display and a alternate gpu while trying to trouble shoot this.
My System SpecsSystem Spec
Reply

 Nothing showing up on screen




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Login Screen Only Showing One Account
On my computer I have two accounts, Admin and user. Recently, whenever I have started up my computer, all that shows on the login screen is admin. I have to restart it ~50 times to get it to show my personal user account. Any suggestions on how to fix this??? I run Windows 7 home edition.
General Discussion
How do I get the log in screen to stop showing my log in on startup??
I simply want it to open to my desktop, but I don't remember how to fix this. Thanks, Bill
General Discussion
Black screen on startup, showing cursor, doesn't go to log in screen.
I'm using I have a DELL4500S desktop, on startup it will not go to the login screen, the screen is just black with the cursor showing. I've tried restarting the computer, unplugging everything and restarting it. Nothing is working. When it first starts a pop up shows and says "This Application...
BSOD Help and Support
Account not showing up on login screen
Today I was trying to log in to my computer after a restart. The computer booted and the screen with the Windows 7 Ultimate logo appeared. However, it does not have the username/password box, so I can't log in. The screen is also refreshing (turning black for a second and coming on again) but it is...
General Discussion
start up screen not showing
I have installed windows 7 and it works fine and has started up sussecfully after a few reboots during set up, showing me my motherboard screen (ie press F8 for boot menu, del for set up etc etc). However my start up screen has now vanished. When I turn my PC, i no longer see these options, or the...
General Discussion
bottom 1/3 of screen not showing! HELP!
so i installed windows 7 about a month ago but just yesterday started getting this issue where the bottom 1/3 of my screen is White and the other 2/3 works perfectly fine. I tried to take a screen shot to show what I meant but screen shots end up looking as if everything is normal. I have a...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App