Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Why won't my external hard drive work in IDE mode through eSATA?

18 Dec 2011   #1

Windows XP Ultimate x64
 
 
Why won't my external hard drive work in IDE mode through eSATA?

My motherboard is ASRock m3a770de. I built my machine 3 days ago. I have one Hiatchi 500gb internal HD, and one 1TB external HD.

I am running Windows 7 x64 Ultimate Edition.

After building my computer three days ago, I installed windows, and my external was not being detected through eSATA in the BIOS or in Windows "Probably need to install drivers" I said.

So I put in the CD that came with my motherboard, and installed the AMD All in One Driver that was on it. Restarted, and hey, my external was showing up.

Today, after installing SP1 (not sure if thats what did it), my ext hd was no longer showing up again. I reinstalled the driver on that CD. Now, I'm not sure if it even installed the first time, because it said it was currently uninstalled through the ATI catalyst installation program. But it didn't work this time. I'm not sure what got it to work the first time. But my eSATA drive was being read in IDE mode for three days. When trying to get it work the first time, I did plug it in via USB to see if it would work, maybe that had something to do with it working the first time?

Anyway, I changed my registry to start up in AHCI mode, and then went into my bios and changed my storage config to AHCI. Upon booting, windows would not load with my external HD turned on (anybody know why?), but loaded once I turned it off. Windows then installed AHCI drivers, and upon restarting, both hard drive, external and internal, were being detected as removal storage.


Why can't I get my external HD to be read in IDE mode through eSATA? IT doesn't get read through the BIOS or Windows, even if i scan for new hardware.

EDIT: sigh, now when I just went to reboot, it wouldn't load windows when my external hard drive was plugged in. Windows loaded when I unplugged it. Windows detected it when I plugged it back in.

I never had the slightest issue with eSATA in Windows XP. What's the deal?

My System SpecsSystem Spec
.

18 Dec 2011   #2

Windows 7 Pro x64
 
 

Check your boot order, sounds like you system is trying to boot from the external drive.
My System SpecsSystem Spec
18 Dec 2011   #3

Windows XP Ultimate x64
 
 

Can't do that. When the external hard drive is connected, I can't even access the BIOS; no command goes through. Not boot menu, bios, etc. It just freezes before Windows boot. If I plug in the external hard drive, then enter the bios, it just goes EXTREMELY SLOW. this is when in AHCI mode. In IDE mode the external doesn't even exist in bios/OS

EDIT: Also, I'm realizing that Windows won't shut down if the hard drive is plugged in / detected. I have to turn it off. Now I can't even get it to be recognized in AHCI.

I just want to use eSATA. I was excited about having eSATA ports right on the motherboard. This sucks.
My System SpecsSystem Spec
.


19 Dec 2011   #4

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64
 
 

Can you fill in your 'System Specs', lower left corner of any of your posts.
Looks like a driver/BIOS or hardware issue.

System Info - See Your System Specs

Speccy Free System information Utility



Have you updated drivers from your motherboard web site?

What BIOS version are you running?

Did you have your external connected when you installed Windows 7?
My System SpecsSystem Spec
19 Dec 2011   #5

Windows XP Ultimate x64
 
 

I updated all of the drivers.

I'm running the latest drivers.

I did not have the external connected when installing 7. Didn't think that would be a problem.
My System SpecsSystem Spec
Reply

 Why won't my external hard drive work in IDE mode through eSATA?




Thread Tools



Similar help and support threads for2: Why won't my external hard drive work in IDE mode through eSATA?
Thread Forum
Getting External Hard Drive to Work Hardware & Devices
USB 3.0 Ports don't work with my USB 3.0 external hard drive. Hardware & Devices
Can I have an external hard drive work on both vista and 7? Hardware & Devices
Solved My external eSata drive not seen. Hardware & Devices
External hard drive doesn't work with W7,64bit Hardware & Devices
External Hard Drive Not Recognized in eSATA Hardware & Devices
External Hard Drive attached by eSATA not detected Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:45 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33