Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird mouse lag problem.

19 Dec 2011   #1
thomas1028

Windows 8.1
 
 
Weird mouse lag problem.

My mouse pointer lags or doesn't respond for about half a second to one second whenever I leave my mouse idle for about a minute or two. When I start to move it around again, it's like it didn't pick up the signal that it's being moved until like about half a second into it.

I have a Logitech M510 Wireless Laser mouse. Batteries are fine and the mouse pad is a regular black mouse pad.

Anyone having the same problem or know what the problem is?


My System SpecsSystem Spec
.

20 Dec 2011   #2
Qdos

 

Has your Windows power management scheme got the ability to save energy on your USB ports after a period of inactivity? This setting is under the 'advanced' parameters of power options, accessed through your control panel.

What you're looking for is to see 'Disabled' present against the 'usb selective suspend setting'.

This is the starting point. If your difficulties persist afterwards then there could be other issues to check, but starting with the simplest possible cause is always a good policy.
My System SpecsSystem Spec
06 Jan 2012   #3
chriszuma

Many different OSes
 
 

It's the mouse. I just "upgraded" from a wired mouse to the same model you have (M510) and whenever it sits idle for 20 seconds or so it takes half a second to pick back up. It must be some power-saving "feature" by Logitech.
My System SpecsSystem Spec
.


06 Jan 2012   #4
beauparc

Windows 7 64 bit
 
 

I had more or less the same problem with a Microsoft mouse. I solved it by moving the USB receiver to a different USB port (on the front panel).
My System SpecsSystem Spec
Reply

 Weird mouse lag problem.




Thread Tools





Similar help and support threads
Thread Forum
Mouse problem: Any external mouse. Touchpad OK. Mouse OK in Safe Mode.
Hi guys, New here, so I hope I'm not out of line asking for help, and that I'm asking correctly. I've exhausted my own ideas on this but the problem is driving me IN.SANE. THE ISSUE: When using an external (USB) mouse with my ASUS Win7 laptop, the mouse randomly lifts up and re-clicks while...
Hardware & Devices
Mouse acting weird. Or?
Hello fellas! A strange one for you today :) I realized, when I shut down my computer all normal and still has the motherboard on power, then if I scroll/click on any button, it will light up as there's different lights on the design. It's a CM Storm Sentinel. Another interesting thing is...
Hardware & Devices
weird usb keyboard and mouse problem :(
Hi- i did try to find a thread concerning this but failed. it's also a bit hard to explain- not in my native language: i recently bought a usb microsoft Keyboard & mouse (connected via a usb external hub 'station') they seemed to work great for a few weeks, but in the last 2 weeks something...
Hardware & Devices
Weird Mouse Problem
I looked at other forums but I guess I keep running into really weird problems. So here's the deal, I've been using a logitech mouse for 2 years. I decided to get a mouse with a higher dpi, so I got a wireless HP mouse same model as this Amazon.com: HP 2.4GHz Wireless Optical Mobile Mouse -...
Hardware & Devices
My mouse is weird.
Hello, well this can only be short and simple I am having troubles with my mouse it is the Razer Deathadder and when I try to copy and paste it goes bonkers literally I will click and hold at the starting of where I want to copy then I try to drag it sometimes it will go to where I want it then...
Hardware & Devices
Weird problem with mouse and keyboard
Hey guys. I'm having a problem with my mouse and keyboard in windows 7. I've been running W7 for nearly a month now without ever experiencing this problem. Just recently during a 4-5 hour long gaming session my game closed down without an error message and suddenly everything went haywire. My...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App