Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Esata on XFX Nforce 750i SLI not visible

23 Dec 2011   #1
amoretam

Windows 7 x64bit Home Premium
 
 
Esata on XFX Nforce 750i SLI not visible

I just bought an Thermaltake BlacX USB and Esata Docking Station. I am connected trough esata but
the problem is that the drive is not detected when I power up the BlacX BEFORE turning on the computer or do a restart.

When I power up the BlacX AFTER booting I have to go to Device manager and click "Scan for Hardware changes" so it will be detected.

I already downloaded and installed the drivers from thermaltake site created to correct this problem.

I tried chooing AHCI in Esata mode but nothing...

I wonder what is going on,
thanks a lot
any help is appreciated

EDIT: my motherboard is a XFX nforce 750i SLI...


My System SpecsSystem Spec
.
24 Dec 2011   #2
amoretam

Windows 7 x64bit Home Premium
 
 

so, anyone can help me here?
My System SpecsSystem Spec
28 Dec 2011   #3
amoretam

Windows 7 x64bit Home Premium
 
 

heeeelpppp!
My System SpecsSystem Spec
.

28 Dec 2011   #4
PwnFrnzy

Windows 7 Home Premium 64-bit SP1
 
 

Don't worry, the Calvary is coming!
As for your "Motherboard" model, that is not your motherboard, it is your chipset and says it is capable of SLI since it has 2 or more PCI-E slots on it.
Have you updated the motherboard's e-Sata drivers?
My System SpecsSystem Spec
28 Dec 2011   #5
amoretam

Windows 7 x64bit Home Premium
 
 

ummm, i cannot see esata drivers updates at xfx site!
My System SpecsSystem Spec
Reply

 Esata on XFX Nforce 750i SLI not visible




Thread Tools




Similar help and support threads
Thread Forum
Need recommendations on ram sticks for nForce 750i SLI motherboard.
Just like title says, I need help on what ram sticks to buy for my nFORCE Motherboard 750i SLI. I originally had 4*2gb ddr2-800 ADATA ram sticks that lasted me a few years. One of the sticks has gone bad so i'm planning to buy a brand new set of ram sticks that are better or maybe another same set...
General Discussion
replacing my xfx nforce sli 750i mobo: Advices
Hey how r you doing,!?! I want to take this oppotunity to tell everyone to please stay away from XFX nforce 750i sli mobo. But actually this thread is for you people to help me choose a replacement mobo so I can keep and use my CPU, GPU, PSU, RAM, HDD's, fans, case, etc. Also I need this mobo...
Hardware & Devices
xfx nforce 750i sli getting too hot
hi there, I have noticed that my freezing problems are due to the mobo getting very hot.. I don't know what they are callled, but the parts getting hot are the parts you can see in the pic, the squares (black with green)... what s that called again? sorry! I have tried several fan...
Graphic Cards
eSATA drive not detected--can CrystalDiskInfo damage an eSATA drive
I plugged in my eSATA drive while CrystalDiskInfo was running and the computer froze. There was no way to regain control of the computer so I restarted. So now this eSATA drive is not recognized by the computer. The eSATA drive works in another computer. What's really weird is that...
BSOD Help and Support
anybody with xfx nforce 750i sli + OCZ2N800SR4GK
OCZ2N800SR4GK: is the P# of SLI-Ready Edition DDR2 PC2-6400 4 GB Dual Channel. I have 4x2gb's sticks (8gb) with this motherboard (XFX nforce 750i SLI) which does not have a QVL, or at least i cannot find it. I have been having problems with this mobo for a long period of time, first I had a...
BSOD Help and Support
eVGA 750i FTW motherboard -> no USB ports are working
Hello Everyone, I am having a problem with my system..... None of the USB ports are working (front or rear). A few days ago I got the "USB Device not recognized" error message but it went away. Then last night I came home and tried to move the mouse and nothing worked.. I tried to type on the...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:17.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App