Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Denied external drive permission after factory reset


28 Dec 2011   #11

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Slammer View Post
Quote   Quote: Originally Posted by Lyrical MC View Post
I tried what you said above and got this message:

Oh you just didn't put spaces between the arguments. Here, copy this:
takeown /f g:\ /r
Then, in command prompt, right-click the the top bar and select Edit -> Paste. Then hit enter. That should do it.

Thanks tried it a few times with various spacing, must have just been getting it wrong. However doesn't seem to have worked got quite a large list of things. I'll post a few:






My System SpecsSystem Spec
.

28 Dec 2011   #12

MS Windows 7 Ultimate 64-bit SP1
 
 

Ok from your screenshots, it looks like it's only failing for critical Windows files and folders that were on your drive before the restore. Depending on what you're trying to do with all your backed up data, it might be OK this way. If you're just putting all your personal folder/files back, then you should be able to copy all your personal stuff back over no problem now. On the other hand if you're trying to completely restore your entire hard drive to how it was before the reinstall, you'll need a different program and method for that. What exactly are you looking to do with these backed up files?
My System SpecsSystem Spec
28 Dec 2011   #13

MS Windows 7 Ultimate 64-bit SP1
 
 

Also, did you manually copy everything onto your hard drive before the restore, or did you use a program? If so, what program was it?
My System SpecsSystem Spec
.


28 Dec 2011   #14

Windows 7 Home Premium 64bit
 
 

I am trying to restores some of the files on the hard drive such as music and some office documents etc. But the majority of it I just want to keep on the drive itself such as movies and games. (The whole reason I did a factory reset was to clear everything like this from my laptop and just run them directly from the drive to avoid the laptop slowing down)

I used the software with the product itself for loading the data to the drive which it periodically backed up itself. However I had quite a bit of trouble getting the software to work. Can't remember if it was preloaded or I had to download additional software from the website for the product.

If it's of any help the drive is a Buffalo Drivestation 2TB.
My System SpecsSystem Spec
29 Dec 2011   #15

MS Windows 7 Ultimate 64-bit SP1
 
 

Ooh ok first of all let me say that running installed programs off that drive like you want probably won't work. When you install a program, it usually stores data in locations other than just Program Files. The two most common other places are the registry and you're user's AppData folder. Now, some programs are simple enough that they store all their data in their program files folder, but unless they're really old, very simple, or specifically designed to be be "Portable," they likely store info in some other location. Which means they will fail to run from your external hard drive.

If you want them to run like this, you'll have to install them like you normally would, and change their install path to somewhere on your external HD. This way, all the settings in the registry and whatnot know to look for the information on your drive when you try to run a program. You'll just have to make sure you're drive is always assigned the same letter by Windows, and this method should work. But just running programs off your backup? Very likely to fail.

Anyway, if it's a software that came with your HD, then it likely just made copies of all the files you told it to back up. Which means that in theory, that command I had you run should have unlocked all the personal music, documents, and videos etc. on your drive that you want to use know. See if you can access them now.

Since it looks like only system folders are still locked, I think you should just ignore them. If you want to delete them to save space or anything, I can guide you through unlocking them, though. Just let me know.

If your normal files are still inaccessible, let me know and I'll give you a better command to run.
My System SpecsSystem Spec
29 Dec 2011   #16

Windows 7 Home Premium 64bit
 
 

I had guessed this may have been an issue with regards to running programmes from the external drive, but it shouldn't be a problem as primerally it's documents and films along with saves from a 3D modeling package.

Unfortunately all the folders still seems to be locked, I can access them by going through the stages in the inital post but all the subfolders and such are still locked.
My System SpecsSystem Spec
29 Dec 2011   #17
Microsoft MVP

Windows 8.1 Pro with Media Center 64 bit
 
 

Your current windows 7 install will likely create a recycle bin folder on that drive and may block access. I believe the system volume information folder has to do with system restore and being a system folder may also be blocked by windows. There shouldn't be anything in those folders you want anyway so I wouldn't worry about not getting access to them. If they are leftovers from a previous install windows can't use them anyway and I'd probably just try deleting them. If you have room I would just try to copy over what you want to keep to another drive and format the problematic external drive. Then copy your stuff back and see if file access is any better.
My System SpecsSystem Spec
29 Dec 2011   #18

Windows 7 Home Premium 64bit
 
 

I tried copying the data from the drive the my laptop although it wouldn't allow me to copy anything past the first few folders which I manually configured permission for myself.
My System SpecsSystem Spec
30 Dec 2011   #19
Microsoft MVP

Windows 8.1 Pro with Media Center 64 bit
 
 

OK, that sucks, I thought you might have tried it but wasn't sure. That would drive me nuts, I have a lot of sub folders in My Music folder, My Pictures folder too for that matter. I wish I could be more help but I'm not getting those prompts anymore or I would still be trying to figure out why. What happened to me was when I went to play some music. MP glitched and wouldn't play the music even though it had searched it all out originally. I forget what the error was but that prompted me to have a look in my music folder. Thats when I got that Prompt you posted. I clicked continue and then looked around in my music folder. After that MP played my music fine. Looking in a couple of other folders on that partition got me that same message. I kind of scratched my head about it but they stopped and everything seems to work OK now, so I just forgot about it until your post.
My System SpecsSystem Spec
30 Dec 2011   #20

MS Windows 7 Ultimate 64-bit SP1
 
 

Ok, using this command has a tendency to screw up permissions for system files, so make sure you only use it on personal files. Although since you're not planning to use any of the old system files on your hard drive, we can just apply it to your whole drive.

cacls [drive letter here]:\ /t /g [username here]:F

So assuming your drive is still on g:\ and your username is Chris (based on your command prompt screenshots) the exact command will be:

cacls C:\ /t /g Chris:f

You can just copy and paste that into command prompt same way as the other one. If this doesn't restore permissions to you, then we've probably got a much bigger problem somewhere. Let me know if it works
My System SpecsSystem Spec
Reply

 Denied external drive permission after factory reset




Thread Tools



Similar help and support threads for2: Denied external drive permission after factory reset
Thread Forum
Solved Access Denied To My External Hard Drive Why ??? Hardware & Devices
External Hard Drive (F is not accessable Access is denied) General Discussion
Extra factory image on external hard drive Backup and Restore
Access denied to external dvd/cd drive Hardware & Devices
File Permission Settings for External Drive Installation & Setup
Permission Denied Network & Sharing
Acces Denied - copy files external drive (xp) System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:30 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33