Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New Seagate Expansion External Drive not showing up in 'My Computer'

09 Jan 2012   #21
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Quote   Quote: Originally Posted by 2harts4ever View Post
I just realized I never gave the model number of the Seagate External. It is: ST310005EXA101-RK
That does not help right now. Can you answer my previous question plse.


My System SpecsSystem Spec
.
09 Jan 2012   #22
2harts4ever

Windows 7 Pro x64 SP1
 
 

whs,

I have always appreciated the help you have tried to give me whether it be this post or one of my other ones.

I do not have near the expertise you do when it comes to the 'ins and outs' of computers.

However, I do know when I am getting in over my head. This Seagate External Drive is supposed to be 'plug and play' but up to this point it has done neither one.

That being said it is going back in the box and will be returned.

Hopefully I will find another plug and play and it will work the way the way it is supposed too ... right out of the box.

Thanks and regards,

2harts4ever
My System SpecsSystem Spec
09 Jan 2012   #23
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Understand, your choice. But with the next bit you may have the same setup problems.

As you say, when you know that stuff it is simple. But setting up a disk is normally no rocket science. Sorry I could not get you going. See you when you have the replacement disk.
My System SpecsSystem Spec
.

09 Jan 2012   #24
2harts4ever

Windows 7 Pro x64 SP1
 
 

My Aluratek spoiled me. I simply plugged that sucker in and I was off to the races. It is only a 250 GB but it worked right out of the box.

Thanks again and good night ...
My System SpecsSystem Spec
09 Jan 2012   #25
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

I think that is problem with Windows - not with your new drive.

Had that before myself - can't recall how I fixed it - I think I may have booted one of my pe discs - done a bit of minor partitioning - then disk mgmt got it's act together at next restart.

Might be that uninstalling the usb drivers then restarting will do the trick.
My System SpecsSystem Spec
09 Jan 2012   #26
2harts4ever

Windows 7 Pro x64 SP1
 
 

SIW2,

I appreciate your follow-up but it is already back in the box and ready for the return trip back.

I connected my previous external drive (Aluratek) a few minutes ago and Disk Management seems to be reading it just the way it is supposed too with no problems.

However, I will keep what you said in mind should I have the same problem with the next one I get ... if I decide to take the plunge again and replace my current 250 GB Aluratek with a larger one.

Like whs I really appreciate the time and effort you have put in this thread too. It must be frustrating for both of you to come across the likes of me.

But the reasonI buy something advertised as 'plug and play' is because I expect it to do just that. If I had your expertise I wouldn't sweat it either.

Until the next time (and I am sure there will be ....lol) ,

Thanks and regards,

2harts4ever
My System SpecsSystem Spec
04 May 2012   #27
AstaLaVista

Windows 7 x64 (Ultimate)
 
 

I am having the same problem as the OP was but with slightly different HDD. I could open up a new post but figured this was never answered completely and others (or even the OP) might find a solution in the future.

I am running an IBM T42 laptop but recently installed Win 7 Home Premium so I could use it with my HDTV. I also have the Seagate 2B FA Goflex external drive and it works ok on my rig and also when connected directly to my samsung hdtv but it refuses to initialize when plugged into the laptop.

I can eject the drive but can not assign a letter to it, it gives me the same error reported by the op a few posts back so I won't bother with a new image.

if I right click on it under disk management, the only options (not greyed out) are:
Change drive letter and paths
Format
Delete Volume
Properties
Help

If I click on Properties, the same error message posted comes up.

I have tried restarting the laptop a few times, with and without the drive being plugged in.

I have also tried download and installing the seagate software to no avail. I did noticed that with the software installed all the lights light up, before installation, only 1 small round light would light up.

I have also tried plugging the drive to the laptop's usb port and plugging it directly to the mini docking station usb port and nothing.

Google does not help and the seagate forums less than google

I guess that if I resurrected an old post, adding another image won't hurt much


Attached Thumbnails
New Seagate Expansion External Drive not showing up in 'My Computer'-2tbgoflex.png  
My System SpecsSystem Spec
04 May 2012   #28
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Try right clicking the drive and select 'change drive letter or path' then select 'add' give it the letter windows suggests or one from the drop down list. If it wants to format it, don't or you will lose all data on the drive.
My System SpecsSystem Spec
05 May 2012   #29
AstaLaVista

Windows 7 x64 (Ultimate)
 
 

Quote   Quote: Originally Posted by essenbe View Post
Try right clicking the drive and select 'change drive letter or path' then select 'add' give it the letter windows suggests or one from the drop down list. If it wants to format it, don't or you will lose all data on the drive.
essenbe, as soon as I do that, the error message pops up (the one I have shown in my image above) and it does not let me continue.

You are also correct, I don't want to Format it, let alone Delete is because I loose all the info I have there.

Again, as soon as I plug the drive in my Samsung or my rig, everything comes up so I know the drive is working. Perhaps the lappy is to old and somehow is not able to initialize this big drives?
My System SpecsSystem Spec
05 May 2012   #30
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

Perhaps that is correct. I really don't know what to tell you other than try updating your chipset drivers. It is obviously a problem with that computer as it works in others.
My System SpecsSystem Spec
Reply

 New Seagate Expansion External Drive not showing up in 'My Computer'




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Seagate Expansion Desktop Drive 3tb responding extremely slow
Hi to all Seagate Model: SRD00F2 Win 7 home prem... 64bit I have had this external for over a year and it just recently started to respond very slow. My aim is to save all the media files before this drive dies out or even solve the problem. Maybe it wont die out yet but never know what...
Hardware & Devices
Seagate Expansion 3TB data recovery / not showing up anymore.
I took my 3Tb out of it's external case and put it into my computer and it didn't show up so I put it back and it looked like my data was gone! I tried a couple programs to get it back because they said the drive was empty or something. I gave up and now I'm trying to get everything back...
Hardware & Devices
Seagate Expansion Drive 320GB Not Showing Up In My Computer Anymore!!
Hey, wondering if someone can help Bought my new external hard drive and put a load of my files onto it with no problem at all, but today, on the second time of using it, I plugged it in and it seems to be working because the green light is on and the icon to eject is there, but its not showing...
Hardware & Devices
seagate expansion drive
I have a 3g usb seagate expansion drive that is about 3 mths old. It has frequently disappeared from my computer. I would have to reboot and disconnect the power from the drive to get it to come back. Is this a sign of a bad drive or just a glitch that some kind of a driver update will solve. ...
Hardware & Devices
My 1Tb Seagate expansion portable cannot be detected by any computer
please help me.. I bought my external hard drive for about 8 month now.. it use 2.0 usb and i'm afraid i cannot recover my files inside it.
Hardware & Devices
Seagate 1TB Expansion Drive is not being recognized on my laptop
My Seagate Expansion drive is not being recognized on my laptop or any other computer that I have tried to put it on. It worked for a while It is fairly new and I have about 500gb on it so far and I don't want to lose any of my data because most of it is my university files. I don't know why...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App