Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Computer shows drive which isn't there

15 Jan 2012   #1
dasmowenator

Windows 7 Home Premium x64
 
 
Computer shows drive which isn't there

I had a friend who plugged his USB hard drive into my computer the other day and my computer wasn't able to use it (I think it was a mac format), but it still showed up in my Computer folder. When we took it back out, the drive is still in my Computer folder. It's been over 24 hours and I've restarted my computer... the stupid non-existent hard drive is still in my Computer. Does anyone know how to get rid of this? It's listed under "Hard Disk Drives" not "Devices with Removable Storage", so there is no eject option when I right-click.


My System SpecsSystem Spec
.
15 Jan 2012   #2
Lemur

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Do you have a program (such as smartdefrag) that was mapped to this drive?
My System SpecsSystem Spec
15 Jan 2012   #3
dasmowenator

Windows 7 Home Premium x64
 
 

I have VirtualCloneDrive mapped to another drive (drive F), which works just fine. But this drive is mapped to drive Q, and it just appeared when I plugged the external hard drive in
My System SpecsSystem Spec
.

16 Jan 2012   #4
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Something to do with Office 2010 perhaps.
My System SpecsSystem Spec
16 Jan 2012   #5
writhziden

Windows 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by SIW2 View Post
Something to do with Office 2010 perhaps.
Probably. May want to see Office 2010 Drive Q for more information.

Also Office 2010 Starter Virtual Q: drive may intermittently disappear from My Computer and An overview of Microsoft Office Click-to-Run for Office 2010 are good further reading.
My System SpecsSystem Spec
16 Jan 2012   #6
dasmowenator

Windows 7 Home Premium x64
 
 

Hmmmm
However, his drive seems to have a bar under it showing how much data is stored. Mine is just blank.
Here's the message I get when I double-click it.


Attached Thumbnails
Computer shows drive which isn't there-screen.jpg   Computer shows drive which isn't there-screen2.jpg  
My System SpecsSystem Spec
16 Jan 2012   #7
writhziden

Windows 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by dasmowenator View Post
Hmmmm
However, his drive seems to have a bar under it showing how much data is stored. Mine is just blank.
Here's the message I get when I double-click it.
That is actually pretty standard. It looks like the image by Derekimo was of the Q drive he created to test if the installation could finish. See Extra Drives showing up in explorer, Mystery Drive (Q:), and Office 2010 Beta Click-to-Run causes Q Drive issue! - Microsoft Help | DSLReports Forums as they have the same behavior as your Q drive.
My System SpecsSystem Spec
16 Jan 2012   #8
dasmowenator

Windows 7 Home Premium x64
 
 

Wow, well I guess that must be it then - weird that it first appeared when I plugged in an improperly formatted hard drive

So do you know how to get rid of that Q drive? I don't see the solution in any of the links

Thanks
My System SpecsSystem Spec
16 Jan 2012   #9
writhziden

Windows 7 Home Premium 64 Bit
 
 

Quote   Quote: Originally Posted by dasmowenator View Post
Wow, well I guess that must be it then - weird that it first appeared when I plugged in an improperly formatted hard drive

So do you know how to get rid of that Q drive? I don't see the solution in any of the links

Thanks
You would have to uninstall Office and re-install it without the Click to Run feature.
My System SpecsSystem Spec
Reply

 Computer shows drive which isn't there




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
A external drive that is not connected to the computer shows in explor
Hi! I have a little annoying problem. A previously connected external drive shows up in my windows explorer even though it's not connected. It also takes up a drive letter. I can't eject it, when I try it says: "An error occurred while ejecting (G). I would like to remove this non existent...
General Discussion
hard drive w/ usb adapter- drive shows in disk manager, not computer
I am trying to access files on a hard drive from a different computer which will no longer load the OS. I have connected the hard drive using a usb adapter. When I plug it in, I get a notice that the device is ready to use, but it does not show up in Computer. It is visible in the disk manager....
Hardware & Devices
Computer shows external drive empty while its not.
HI everyone, Ive been using my WD Elements 1.5TB for quite a while now but I recently had trouble with it. It doesn't show any of the maps I created on it. However if I type the name of the map in the address bars it does reach the map. I use it to store all my programs, games and movies so...
Hardware & Devices
External hard drive shows up in devices but not in my computer
hi computerfriends, I got a problem, my external hard drive (westen digital 1.0TB) isn't popping up my computer. I can see it in devices (USB to ATA/ATAPI bridge) but i can't acces it. What i've done already: Computer Management-> Disk Management. Than ive to initialize the disk, i can choose...
Hardware & Devices
My Hard Drive no longer shows up in My Computer
I have a Western Digital 1TB Hard Drive (External). I use it 99.9% of the time on my Windows 7 64bit computer to store pictures/videos and backup important files. It was working fine until I plugged it into a MACINTRASH to backup files from that computer. It was a simple copy and paste from...
Hardware & Devices
Hard Drive shows in device manager, not My Computer
I've spent most of the night searching and cannot seem to find an answer to my problem so I registered with the hopes that someone here may be able to help. I have a NAS set up with two 2TB Samsung Spinpoint hard drives. The hard drives in the NAS were partitioned to have 300GB in a RAID 1 and...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App