Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Some USB mass storage devices don't work

25 Jan 2012   #1
eforce

Windows 7 Ultimate 64-bit
 
 
Some USB mass storage devices don't work

They work in my other PC's though.

When I plug them in, it fails to install the driver and in the device manager they are listed as Generic USB2.0 card (The drivers for this device are not installed. (Code 28)).

I have the latest motherboard drivers/BIOS.

(My system specs are filled in for further details).


My System SpecsSystem Spec
.

25 Jan 2012   #2
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

Hello eforce, and welcome to Sevenforums

Have you tried right clicking the device and clicking update driver>search internet for correct drivers?

Are you positive you installed the (most recent) USB drivers for your motherboard, as they are required.

If you would like, you can set windows to automatically search for drivers through windows update for you: Device Installation Settings
My System SpecsSystem Spec
25 Jan 2012   #3
eforce

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by DustSailor View Post
Hello eforce, and welcome to Sevenforums

Have you tried right clicking the device and clicking update driver>search internet for correct drivers?

Are you positive you installed the (most recent) USB drivers for your motherboard, as they are required.

If you would like, you can set windows to automatically search for drivers through windows update for you: Device Installation Settings
I have tried uninstall and re-installing the driver and the option to update via the internet.

My motherboard uses AMD drivers as it uses an AMD chipset and they are the latest version, it's not like Intel boards where you have loads of different ones (unless Sapphire are just being lazy).
My System SpecsSystem Spec
.


25 Jan 2012   #4
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

What are the differences between the devices? Some of them work and others do not?

You have all windows updates installed?

Do you have a 3rd party firewall installed? What antivirus are you using? Try temporarily disabling it to see if you notice any change.

Have you done any registry editing?

Enter your motherboard info here to search for other drivers: http://support.amd.com/us/Pages/AMDSupportHub.aspx
My System SpecsSystem Spec
25 Jan 2012   #5
eforce

Windows 7 Ultimate 64-bit
 
 

Quote   Quote: Originally Posted by DustSailor View Post
What are the differences between the devices? Some of them work and others do not?

You have all windows updates installed?

Do you have a 3rd party firewall installed? What antivirus are you using? Try temporarily disabling it to see if you notice any change.

Have you done any registry editing?

Enter your motherboard info here to search for other drivers: AMD Support & Drivers
Turns out Sapphire were being lazy, very lazy, on their site they only had 8.8, the AMD site had 12.1, while this didn't fix the problem, guess it can't hurt to update.

However, I checked Windows Update, my fatal mistake was ignoring the updates in italics (italics = supposedly non-essential?), installed them all, one of them on the Microsoft site there was a USB issue caused by W7 64-bit, so I think that was what did it, all USB devices work which originally didn't.

Thanks!
My System SpecsSystem Spec
25 Jan 2012   #6
DustSailor

Microsoft Windows 8.1 Pro 64-bit
 
 

Thats awesome, glad it is working for you

If you can, mark the thread as "solved" so others may gain from your findings.
My System SpecsSystem Spec
Reply

 Some USB mass storage devices don't work




Thread Tools





Similar help and support threads
Thread Forum
USB mass storage devices cause permanent computer crashes
Hello, I am desperately searching for a solution of a great problem I have never had before, but that I am having now after a completely fresh re-installation of Windows 7 Ultimate x64. Each time when I plug in a USB mass storage device (USB stick or external hard drive), no matter at which...
BSOD Help and Support
USB mass storage devices dont show in explorer.exe
Hi.I've been experiencing this issue since a week,searched a lot still,found no solution. My laptops USB ports are fine.I have many USB mass storage devices which I can use with other PCs with win xp,7,8,etc. But in my laptop,windows just makes new device connected sound,but nothing appear in...
Hardware & Devices
USB Mass storage devices not working - including card readers
Some while back I installed Acronis True Image Home 2012 on my Win7 64 bit PC. It is a backup solution that would have satisfied my backup requirements at the time. I immediately found a problem with the fact that it failed to recognise my network drive as a backup location. After days of...
Drivers
Asrock H67M / Etron USB: Can't access USB Mass Storage Devices anymore
Hi, it's driving me mad :devil: My system: Asrock H67M Mainboard with Etron USB 2.0/3.0 chipset Windows 7 Ultimate with all current fixes applied The problem: I just discovered by accident that no matter what USB Mass Storage device (USB-MSD) I plug into my PC (and also no matter if I...
Drivers
Computer not Reading Mass Storage Devices
Alright guys/gals, I'm stuck! Here we go.... I have a Android Phone(evo4g) and I also have a 60n1 Card Reader neither of then will read cards! Card Reader= I put any card into it slot (sd,mirosd,sdhc,microsdhc) and it WILL show in computer as a "removable device" but if I go to open them I...
Hardware & Devices
USB Mass Storage devices won't install
Hello all Well this is a strange one. Anytime I try to plug in a "new" (e.g. never plugged in to this computer before) USB Mass Storage device, device installation fails. When I click on the balloon that says device installation failed, it says "No driver found". If I manually choose a...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:08.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App