Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: External hard drive not showing up in Windows Explorer

06 Feb 2012   #1

Windows 7 Home Premium 64 Bit
 
 
External hard drive not showing up in Windows Explorer

I am having a strange problem with my external hard drive for my backups. When I plug the drive in, it does not show up in Windows Explorer. I can make it show up by going into disk management and assigning it a drive letter, but the next time I plug it in, I have the same problem again. Any ideas why this might be occurring?


Edit: Turns out this is not limited to my backup drive. Once I assign a letter, the drives work fine. They will even keep the letter if I eject them and re-insert the USB connection, but any external media I plug in fails to assign a drive letter automatically the first time it is plugged in. While I do not see this as a huge problem, it bothers me that Windows is not working as it used to nor as it should.

Edit2: After reading some of the related forums, I realize I should be clear about a couple things. I am having this problem with drives that have already had their drivers installed in Windows. I do not get a dialog saying that Windows is installing these devices because the devices have already been installed. For some reason, their volume letter has been forgotten by Windows and I have to re-assign it. I am being careful not to use the same letter more than once. I am plugging the drives in while Windows is already running.


Any help would be greatly appreciated so that Windows will automatically assign a drive letter to a device instead of me having to manually do it when Windows forgets what letter it had assigned.

My System SpecsSystem Spec
.

06 Feb 2012   #2

Windows 7 Home Premium 64 Bit
 
 

Windows 7 x64 Quit Assigning Drive Letters Automatically helped me solve my problem. Ran an Elevated Command Prompt and typed the following commands.
mountvol.exe /n
mountvol.exe /e
Guess it just needed to be reset by disabling auto mounting and re-enabling it.
My System SpecsSystem Spec
22 Dec 2012   #3

Windows 7 Pro x64
 
 

Windows stopped automatically assigning drive letters for some reason. I assigned manually, not a real big deal for now.

But then Truecrypt stopped being able to mount my encrypted volumes (which don't even have a drive letter assigned till mounted in Truecrypt). A BIG deal! Every attempt gave me a Truecrypt error -- "Device not ready". I went to the first suspect -- Windows -- found this thread, did the above and that fixed BOTH problems. THANK YOU!
My System SpecsSystem Spec
.


Reply

 External hard drive not showing up in Windows Explorer





Thread Tools



Similar help and support threads for2: External hard drive not showing up in Windows Explorer
Thread Forum
External Hard-Drive Not Showing Up Hardware & Devices
External Hard Drive Not Showing Up Hardware & Devices
Samsung s2 external hard drive not loading showing local disk F drive Hardware & Devices
Cannot access 1TB External Hard drive (USB) Crashing windows explorer Hardware & Devices
External Hard Drive not showing up anywhere Hardware & Devices
External hard drive not showing up Hardware & Devices
Explorer Not Showing External Drive - Help! Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33