Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: How can I fix USB Mass storage problem on my laptop?

10 Feb 2012   #1
nit83

Windows 7 Pro 64 bit
 
 
How can I fix USB Mass storage problem on my laptop?

Hi

I've just got a StarTech dock station for the Hard Drive (with Esata and USB 3.0 ports). When I first used it first time. The first thing I use is ESATA port and ran without a problem (run CrystalDiskInfo and CrstalDiskMark to test) and also I format the drive.

But when I try USB 3.0 port is won't response well (using express card). For example it found new hardware and open the drive - but then I ran CrystalDiskInfo or CrstalDiskMark it won't open unless I disconnect the USB then the program will open after I disconnect the USB. I've try copy a file across nope crash or stop working. So I've try using USB 2 to see if not the USB 3.0 same problem but gone back to Esata port work fine!!!

So I’ve try on another laptop to see if not the Dock problem. And USB 2 work!!!! even USB 3.0 work using Express card so it not the dock problem (The laptop is running Win XP 32 bits).

I also got WD passport and book (1tb/3tb) and they both work fine on my laptop plus the USB 3.0.

So what I'm doing wrong? I can't pin the problem on my laptop with USB issues with the dock station. Any idea?? Don't really want to re install win 7 to see if that fix it.

Cheers


My System SpecsSystem Spec
.
10 Feb 2012   #2
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi nit83 welcome to the forums Here is a link to the Ricoh card driver Drivers and Downloads | Dell [United States] unfortunately there is no win764bit driver install the vista 64bit in compatibility mode
My System SpecsSystem Spec
10 Feb 2012   #3
Azo

Windows 7 Home Premium 64Bit
 
 

Why not try using the USB 2.0 port on your lappy? It's on the right side of it ! I am sure it's gonna work fine. Also did you install the Star Trek USB 3.0 driver? Link Here: http://files.startech.com/ProductDri...ATDOCK4U3E.zip. Let us know if it helps.
My System SpecsSystem Spec
.

10 Feb 2012   #4
nit83

Windows 7 Pro 64 bit
 
 

Quote   Quote: Originally Posted by pebbly View Post
Hi nit83 welcome to the forums Here is a link to the Ricoh card driver Drivers and Downloads | Dell [United States] unfortunately there is no win764bit driver install the vista 64bit in compatibility mode
Try install Ricoh card driver and no different it open the drive but won't open the folder or file - it just crash (it effect everything and I have to force unplug the USB to make the computer work again). Also there no option to install 64bit compatibility mode. Anyway what Ricoh card driver got to do with USB?

Try the USB 3.0 express card it kept closing down then restart - like I disconnect it and plug back in again.

Quote   Quote: Originally Posted by Azo View Post
Why not try using the USB 2.0 port on your lappy? It's on the right side of it ! I am sure it's gonna work fine. Also did you install the Star Trek USB 3.0 driver? Link Here: http://files.startech.com/ProductDri...ATDOCK4U3E.zip. Let us know if it helps.
That what I test first to check see if not the USB 3.0 on express card. And it plug on the right side (is there any different to left side of it?)

What is the USB 3.0 driver that you link for?
My System SpecsSystem Spec
10 Feb 2012   #5
Azo

Windows 7 Home Premium 64Bit
 
 

Well it is supposedly the driver of your product, although if you give me the exact model number, I can be more sure. The ports to the left are USB 3.0, while that to the right is USB 2.0. So why not try the ports to the right?
My System SpecsSystem Spec
11 Feb 2012   #6
nit83

Windows 7 Pro 64 bit
 
 

Quote   Quote: Originally Posted by Azo View Post
Well it is supposedly the driver of your product, although if you give me the exact model number, I can be more sure. The ports to the left are USB 3.0, while that to the right is USB 2.0. So why not try the ports to the right?
The laptop is XPS M1530 is about 4 years old. It got no USB 3.0 just USB 2.0. That why I brought StarTech 2 port Flush Mount 54mm SuperSpeed USB 3.0 ExpressCard (ECUSB3S254F) about year ago to use the USB 3.0 port. And my other External Hard Drive WD MY Book 3TB and WD Passport 1TB work fine on my USB 3.0 ExpressCard and same for normal USB 2.
Because I got other internal Hard Drive around so I only just brought StarTech USB3 eSATA HDD Docking Station (SATDOCKU3FGB).

When I first use it (StarTech USB3 eSATA HDD Docking Station) using the eSATA port first on my ExpressCard that take eSATA II 300 - and it work fine, then I try USB 3.0 ExpressCard it giving me problem - so I try the USB 2.0 but give me same problem. So I thought I got faulty Docking Station with USB problem but I though I check on other laptop (got win xp 32bit) before I send it back, and it work without a problem so it can't be the Dock Station. So it only can be the problem with Win 7 on my laptop - it used to be Win Vista Pro 32bit before I did fresh install copy of Win 7 Pro 64 bit.

My Laptop spec are (Dell XPS M1530):

Intel Duo core T7700 @ 2.4Ghz
4Gb Ram
Nvidia 256mb 8600M GT
Blu Ray Writer
WD 250 GB Hard Drive

Hope that help.

Thanks for the help
My System SpecsSystem Spec
11 Feb 2012   #7
nit83

Windows 7 Pro 64 bit
 
 

By the way I going to test it on another laptop that got Win 7 and he think he got USB 3 as well. So I'm going over there to test it in the late afternoon to see if it win 7 cause it.
My System SpecsSystem Spec
11 Feb 2012   #8
nit83

Windows 7 Pro 64 bit
 
 

Just test on other computer early on this afternoon that got win 7 but it haven't got USB 3 which it not a problem because my don‘t work on USB 2 as well. It work fine on their Win 7.

I can't see any reason why my don't work unless the driver or some file is causing the problem. Bit annoy now - look like I'm going have to reinstall Win 7 unless there other way I can do before I do clean install?

Thanks for the help
My System SpecsSystem Spec
Reply

 How can I fix USB Mass storage problem on my laptop?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Problem Ejecting USB Mass Storage Device
After attempting to 'Eject' my flash drive (all programs closed), I got this message. I've just transferred lots of data over to it using Synctoy, and do not want to risk pulling it and potentially damaging what's on there. In the past I've pulled these drives regardless of message, but ended up...
Hardware & Devices
Missing Mass Storage Device Driver for Installing Win 7 In My laptop
Hello; How are you? I'm new to this forum. I have Compaq Presario CQ61-405SF and i try to doing clean installation of windows 7 but setup can not find my hard disk and i need to find Mass storage device driver. So help me to find mass storage of my laptop (sorry i m poor in english)
Installation & Setup
Problem Ejecting USB Mass Storage Device
This to me is the most annoying feature in Windows. Why can't Windows tell me what programs or windows are using the device so I know what to close? Many times, I have tried closing all programs and windows that might be using the device. I even closed programs and windows that I was fairly certain...
Hardware & Devices
Problem installing USB mass storage device driver
I have an Acer R3610 (so everything is via USB). When I plug in an I/O Magic disk drive, I get an error "Device driver software was not successfully installed". I had earlier tried to fix this situation by going to Device Manager and deleting all drivers under USB controllers. When I rebooted...
Drivers
toshiba laptop mass storage controller
have loaded windows 7 7000 on two test machines, desktop running fine. clean installs in both cases. toshiba satellite a200 runs faster than vista, better shutdown et al, but has a quality index of 2.0 due to driver not loading for mass storage controller, pci memory controller and one unnamed...
Drivers
Problem Ejecting USB Mass Storage Device
I am having issues disconnecting / ejecting a Seagate portable expansion drive. I keep getting the following error message (see pic) .. I don't have any open programs.. Why am I getting this message? How do I fix it?
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App