Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Biostar TZ68A+ and Creative X-Fi Gamer Sound Drivers do not load

15 Mar 2012   #1
radman3d

Windows 7 64 Home
 
 
Biostar TZ68A+ and Creative X-Fi Gamer Sound Drivers do not load

The sound drivers intermittently do not load. It is listed in Device Manager under Other Devices as Multimedia Audio Controller when it does not load at boot. I have to turn off the computer and boot again until it loads. This is a clean install and not sure what is not right.


My System SpecsSystem Spec
.

15 Mar 2012   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Start with the easy, pull and re-seat the card. If that doesn't work and it is free, try it in the other PCI slot.
My System SpecsSystem Spec
15 Mar 2012   #3
radman3d

Windows 7 64 Home
 
 

Good idea about trying the re-seat, not sure why I did not think of that, but that's why I'm here. I re-seated it and booted and the computer found it. This is an intermittent problem so we will see. If it does it again I will try the other PCI slot...I have only one other. It has done this since I installed the operating system 3 days ago. Is it possible it is a setting in the bios? It is the most complicated bios I have ever seen. Any good sites to read up on the bios entries?
My System SpecsSystem Spec
.


15 Mar 2012   #4
ReviverSoft

Windows 7 HP / Ultimate x64
 
 

Hi there,

1. Have you disabled the onboard audio in the BIOS?

(In the BIOS, go to Advanced > Peripheral Configuration > disable Onboard Audio - or something similar)

While you're in the BIOS, also check to see if the X-Fi card is being detected and enabled.

2. Have you tried using the old (original) and new drivers for the Creative X-Fi sound card?
My System SpecsSystem Spec
15 Mar 2012   #5
radman3d

Windows 7 64 Home
 
 

Yes, I disabled the on-board audio. This is something I kept checking to make sure the bios did not somehow switch it back to enabled. It has stayed disabled, so that is not an issue. I do not see the X-Fi in the bios anywhere, but it could be somewhere I have not looked. Not sure it would show in the bios, I have never had any PCI card show in the bios. I have several different drivers, old, new and beta and it did not make a difference. Seems more like a detection problem when it happens. Will it does show a audio card but does not load the drivers. Guess that could be a driver problem...I'm stumped.
My System SpecsSystem Spec
18 Mar 2012   #6
radman3d

Windows 7 64 Home
 
 

After I reseated the card it worked for several boots, about a day before it happened again. I moved the PCI card to another slot and nothing changed, as a matter of fact it seemed worst so I moved it back to the original PCI slot. The card seems to seat well in both slots, so I do not think it is a connectivity issue. Are there any logs Win7 would keep that would help? I have looked at Event Viewer to see if anything there would point to the problem, but I'm not experienced in this area at all.
My System SpecsSystem Spec
Reply

 Biostar TZ68A+ and Creative X-Fi Gamer Sound Drivers do not load




Thread Tools





Similar help and support threads
Thread Forum
Creative SB X-FI Xtreme Gamer / upgrade
Hello. I want to upgrade my soundcard Creative SB X-FI Xtreme Gamer and i don't if it's worth. For now i use my headphones Sennheiser 429 HD + Logitech 5.1 x530 but soon i'll have Behringer MS40 instead Logitech 5.1 x530 What would you advice me ? Should i go for Asus Xonar ? Should i go again...
Sound & Audio
Pax Drivers for Creative Sound Cards
Tweaked drivers available which are alternatives to Creatives own drivers. Supports X-fi, Audigy and Forte cards, including Titanium HD and Fatality series. Can be found here - Get the latest X-fi Pax Drivers here Updated regularly. :D
Sound & Audio
biostar mobo TZ68A+ compatability with CPU coolermaster hyper 212
So I'm putting together a new rig. I have purchased the biostar TZ68A+ LG-1155 socket MOBOand I will be getting the intel i5 2500k sandy bridge CPU along with G-skill ripjaws RAM 16 GB. I might do a little OC'ing on the CPU and I really want to keep this stuff cool. I bought a ful ATX tower with 4...
Hardware & Devices
creative sound extreme gamer pro 100% CPU
I just upgraded to windows 7 from XP. Everything went fine for a couple of days when my graphics card went dead (XFX 7900GS). I switched cards with my son (9500 GT) and sundenly my CPU is pinned at 100%. After lots of research and dissabling just about everything in BIOS and starting in Safe...
Sound & Audio
Creative X-Fi Gamer
I have problems with my soundcard, all drivers seem to install correctly, both from original vista disk, and from the latest 2.18.0010beta drivers from creative. however i get problems with playback, crackles through the speakers, faint sounds, sound cutting out etc etc. doesnt sound great through ...
Sound & Audio
creative sound blaster audigy se drivers
i have just downloaded the ones that stormy showed and i also downloaded from the creative website itself. i have installed and reinstalled and restared my computer many times and still no luck what so ever. all it says is that there is no audio output device installed when actually i have...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App