Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: So, about those pesky external hard drives...

22 Aug 2009   #1

Windows 7 Build -7600- (x64)
 
 
So, about those pesky external hard drives...

Long title..I know. For whatever reason, this latest build has caused windows to not pickup my external USB hard-drive on startup, I have to physically unplug it and replug it in each time. Any ideas or fixes? I did a quick search but perhaps I'm not using the right words because I didn't find any previous posts that isolated my issue.

Thank you in advance!

If you come here often and ask for help, yet give nothing back, monetarily or written; then you are no better than those that we fight against by creating this site. Support your community, they pay for hosting, domains, and for knowledge; you pay only for help.

My System SpecsSystem Spec
.

22 Aug 2009   #2

Windows® 8 Pro (64-bit)
 
 

Which External hard drive do you have?

Did you install the chipset driver for the motherboard?
My System SpecsSystem Spec
22 Aug 2009   #3

Windows 7 Build -7600- (x64)
 
 

It is a "Simpletech" Simpledrive 9 series (320 Gig) and yes, I did indeedy install the chipset driver.
My System SpecsSystem Spec
.


22 Aug 2009   #4

Windows 7 Build -7600- (x64)
 
 

Double Post.
My System SpecsSystem Spec
23 Aug 2009   #5

Windows 7 x64
 
 

i suppose you have 64-bit version... Don't worry then. Thousands of users have external storage dvices problems (wel, USB storage devices) on it, and most of them haven't found solution yet. Maybe there's no one yet, waiting for Microsoft to release some update/fix.
Well, of course you can search this forum and find like 5-7 different suggestions how-to-solve, and you're REALLY lucky if one of them works for you.
My System SpecsSystem Spec
24 Aug 2009   #6

XP, Vista, W7 64bit Home Premium
 
 

You could try turning the pc off disconnect the usb drive and restart Windows 7, then give it a min or two to load a few programs then plug it in (make sure it is turned on) - usb is plug and play it should load the driver and your fixed. If it doesnt as someone else suggested try the latest intel chipset drivers for your motherboard - they may need to be installed in compatibility mode with vista if you get an OS mismatch and they wont install -
To install a driver OR program in compatibility mode - right click the setup.exe file - click properties - click compatibility - check run in compatibility with vista/xp etc - check run as administrator - leave the rest blank. Start setup.exe and install.
http://downloads.guru3d.com/ all mainboard drivers - via, nvidia, and intel
http://downloads.guru3d.com/Mainboar...Intel_c17.html intel drivers (most common)
My System SpecsSystem Spec
Reply

 So, about those pesky external hard drives...





Thread Tools



Similar help and support threads for2: So, about those pesky external hard drives...
Thread Forum
Run two external hard drives? Hardware & Devices
Solved Win 7 vs External Hard Drives Hardware & Devices
External Hard Drives Gone After a Restart Hardware & Devices
External hard drives what to get? Hardware & Devices
External hard drives Hardware & Devices
External Hard Drives Hardware & Devices
External USB Hard Drives Issue Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:26 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33