Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Brand new WD Elements 3TB drive stopped showing up.


21 Mar 2012   #1
JRM

 
 
Brand new WD Elements 3TB drive stopped showing up.

Hello i just recived my new WD Elements 3TB Exteral drive and at find it worked fine and i was copy files to it and it seem to of froze and the files stopped copying(using TeraCopy) so i pressed cancel to stop the transfer and it wouldnt stop so i just unplugged the drive and now it doesnt show up in windows anymore. I went into Disk Management and it shows up but i cannot do anything to it. The Initilize disk pops up and i click GBP and it fails and says Media is write protected. Im totally confused can anyone help me fix it?

My System SpecsSystem Spec
.

21 Mar 2012   #2

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

With the drive plugged in, could you post a screen shot of disk management? It might give a clue as to what's gone wrong. Also, open device manager and click on the + sign next to disk drives. You should see your internal drive and the external WD drive listed. Double click on the WD drive and a dialog box with several tabs should open. On the general tab it should indicate if the drive is working properly. If it's not, you should be able to click on a troubleshoot button.
My System SpecsSystem Spec
21 Mar 2012   #3

Vista Ultimate X64/ Windows 7 Dual-boot
 
 

You unplugged it without using "safely remove hardware"...while a file transfer was running...never a good idea.
Does it show up in Disk Management ? ?
My System SpecsSystem Spec
.


21 Mar 2012   #4
JRM

 
 


Right clicking the disk:

Trying to initialize:

Failure:

Right clicking on the unallocated space:








here are some screen shots
My System SpecsSystem Spec
22 Mar 2012   #5

Windows 7 Home Premium 32 bit
 
 

I am not sure whether this will help you, but there is no harm in trying.

I am a little bit paranoid when it comes to registry modification. So before trying this, you either backup your registry or use System Restore and create a restore point. ( Make sure that your System Restore works.)

Download Thumbscrew Thumbscrew: Software USB Write Blocker and run it.

Using it you can toggle between write enable and write disable your USB device.

Try to write enable your HDD and check whether your problem is resolved.

Though it is a nice utility, if you do not want to keep it use System Restore to go back or restore your registry to undo the only registry entry it makes/modifies ( depending upon whether it was already there or not.)

Let us know how it goes.
My System SpecsSystem Spec
Reply

 Brand new WD Elements 3TB drive stopped showing up.




Thread Tools



Similar help and support threads for2: Brand new WD Elements 3TB drive stopped showing up.
Thread Forum
Display driver stopped responding and has recovered-brand new system Drivers
Solved File folder is not showing in my pen drive, showing it is empty. General Discussion
Solved Brand new build, 1tb drive showing up as 1gb, how to fix? PC Custom Builds and Overclocking
Win 7 doesn't assign drive letter with 2nd Western Dig Elements drive Hardware & Devices
Solved Win 7 Suddenly Stopped showing USB Drives Hardware & Devices
Win7 PC stopped showing up on Mac Network & Sharing
WD Elements 640GB External Drive Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:52 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33