Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't update firmware on ADATA S510 SSD


26 Mar 2012   #1

Windows 7 Ultimate 64bit
 
 
Can't update firmware on ADATA S510 SSD

I have an ADATA S510 120gig SSD, i tried downloading the Firmware upgrade tool seen on this page

S510 SATA 6Gb/s Solid State Drive, Download, S510, 500 Series, Solid State Drive, Welcome to ADATA

I opened the tool and it didnt find my SSD drive. I then downloaded the file itself to try and manually install it but it is a "VIC" file, i dont even know how to open it.

Does anyone have experience with updating their firmware on these SSD drives? What am i doing wrong?


edit: after digging around on my machine i found that i have firmware 3.3.2 which is apparently the latest firmware out there right now (i didnt know that till i just found this info out, this machine is 2 weeks old)


My System SpecsSystem Spec
.

07 Aug 2012   #2

Windows 7 home Premium 64bit
 
 
same to me - fixed

I started my PC with a Linux live DVD (Knoppix) because my ADATA S510 SSD Device is my boot device and device with OS (Windows 7).
So I run the Linux version of the updater (you must be root!) and all worked fine!
But: please check the signature (for example 22739) - it has to be in the filename of the firmware update!
Good luck

PS: my drive was not 3.3.2....now it is! I hope my problems (bluescreen) are gone now!
My System SpecsSystem Spec
15 Sep 2014   #3

W7 Pro x64
 
 

It didn't find my drive either. Seems like there are 2 ways to solve this:

1. Restart in safe mode (Start, Shut down, Restart, press F8, select Safe Mode). That worked for me.
2. Copy the Adata files to the root and try again. Didn't try that but others confirmed it worked for them.
My System SpecsSystem Spec
.


Reply

 Can't update firmware on ADATA S510 SSD




Thread Tools



Similar help and support threads for2: Can't update firmware on ADATA S510 SSD
Thread Forum
Solved Firmware update question on ssd Hardware & Devices
Trying to update firmware on Crucial C300... Hardware & Devices
update firmware Drivers
OCZ SSD Firmware update for... Hardware & Devices
Firmware update for my modem Hardware & Devices
(Re-) Installing a printer after firmware update Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:47 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33