Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: network adapters won't install...parameter is incorrect ...please help


30 Mar 2012   #1

windows 7 ultimate 64 bit
 
 
network adapters won't install...parameter is incorrect ...please help

I've been without internet for 2 weeks. Upgraded to windows 7 ultimate 64bit from vista ultimate 64 bit. That didnt fix it. I'm desparate. I've tried everything I can find. It has a realtek 8169 nic on board sabertooth x85. I tried USB adapter and where it normally loads it just says it's installed but shows up in device manager. Like thw tealtek nic with yellow triangle on it. If I try an update driver it returns "parameter is incorrect" message. Its not connected and the is no IP using ipconfig. PLEASE HELP. I Lost all my software CDs and emails with serials etc in a house fire last year. So I'm desparate to avoid aa clean install. Could I maybe install to a new hdd install win 7 and still use the aapps?

My System SpecsSystem Spec
.

30 Mar 2012   #2

windows 7 ultimate 64 bit
 
 

Fyi I'm on a table so typing is challenging lol
My System SpecsSystem Spec
30 Mar 2012   #3

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Hello efcs. Welcome to the Forum.

The LAN driver you will find here:
ASUS - Motherboards- ASUS SABERTOOTH X58
are for a Realtek 8110SC chip.

Are you sure you downloaded the correct driver? If your motherboard is an Asus SaberTooth X58 (and not some other model) then the above driver should be the correct one.
My System SpecsSystem Spec
.


30 Mar 2012   #4

windows 7 ultimate 64 bit
 
 

Tried that but did it again to be sute off your link. Here's a screenshot of what I get regardless of network adapter ...well seems I can't upload from my iconia. Give me an email aand ill inbox you. It says "The parameter is incorrect."
My System SpecsSystem Spec
31 Mar 2012   #5

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

One of the more reliable solutions I've read about is to do a System Restore to a date before the behavior started happening.

If that is not possible or practical, then you could try this:
  • Create a System Restore Point.
  • Go to Control Panel > Programs. Check to see if there are any software installed regarding network connections (including wireless) > uninstall any and all.
  • Then check in Windows Explorer for any folders created from any software installs found above.
  • Then go into Device Manager and UNINSTALL the network device(s) > restart the computer.
One of 3 things will happen:

  • Best: new hardware will be found, but no drivers are installed. Now you can install the correct driver.
  • OK: new hardware found, Windows installs driver from the Driver Storage, and everything works.
  • Not OK: new hardware found, Windows installs driver from the Driver storage, and the Parameter is still incorrect.
Very important: find out what the exact model of Network Controller is on that motherboard. Do not guess. Do not try and install a driver from a different chip.


Give that a try. Let me know what the outcome is.
My System SpecsSystem Spec
31 Mar 2012   #6

windows 7 ultimate 64 bit
 
 

System restore tried a few no change

Device manager uninstall...no effect
My System SpecsSystem Spec
31 Mar 2012   #7

Windows 7 Professional x64
 
 

Would you mind creating a jcgriff2 report and uploading it here? While it was written with BSODs in mind, in reality, it's just a system information tool that's good for all kinds of troubleshooting.

http://www.sevenforums.com/crashes-d...tructions.html
My System SpecsSystem Spec
Reply

 network adapters won't install...parameter is incorrect ...please help




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:52 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33