Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: network adapters won't install...parameter is incorrect ...please help

30 Mar 2012   #1
efcs

windows 7 ultimate 64 bit
 
 
network adapters won't install...parameter is incorrect ...please help

I've been without internet for 2 weeks. Upgraded to windows 7 ultimate 64bit from vista ultimate 64 bit. That didnt fix it. I'm desparate. I've tried everything I can find. It has a realtek 8169 nic on board sabertooth x85. I tried USB adapter and where it normally loads it just says it's installed but shows up in device manager. Like thw tealtek nic with yellow triangle on it. If I try an update driver it returns "parameter is incorrect" message. Its not connected and the is no IP using ipconfig. PLEASE HELP. I Lost all my software CDs and emails with serials etc in a house fire last year. So I'm desparate to avoid aa clean install. Could I maybe install to a new hdd install win 7 and still use the aapps?


My System SpecsSystem Spec
.

30 Mar 2012   #2
efcs

windows 7 ultimate 64 bit
 
 

Fyi I'm on a table so typing is challenging lol
My System SpecsSystem Spec
30 Mar 2012   #3
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Hello efcs. Welcome to the Forum.

The LAN driver you will find here:
ASUS - Motherboards- ASUS SABERTOOTH X58
are for a Realtek 8110SC chip.

Are you sure you downloaded the correct driver? If your motherboard is an Asus SaberTooth X58 (and not some other model) then the above driver should be the correct one.
My System SpecsSystem Spec
.


30 Mar 2012   #4
efcs

windows 7 ultimate 64 bit
 
 

Tried that but did it again to be sute off your link. Here's a screenshot of what I get regardless of network adapter ...well seems I can't upload from my iconia. Give me an email aand ill inbox you. It says "The parameter is incorrect."
My System SpecsSystem Spec
31 Mar 2012   #5
TVeblen

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

One of the more reliable solutions I've read about is to do a System Restore to a date before the behavior started happening.

If that is not possible or practical, then you could try this:
  • Create a System Restore Point.
  • Go to Control Panel > Programs. Check to see if there are any software installed regarding network connections (including wireless) > uninstall any and all.
  • Then check in Windows Explorer for any folders created from any software installs found above.
  • Then go into Device Manager and UNINSTALL the network device(s) > restart the computer.
One of 3 things will happen:

  • Best: new hardware will be found, but no drivers are installed. Now you can install the correct driver.
  • OK: new hardware found, Windows installs driver from the Driver Storage, and everything works.
  • Not OK: new hardware found, Windows installs driver from the Driver storage, and the Parameter is still incorrect.
Very important: find out what the exact model of Network Controller is on that motherboard. Do not guess. Do not try and install a driver from a different chip.


Give that a try. Let me know what the outcome is.
My System SpecsSystem Spec
31 Mar 2012   #6
efcs

windows 7 ultimate 64 bit
 
 

System restore tried a few no change

Device manager uninstall...no effect
My System SpecsSystem Spec
31 Mar 2012   #7
Jonathan_King

Windows 7 Professional x64
 
 

Would you mind creating a jcgriff2 report and uploading it here? While it was written with BSODs in mind, in reality, it's just a system information tool that's good for all kinds of troubleshooting.

http://www.sevenforums.com/crashes-d...tructions.html
My System SpecsSystem Spec
Reply

 network adapters won't install...parameter is incorrect ...please help




Thread Tools





Similar help and support threads
Thread Forum
Disk Part has encountered an error: the parameter is incorrect
Hi, I recently acquired a new computer that's fairly old but I tried reinstalling windows on it with all of these errors regarding the hard drive being unable to be read with an error code. After several hours of trouble shooting I went to the Windows x32 bit command prompt tool on the disc, typed...
Hardware & Devices
0x80070057 incorrect parameter when trying to restore image new disk
This drove me MAD for almost a weak now. Everytime I tried to restore my system image to another hard drive it would give me this error. As others may have the same issue and searching the internet did not turn up this solution I thought to repost this here. It can be usefull. Basically,...
Backup and Restore
Virtual Disk Manager - The Parameter is Incorrect
Hahah, what a joke. Okay, so I can't change the drive letter. Epic. It wouldn't be worth the total embarrassment for me if I owned a company responsible for this - I'd step away too. Do I need to use Partition Magic again? //The more I keep hearing/reading "do you have a backup?" -...
General Discussion
Error 0x80070057: The parameter is incorrect on Copy Paste
Hi, When trying to copy a file off a networked drive I get the following error: Error 0x80070057: The parameter is incorrect. This is the second time this has occurred. The first time I was trying to copy 4 files and 3 of them were copied correctly and the other was not. The solution then...
BSOD Help and Support
Dell 1545 Recovery failure - Parameter is incorrect
Hello all. I have a Dell 1545 running Win 7 Home Premium. I can't do a system recovery. I can't make recovery discs, none came with the computer, there is an easy-to-use function built into the hard drive, just do F8 at start-up. The only problem is, it isn't working. It goes through choosing the...
Backup and Restore
Changing Drive Letter for USB Ext HD - Parameter is Incorrect
Hi Everyone, I have a few external disk drives I'm accessing via USB. When I attempt to change the drive letter using Disk Management I get a popup window that says: "The Parameter is Incorrect." These are SATA drives that I previously had assigned drive letters like T, V or X while on a...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:04.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App