Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "VSC Engine" device not working properly (?)

28 Apr 2012   #1
Johnny8

MS Windows 7 Ultimate 32-bit
 
 
"VSC Engine" device not working properly (?)

Hello, today something strange popped up in my tuneup utilities:
-problem.jpg
So naturally I went ahead and followed the steps as seen in the screenshot. There is nothing wrong in my device manager.
What comes to mind though is that earlier today I was testing some gamepads that don't work properly. And when I plugged one in, it showed me that little exclamation icon (over the gamepad icon in the devices and printers window) for a while, after which it disappeared. But I unplugged it and went about fixing it. When I came back I noticed that "VSC Engine" thing in tuneup. So, what's that all about ? What is this VSC Engine ? False alarm ? What should I be looking at ? In device manager everything looks alright:
Name:  dm.jpg
Views: 13
Size:  39.5 KB

EDIT: After reading closely and enabling hidden devices I came across this:
-dayum.jpg




My System SpecsSystem Spec
.

28 Apr 2012   #2
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Wow you've actually got me on this one, I have no clue what it's talking about. The only place I've seen VSC before is when dealing with car computers.

Since it's not an actual device the only first piece of advice I can come up with for you is to run a system file check.
SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
28 Apr 2012   #3
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

scratch that other post I found something that makes sense. See here.
VSC.exe Windows process - What is it?

If that is the case I would suggest just removing the software associated with it.
My System SpecsSystem Spec
.


28 Apr 2012   #4
Johnny8

MS Windows 7 Ultimate 32-bit
 
 

Quote   Quote: Originally Posted by Maguscreed View Post
scratch that other post I found something that makes sense. See here.
VSC.exe Windows process - What is it?

If that is the case I would suggest just removing the software associated with it.
God I really have the talent of posting for help before I do all my own research. Sorry, guess this was about a Virtual Sound Canvas DXi something something. Apparently it was a software component left over from Band in a Box which I uninstalled the other day (the uninstall didn't go all that well, so I had to manually delete the main folder and some others + run a registry clean). Uninstalled said Virtual Sound Canvas just now, and there is no more error. In any case, thank you very much ! Good day !
My System SpecsSystem Spec
28 Apr 2012   #5
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Glad I was able to help, just remember google in the future.
When it comes to windows 7 it doesn't hurt to add
site:sevenforums.com
to your google searches
My System SpecsSystem Spec
Reply

 "VSC Engine" device not working properly (?)




Thread Tools





Similar help and support threads
Thread Forum
HDD shows in "Device Manager" but not in "DiskPart"or" Disk Management
Hi Guys, any ideas how to access my external hard drive device manager can see it but it does not appear in disc management. I use this HDD perfectly in my car HDD player. But when I try to connect it to my Laptop, it does not show up in disk management. Please check the attached screen...
Hardware & Devices
"USB Device Not Recognized" but the device is working fine.
This has become a great annoyance to me. Whenever I have my keyboard and mouse plugged into my computer (the mouse uses a USB port on the KB (it's a G-15)) I keep getting messages of "USB Device Not Recognized", however, the mouse and keyboard work perfectly fine. It's not really a problem, it's...
Hardware & Devices
"HWiNFO32 Kernel Driver" device is not working properly
I am told that ' "HWiNFO32 Kernel Driver" device is not working properly ' what can I do about this?
Drivers
Windows reports that the "cpuz133" is not working properly.
A device is not working properly which was suggested from avgpc tuneup 2013. Windows reports that the "cpuz133" is not working properly. Recommended solution to the problem Use Windows Update to check whether new device drivers are available. Proceed as follows: Open Device Manager...
Drivers
Built-In Webcam Not Working - "Unknown Device" USB Code 43
Hello, I have looked over many, many other forums and threads regarding this issue, but to no avail, have not been able to solve my problem. I'm starting to think that some hardware that communicates with my Webcam could be damaged - but I have not given up hope that this could be solved...
Hardware & Devices
the "local area connection" adapter is not working properly
Although my computer modem and internet was working all fine, after I boot it up again with fresh windows 7 ultimate, while creating new network connection, it shows whether modem is connected and is power on? where the problem might be.. help appreciated.
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App