Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: OWC Mercury Elite AL Pro Not Showing Up Suddenly


01 May 2012   #1

Windows 7 Home Premium 64bit
 
 
OWC Mercury Elite AL Pro Not Showing Up Suddenly

Hey everyone,

Today my external hard drive is suddenly not showing up in my computer or on my one file manager program. It is really weird cause the computer reads it and it comes up in disk management and in my device and everything says it is working fine.

I check for updates and everything with no luck. Rebooted it and tried all the simple fixes like that. I dual boot this computer and the external drive pops up on OS X Lion fine and lets me access it and everything, so it doesn't have to do with the hard drive itself.

It has been working fine for months and I really don't think I changed anything in the last day or two with the computer for it to suddenly not be working. Very strange problem. Windows basically says its working fine except it just won't show up in My Computer. I tried connecting with both a Firewire cord as well as USB and neither work. I spent hours checking all over the internet and still no luck.

Any advice? Please help!!

Thanks,
Dom


My System SpecsSystem Spec
.

01 May 2012   #2

Win7 Pro 64
 
 

Mine just died not to long ago. That Oxford chip set doesn't last very long on these things. Been looking for something else that doesnt use that chip set.
My System SpecsSystem Spec
01 May 2012   #3

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Bearcatrp View Post
Mine just died not to long ago. That Oxford chip set doesn't last very long on these things. Been looking for something else that doesnt use that chip set.
You have the same brand? Thing is, it works completely fine when I boot into the Mac side.
My System SpecsSystem Spec
.


02 May 2012   #4

Windows 7 Home Premium 64bit
 
 

My roommate has the exact same model as mine and he just tried to plug his into my computer and the exact same problem is occurring. I am pretty sure the external hard drive itself is fine and it something with Windows 7. Any advice?
My System SpecsSystem Spec
02 May 2012   #5

Windows 7 Home Premium 64bit
 
 

Got it. Turns out after messing with its settings, it was somehow marked as unlabeled and I simply assigned a new drive letter to it and it immediately popped up working! Solved!
My System SpecsSystem Spec
05 Jun 2012   #6

Windows 7 Home Premium 32bit
 
 

Hi justananimal32. Specifically what settings did you have to change? I am experiencing the same problem!
My System SpecsSystem Spec
05 Jun 2012   #7

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by runningdude86 View Post
Hi justananimal32. Specifically what settings did you have to change? I am experiencing the same problem!
All I simply did was go into control panel -> system and security -> administrative tools -> computer management. Then hit disk management on the left hand side. Or hit start then run and enter diskmgmt.msc to get to disk management faster.

Once in disk management go down and right click on the drive you are having an issue with (if there are no names distinguish it by the size) then hit change/assign drive letter or paths and add a new drive letter to it. That's all!
My System SpecsSystem Spec
05 Jun 2012   #8

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by justananimal32 View Post
Quote   Quote: Originally Posted by runningdude86 View Post
Hi justananimal32. Specifically what settings did you have to change? I am experiencing the same problem!
All I simply did was go into control panel -> system and security -> administrative tools -> computer management. Then hit disk management on the left hand side. Or hit start then run and enter diskmgmt.msc to get to disk management faster.

Once in disk management go down and right click on the drive you are having an issue with (if there are no names distinguish it by the size) then hit change/assign drive letter or paths and add a new drive letter to it. That's all!
ah, those options appear greyed out to me, is you mercury elite formatted ad NTFS? I think mine is formatted as SATA, and thats why its greyed out?
My System SpecsSystem Spec
06 Jun 2012   #9

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by runningdude86 View Post
Quote   Quote: Originally Posted by justananimal32 View Post
Quote   Quote: Originally Posted by runningdude86 View Post
Hi justananimal32. Specifically what settings did you have to change? I am experiencing the same problem!
All I simply did was go into control panel -> system and security -> administrative tools -> computer management. Then hit disk management on the left hand side. Or hit start then run and enter diskmgmt.msc to get to disk management faster.

Once in disk management go down and right click on the drive you are having an issue with (if there are no names distinguish it by the size) then hit change/assign drive letter or paths and add a new drive letter to it. That's all!
ah, those options appear greyed out to me, is you mercury elite formatted ad NTFS? I think mine is formatted as SATA, and thats why its greyed out?
Sata isn't a drive format though, but yes mine is formatted as NTFS. All of those hard drives are by default formatted as NTFS so I think yours should be too. Upload a screen shot of it if you can so I can try and help ya.
My System SpecsSystem Spec
Reply

 OWC Mercury Elite AL Pro Not Showing Up Suddenly




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:36 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33