Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Advent Roma 2000 - Constantly powers on/off with no display.

03 May 2012   #1
rikstaparr

Windows 7 32-Bit Professional
 
 
Advent Roma 2000 - Constantly powers on/off with no display.

Hi

Specs:

Advent Roma 2000
Intel Celeron C900
Win 7 Home Premium
4GB DDR2
320GB HDD
Intel Mobile 4 Series Graphics

I have removed the battery, held the power for 30 seconds and then connected just the mains and the problems remains.

I have removed the Heat Sink and cleaned out the dust and replaced

I have tried another RAM chip

I have tried another HDD

The only other thing I can think of is to remove the BIOS battery, but if anyone could please help then it would be greatly appreciated, many thanks in advance.


My System SpecsSystem Spec
.

04 May 2012   #2
rikstaparr

Windows 7 32-Bit Professional
 
 
Anyone

Anybody?!?!?
My System SpecsSystem Spec
Reply

 Advent Roma 2000 - Constantly powers on/off with no display.




Thread Tools





Similar help and support threads
Thread Forum
Problem with my partner's Advent Roma 1001 laptop.. OEM SLP..
I posted this in a another thread and felt that maybe it'd be better if I created it's own thread, to get the attention it needs.. :) Please don't think I'm cross-posting.. I have a problem with my partner's Advent Roma 1001 laptop.. I have to start by stating that the label on the rear...
Installation & Setup
powers on but no display, boot, beeps
i have this pc about 7 yrs. it powers on but no disp. boot beeps, but the fans, hdd, dvd rom works. my psu is not branded btw. 540w, and the prob occured when i smelled something burned or toased. i just cant tell surelly. note: i have no vcard, also tried reseating cmos. checked the cpu hsf...
Hardware & Devices
pc powers on but no display, beep or anything
so i had this 6 yr old pc when i turn on the power it doesnt show any display, bios, or beep sounds. before this.problem occured i just cleaned out the dust inside.the pc.and after i turned it on.in displays.nothing. i also tried seating the loosen parts properly i also tried reseting the bios...
Hardware & Devices
Computer powers up, but nothing on display.
Hello all! Recently my computer has been giving me some strange troubles. The Past Two Days: Two days ago I was messing with overclocking my pc (via n overclock dial that is on my motherboard) and had it all working fine, but decided I didn't need to overclock. After bringing my ghz back to...
General Discussion
Excel 2000 display issues
Has anyone encountered this issue before with Excel 2000 in Windows 7 (professional 32bit). We are testing windows 7 on some Pc, and those users are using Office 2000. Everything works fine, however, sometimes users launch excel (by double clicking on an XLS file) and excel come up like the...
Microsoft Office
Display constantly freezes after RC1 install
I was using the Beta since Feb. with no problems whatsoever. When the time limit was up I installed the RC1. I did a freesh install, not an upgrade. Ever since the install, my display will freeze at random and the pc requires a hard reboot. I initially assumed it was a video driver issue. First, I...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App