Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win 7 New Install -> Secondary SATA HDD does not auto mount

03 May 2012   #1

Windows 7 Professional 64bit wSP1
Win 7 New Install -> Secondary SATA HDD does not auto mount

Hi everyone

I just put together a new build but am having a bit of weird problem.

When I boot into Windows, my secondary SATA drive does not get auto mounted so it shows up on "My computer". Every time I boot I need to go and designate a letter for it (via Disk management). Once I do, the drive shows up and everything is dandy until I boot again and have to repeat the steps.

The drives (both) are detected fine via the UEFI bios and Windows disk management itself.

The specs are:
  • Intel Core i7-3920K Sandy Bridge-E LGA 2011
  • ASUS Sabertooth X79 LGA 2011 Intel X79 SATA 6Gb/s USB 3.0 ATX Intel with UEFI BIOS and latest BIOS
  • ASUS GTX580
  • G.SKILL Ripjaws X Series 16GB (4x4GB)
  • Plextor SSD SATA III 128Gb
  • WD Caviar Black SATA III 1TB (3 partions)
  • CORSAIR Enthusiast Series TX750 (which is getting replaced with a 850W version)
  • Windows 7 Professional x64 (clean install) with SP1

I have the system to boot via UEFI to the Plextor SSD drive, and have the WD HD has a backup drive.

I installed all the drivers included on the ASUS MB install CD (which includes SATA, etc).

Any ideas?

My System SpecsSystem Spec
03 May 2012   #2

Windows 7 Professional 64bit wSP1

Thanks everyone for the help, but I fixed it.
My System SpecsSystem Spec
04 May 2012   #3

Windows 7 Home Premium SP1

Quote   Quote: Originally Posted by R1chard View Post
Thanks everyone for the help, but I fixed it.
It might be very helpful to me if you were to tell how you fixed the problem.
My System SpecsSystem Spec


 Win 7 New Install -> Secondary SATA HDD does not auto mount

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Secondary SATA drive not recognised
I bought a Seagate 2Tb internal 3.5 inch drive intending to install it in my desktop as a secondary drive. The desktop currently has two 500Gb disks in a Raid 0 (striped) array. One SATA port is free and I connected the new disk to this. The system did not recognise the disk so I put it in a caddy...
Hardware & Devices
New sata secondary hardrive not showing up in Windows
New member here, In the process of completing and setting up a new build. As recommended installed windows 7 prof on Samsung 830 256gb SSD with no problems. During installation was only hard drive hooked up. Now I am trying to install a Seagate 320gb sata drive to use as a storage drive. The...
Installation & Setup
secondary SATA HD
I have been trying to plug in a secondary HD using SATA cables. I have 4 SATA ports 1 has my current HD in the other has my DVD/RW in but wen plugin a second HD in to one of the other ports it did not respond in any way what so ever, does anyone know why that might be
Hardware & Devices
AHCI SATA disk E: suddenly DISAPPEARS (auto-ejects..?!)
I have been using XP for many years, now I'm building a pc for the son of a friend of mine, with Windows 7 x64. I decided to go for a Corsair P64 SSD for (C:), and a 1 TB WD Caviar Black for (E:). I connected first the SSD and installed Windows 7, then after I had installed drivers through...
Hardware & Devices
Secondary SATA HD Turns off
I've searched for an answer, but just can't seem to find the solution. My secondary HD, used for storage and backup, turns off at after about 5 minutes. This is a 1 TB drive used for storing all of my videos, music and photos. The problem is that I access this drive quite often; edit a photo or...
Performance & Maintenance
Virtual Mount Install
Is there any way to virtually mount the ISO file and install it from there? I would rather clean install if possible, but if I have to upgrade that is fine. Is it possible without discs?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:36.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App