Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Hardware & Devices panel not loading

08 May 2012   #1
Rontro

Windows 7 Home Premium 64bit
 
 
Hardware & Devices panel not loading

Hello,

My problem started with Microsoft Word hanging while loading. I followed the troubleshooting guide for that and was able to load word if I stated it in safe mode (winword.exe /a). I could not find any issues that caused this so I decided to approach the problem from another angle.

I went to the device & hardware panel and found that I could not load it. However, if I rebooted the machine I could load it once, but could not do so a second time. I have tried all of the troubleshooting guides I could find and still had no luck. I believe the problem is related to the printer because one of the fixes I tried was to run a checker that tested for printer spooler errors. This test could never be completed but nor has it timed out.

System:

OS Name Microsoft Windows 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Name VOYAGER
System Manufacturer Hewlett-Packard
System Model p6654y
System Type x64-based PC
Processor AMD Athlon(tm) II X4 630 Processor, 2800 Mhz, 4 Core(s), 4 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 6.04, 9/7/2010
SMBIOS Version 2.6


My System SpecsSystem Spec
.

08 May 2012   #2
F5ing

Windows 7 Ultimate x64
 
 

Try running sfc /scannow from an elevated command prompt to check for corrupted protected files.

It may take running it multiple times to correct the errors that it finds.
My System SpecsSystem Spec
09 May 2012   #3
Rontro

Windows 7 Home Premium 64bit
 
 

I have tried that. I will try to run it a few times, and check back.

-Ron
My System SpecsSystem Spec
.


09 May 2012   #4
F5ing

Windows 7 Ultimate x64
 
 

Also try a System Restore to a point in time that's prior to the problem starting.
My System SpecsSystem Spec
10 May 2012   #5
Rontro

Windows 7 Home Premium 64bit
 
 

I have done a system restore and the problem persists. Also I ran SFC /scannow several times and it found no issues. I am convinced that it is a program that is running in the background and am currently using the process of elimination to figure it out. Also, the problem is with the print spooler or least something in the print system.

-Ron
My System SpecsSystem Spec
10 May 2012   #6
F5ing

Windows 7 Ultimate x64
 
 

Does Device Manager now load properly?
My System SpecsSystem Spec
10 May 2012   #7
Rontro

Windows 7 Home Premium 64bit
 
 

Nope not yet. Still am working through start-up programs to see if one of those is the problem. I have confirmed that the problem is gone in safe mode. Should have checked that early on.

-Ron
My System SpecsSystem Spec
10 May 2012   #8
event3horizon

Windows 7 Home Premium 64 bit
 
 

check to see if third party services and startup programs are causing this now that we know it's gone in safe mode. go to MSCONFIG and services tab, click hide all microsoft services, click disable all, then click apply. Next click startup tab, and disable all. Apply and reboot.

If problem is still gone then its third party problem.
My System SpecsSystem Spec
10 May 2012   #9
Rontro

Windows 7 Home Premium 64bit
 
 

I found the problem. It was a 3rd party program that allowed me to print to a PDF file rather than the printer. It was put on my machine by the manufacturer and was on a free trail basis. My best guess is that trial period ran out and the program did not start up properly. I had to uninstall the thing in safe mode to get the bugger off! All is working normally now.
My System SpecsSystem Spec
10 May 2012   #10
F5ing

Windows 7 Ultimate x64
 
 

Could you reply back with the name of that pdf "print to file" program?

It may very well help others...

Kind of surprising that it was responsible for blocking the loading of Device Manager. Or maybe not too surprising as Windows would treat it as a psuedo-device. Did you check that you could now load Device Manager?
My System SpecsSystem Spec
Reply

 Hardware & Devices panel not loading




Thread Tools





Similar help and support threads
Thread Forum
Devices & Printers not Loading
Whenever I click devices and printers, the green loading bar gets to a certain point and refuses to load past there. It's been persisting for a few months now. I've tried checking device manager and everything is working fine. I also went into bluetooth services & bluetooth support service and...
Hardware & Devices
Biometric Devices not showing up in Control Panel
I have looked for help all over the internet and cannot find a solution: My fingerprint reader shows up in Device manager, but I cannot do anything with it if Biometric Devices does not show up in Control Panel!! what's wrong? I have ALL the right and updated drivers. thanks! Joe
Hardware & Devices
Devices and Printers not loading.
I joined this site because the thread on this does not fix my problem. I installed Win7 Professional and the devices and printers windows was loading just fine. Then I noticed that it wouldn't load at all, and just get the green status bar thing across the top of the screen. Here is what I...
Hardware & Devices
Renaming Devices in Windows Sound Control Panel
If I rename audio devices by the method indicated below, will there be any negative repercussions? I would assume that programs don't use those names to identify devices, but I want to double check. http://i.imgur.com/5YXM0.jpg
Sound & Audio
Devices and Printers keep loading
Hi there, on my Windows 7 my Devices and Printers keep loading. I enabled the Bluetooth support service but problem didn't solved. I don't have a Bluetooth device on my computer. Help pleases.
General Discussion
Devices and Printers Not Loading
Devices and printers just continues to search without finding anything. I have read in other threads where this is a Bluetooth support service problem and can be rectified by setting Bluetooth support service to automatic in local services. When I go to services and then try to set the Bluetooth...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:29.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App