Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: RAID array with chirping drives

11 May 2012   #1

Windows 7 Professional 64bit SP1
 
 
RAID array with chirping drives

I have a Dell Precision T3500 workstation (tower) running Win 7 Pro 64bit SP1 (with all MS updates in place.) The Dell's motherboard has an integrated SATA RAID controller but I have an external enclosure that has it's own hardware RAID controller so I don't want to use the motherboard or Windows to manage RAID, so in BIOS I have the controller mode set to AHCI.

The external drive enclosure is an Addonics Mini Storage Tower with an HPM-XU hardware port multiplier capable of managing different RAID levels (either by setting physical dipswitches on the PM or by using Jmicron software to configure from Windows.) Inside the enclosure, connected to the RAID PM are four Seagate ST2000DM001 Barracuda 7200RPM 2 TB SATA 6 GB/s NCQ 64 MB Cache 3.5-Inch Internal Drives, and the enclosure is connected via eSata cable to the Dell's integrated eSata port.

I used JMicron software in Windows to configure the drives into a single RAID 10 4TB volume. Drives 0+2 are striped into one large volume which is then mirrored on drives 1+3. In Windows Disk Management I formatted the partition as NTFS GPT (with 512K blocks I think, or maybe it was 1024.)

In Device Manager I show...

IDE ATA/ATAPI Controllers
ATA Channel 0
ATA Channel 1
ATA Channel 2
ATA Channel 3
ATA Channel 4
ATA Channel 5
Standard AHCI1.0 Serial ATA Controller
Disk Drives
Hitachi HDT725050VLA360 ATA Device (internal 500GB C: / ATA channel 0)
Hitachi HDT725050VLA360 ATA Device (internal 500GB D: / ATA channel 1)
Addonics H/W RAID 10 ATA Device (external eSata enclosure / ATA channel 5)

Everything is fine, it all works, it's really fast, I'm very happy with it, there's just one problem... the drives do this silly little chirpy thing on a regular schedule. It's not an "alarm," it's not a nasty loud "click," it's not grinding, it doesn't really sound bad or broken. I don't like drives to make any noise at all, so it makes me nervous.

I don't think they are failing, they are all brand new, just bought, not refurbs, burned in for about 10 days now. I do not believe this is a hardware failure or "dying" drives, they've been doing it since day 1, I'm just looking into it now. Instead of bad drives I think this might have something to do with Win 7 polling the drives or some kind of green power state or some setting in Windows, which is why I'm posting this here for this most wise and excellent forum.

Here's what the little buggers are doing...

When the enclosure is powered on and my PC is powered off, there are no lit orange drive LEDs on the enclosure, just the green power, and no chirping, drives are just quietly spinning like you'd expect them to.

When I boot into Dell BIOS system setup the enclosure initializes, single audible beep from the RAID PM, the orange LEDs all flicker and then light up solid, but there's still no drive chirping, they're still just quietly spinning.

However, once I boot all the way into Windows I get the following behavior...

If there's no interaction with Windows (I'm just observing the enclosure) I get:
4 little chirps (one per drive) accompanied by LEDs flickering in succession 0,1,2,3...
30 seconds pass...
4 very faint chirps w/ no LED flickering...
10 seconds pass...
this cycle repeats over and over

Here's a youtube video w/ audio of the chirping: http://www.youtube.com/watch?v=6xRit...ature=youtu.be * You can hear the "4 chirps w/ LEDs flickering" at 7 seconds and the "4 chirps w/o LEDs flickering" at 37 seconds. The cycle repeats again in another 10 secs, it's the same every time.

If I open Windows Explorer and expand the raid drive to see its subfolders I get:
4 slightly louder chirps, as though the heads are waking up, but they don't spin faster or anything and there's no apparent LEDs flickering, then back to that cyclical "no interaction with Windows" behavior.

If I copy several GB of files from the RAID drive to my desktop I get the normal operational sounds of the heads as you'd expect with any drives and the normal flickering orange enclosure LEDs as it copies, but... I still get the "no interaction with windows" chirping behavior in the background at the same 30 + 10 sec intervals. However... instead of 4 it's just 2. Apparently disk 0 and 2 (striped) are busy performing the reads so they don't chirp, but 1 and 3 (striped) are idle so they still do the chirping thing.

Sounds to me like there's something in Windows that's messing with the drives, trying to poll them or make them sleep or go green or ask them how they're feeling at the moment or something, but I checked windows system power settings and everything is on full blast with no sleep... the "standard AHCI 1.0 Serial ATA Controller" in device manager has no settings for power (other than saying it supports various power levels in the detail tab)... windows disk management doesn't seem to have any settings that would help... I flashed the enclosure's RAID PM firmware to the latest... and the Jmicron software doesn't have any settings for drive power or sleep modes that I can find. Other than that I don't know where to look, I'm at a loss.

The Addonics folks said that they'd recommend different drives. They said their RAID PM is SATA 3.0 native so my 2TB SATA 6.0 drives might be trying to pull too much power from their 150W enclosure power supply. Or possibly the drives I chose have some kind of power saving green mode and I should replace them with "normal non-green" SATA 3.0 drives. I'd really rather not go through all the pain of migrating 700GB of data and replacing these drives if there's some setting in windows I can just tweak. RegEdit setting? AHCI controller driver? Turn off Write Caching or set them to Quick Removal under drive policy? Maybe the drives are trying to conserve power and windows keeps waking them? Maybe Windows is telling them to sleep and they don't want to? I'm at a loss. Any suggestions would be greatly appreciated.

My System SpecsSystem Spec
.

Reply

 RAID array with chirping drives





Thread Tools



Similar help and support threads for2: RAID array with chirping drives
Thread Forum
New RAID Array and Clean Install Win7HP-Help with RAID Driver Install Installation & Setup
RAID array isn't recognized? Hardware & Devices
Solved RAID - deleted RAID array, Windows 7 ok but I have questions Hardware & Devices
Help w/ RAID Array Hardware & Devices
Solved SSD as cache for HDD RAID ARRAY help Hardware & Devices
Raid 0 Array Hardware & Devices
RAID Array Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:14 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33