Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Problem. Driving me nuts!


16 May 2012   #1

windows 7 home 64 bit
 
 
USB Problem. Driving me nuts!

It may be coincidental, but I bought a memory stick off ebay which turned out to be fake. Since that time, I found that every time I turn on my Acer Aspire laptop it will not recognize anything (stick, drive, camera, ipod etc.) plugged into the USB ports or a card in the memory card socket.
No messages or anything, just no reaction to anything plugged in.
DeviceManager shows nearly all the ports (Intel ICH9 Family USB Standard and Enhanced Controllers) and the USB Root Hub(s) with little yellow exclamation marks.
At first I uninstalled all the hubs manually and restarted the computer and this got the hubs working, but next time I booted up, the same thing had happened and I had to go through the whole thing again.
I then found that the Troubleshooter and Windows Fix It (ha ha) would reinstall all the hubs automatically, but they would still be corrupted next time I booted up, so I had to go through the whole rigmarole again to use the USB ports.
Each time i use the Troubleshooter it fixes all the ports, but I get a message - "Hardware changes might not have been recognised" and a yellow warning triangle.
Fix It does exactly the same with nothing else to offer regarding the "Hardware changes...." message.
Next time I start the computer I am back to square one!
I have tried updating the drivers - I always get told they are up to date.
My computer OS is totally up to date with "Windows Update".
I always remove the USB devices properly.
Another post elsewhere suggested checking that the Windows Installer in Services is set to Automatic - it is.
How do I get it to recognize the hardware changes so that it starts up with all the ports working every time?

My System SpecsSystem Spec
.

16 May 2012   #2

Windows 7 Ultimate x64
 
 

What is your computer model ?
My System SpecsSystem Spec
16 May 2012   #3

windows 7 home 64 bit
 
 

Its an Acer Aspire 5732Z. Intel T4300 processor.

This has been going on for about a month now and I have looked at lots of similar posted problems for help. This "hardware changes..." message seems to be generated a lot when people have problems with sound, and there are other problems with USB ports on Win 7, but I have not seen a post about my particular problem anywhere, except for one poor soul with the same thing who posted a cry for help on another forum but got no replies.
My System SpecsSystem Spec
.


16 May 2012   #4

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi fedupwith72, Welcome to the forums, Visit the acer website and download and reinstall the motherboard chipset, this contols the usb ports which have got corrupted, You may also try right clicking on the little yellow exclaimation marks and selecting " update driver" see if windows update will find the drivers for you
My System SpecsSystem Spec
16 May 2012   #5

windows 7 home 64 bit
 
 

I've tried updating the drivers. They are up to date. even tried updating via the net. same result.
One thing that puzzles me is that it has 7 USB controllers and 7 hubs in Device Mangr, but only two physical ports and one card slot on the laptop. I'll try the chipset update and report back Thanks.
My System SpecsSystem Spec
16 May 2012   #6

Win7 Home Premium 64x
 
 

The 7 Controllers and Hubs listed is to detail how many the USB Host Controller can handle. For example say a Desktop has 8 controllers supported. It has 4 on the back panel and 2 in front. that makes 6 already installed. The computer owner could add another USB card to the expansion slot with 2 extra USB ports.

In each USB port, you can use a USB Hub that acts as 4 USB ports to 1 USB port. This does not affect the total. Usually I think the Host controller can handle about a 100 connections so usually, you wont reach that cap. Its 127 according to wiki: USB hub - Wikipedia, the free encyclopedia

It is possible that when you plugged in the fake device, it damaged the Host Controller. I have not seen this before, but seems possible. the USB port has a good bit of power running through it.
My System SpecsSystem Spec
16 May 2012   #7

windows 7 home 64 bit
 
 

Thanks for that USB info.
The stick was all packaged right and looked like a real Kingston stick, but instead of being the size advertised it was just 4gb.
I seem to have had problems since then.
I went to the Acer site and found the Chipset Drivers it recommends (2009), but when I tried to load them I got a "these are older than the installed ones" type message. 9.1.1.1015 instead of 9.1.1.1020. So I didn't install them.
I went to the Intel site and the Chipset they show as 9.1.1.1020 is for XP and 2003 so that seems to be just a revision number. .
There were loads of other free chipset download sites on Google, but they looked very dodgy!
Intel do a chip ID check, but it does not support Windows 7 64bit, so I am not 100% sure which chipset I have. Intel update checker says its a 6, 5, 4, 3, 900 type chipset.
As I have not updated chipset drivers before, should I just the earlier version, or should I load one of these latest .inf chipset files?Support for the Intel® 945 Express Chipset Family
My System SpecsSystem Spec
17 May 2012   #8

Windows 7 Ultimate x64
 
 

My System SpecsSystem Spec
19 May 2012   #9

windows 7 home 64 bit
 
 

Thank you for your help so far but:
I installed the chipset drivers and it has not made any difference. When I start the laptop all the USB ports and hub are u/s. I have to run the troubleshooter and this restores them to normal, but with the same "Hardware changes..." message. They work until the PC is turned off but when I turn it on again I have to use the troubleshooter again to get them working.
My System SpecsSystem Spec
19 May 2012   #10

Windows 7 Ultimate x64
 
 

My System SpecsSystem Spec
Reply

 USB Problem. Driving me nuts!




Thread Tools



Similar help and support threads for2: USB Problem. Driving me nuts!
Thread Forum
Faster than the eye splashscreen driving me nuts General Discussion
Finding this driver is driving me nuts! Drivers
BSOD is driving me NUTS! BSOD Help and Support
This is driving me nuts :( General Discussion
Driving me nuts !!!!!!!!!!!!!!! BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:27 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33