Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot access bios after SSD upgrade


30 May 2012   #1

7 ultimate 64bit
 
 
Cannot access bios after SSD upgrade

Hi everyone, I recently purchased SSD drive and started installing windows on it. And thats where the problems began:
-only keyboard worked on the installation
-when windows started, mouse not working(tried ps2 also)
-when shutting down, got blue screen saying about "bugcode usb"
after that few reinstall tries, no help.

One thing that I forgot/didn't know was some achi mode which had to be enabled in bios.
Well now I cannot do anything because my ps2 keyboard wont work in bios.
Tried search but found nothing useful. What should I do? Will I need to buy new motherboard to get SSD working? current version is GIGABYTE GA-MA78G-DS3H, I contacted technical support and they said to enable achi, and install some updates on windows installation process. But I cannot use bios, anybody could help? I'm getting fustrated and will do anything that is necessary. Thank you!

My System SpecsSystem Spec
.

30 May 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Hello heromanni. Welcome to the forum.

First - Disconnect the SSD, and any other connected hard drives, and try and get into the BIOS without it.
EDIT: If you can get into the BIOS, note your current settings, the perform a "Reset BIOS Defaults" (usually on the EXIT tab). then restart, enter BIOS again, and change the settings you need.

If that does not work then perform a Clear CMOS or CLRTC procedure:
Typically:
  • Shut down the computer > remove the power cord.
  • Remove the 3v battery.
  • Move the CLRTC jumper from pins 1-2 to 2-3.
  • Touch a metal part of the case and Press and Hold the reset button for approx. 30 seconds to discharge all power from the board.
  • Put the CLRTC jumper back on pins 1-2.
  • Replace the 3v battery > replace the power cord > boot.
  • Immediately go back into BIOS and reset all your preferred settings. If the CLRTC worked you will need to reset the date and time.
I would leave the SSD out while performing the CLRTC.
My System SpecsSystem Spec
30 May 2012   #3

7 ultimate 64bit
 
 

Thank you for information. I eventually got into the bios, changed ahci to enabled and began to install windows again, during the installation I installed driver called "motherboard_driver_ahci_amd_sb7xx_bootdisk_win7-64bit" but windows suddenly stops and i get bluescreen "bugcode usb driver", after restart windows will not continue installation What can I do, running out of ideas. Sorry and thank you
My System SpecsSystem Spec
.


30 May 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Don't install that driver.

Windows 7 has it's own AHCI driver native. You do not need to preload any driver during installation like we did with Windows XP. You just set AHCI in BIOS and that's it.

After you start the installation DVD, go into advanced setup, and format the hard drive to erase everything you did previously, then try the installation again, just letting Windows 7 do it's thing.

After Windows 7 is installed then you can go in and install the manufacturer's AHCI driver, or Intel's Rapid Storage driver.
My System SpecsSystem Spec
31 May 2012   #5

7 ultimate 64bit
 
 

Well, the problem seems to be that bsod saying "bugcode usb driver", no matter how I try to install windows. (I'll give it a try without the preload driver, once my keyboard happens to work(not in every boot, if it does work it works as described below.)

When I was able access bios, my keyboard(ps2) was not working correcly, it came 3 buttons late. Like if I press 3 times up arrow then enter, as I press enter I get the up arrow action. So there is something wrong in there.

Should I do this -Clear CMOS or CLRTC procedure-?
My System SpecsSystem Spec
31 May 2012   #6

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Yes. Anytime you are dealing with a problem at that most basic level (BIOS boot) then performing the CLRTC will eliminate a BIOS corruption as a cause.

I am assuming the keyboard is a USB or PS2 (wired) keyboard? If it is USB connected then try a different USB port.

The keyboard "driver" is hard coded into the BIOS instruction set. So a wired PS2 keyboard should always work on a standard PC when operating at the BIOS level. A USB keyboard will normally work on a modern motherboard with a USB controller in the BIOS instruction set.

What was the result when you disconnected all the hard drives?
With all drives disconnected can you get into the BIOS settings normally?
Does the keyboard work normally?

You really should test the system without the drives installed before you perform the CLRTC/ClearCMOS. Otherwise you might lose some important clues as to what is going on. The key is that you say this behavior started only after you installed the SSD. So that should be your first focus.

There is no danger in harming the system in doing one or the other first, it is just a matter of gathering more information.
My System SpecsSystem Spec
31 May 2012   #7

7 ultimate 64bit
 
 

I have been using ps2 keyboard all the time. When I took all harddrives off and entered bios, the result was as I described, keyboard is not working correctly(altough it works).

Yes, everything started when I installed ssd. Now whether or not is the ssd plugged the keyboard will not work properly.

My last attempt to install windows was the best so far(I unplugged all usb, did fresh install), at first I got blue screen when trying to shut down(same bugcode usb). next boot and after installing windows updates, it became better. Now the thing is, windows works fine except out of 7 (bootup)tries I got windows to regognize mouse twice.

So there is something weird in there, nevertheless the bios is not working correctly. Hope I don't make this too messy?

Thank you, I quess I've made some success
My System SpecsSystem Spec
31 May 2012   #8

Microsoft Community Contributor Award Recipient

Windows 7 64 Bit Home Premium SP1
 
 

Time to try the CLRTC.
Be sure to disconnect the SSD before doing so.
My System SpecsSystem Spec
31 May 2012   #9

Windows 7 x64 Ultimate
 
 

It may be that your motherboard could use a BIOS update. Especially if it's older...
My System SpecsSystem Spec
31 May 2012   #10

7 ultimate 64bit
 
 

I just got instructions how to update bios, my current is the oldest version.

Got to update it today and I'll post how it goes.

Quick question, should I update first and then CLRTC or the other way around?
My System SpecsSystem Spec
Reply

 Cannot access bios after SSD upgrade




Thread Tools



Similar help and support threads for2: Cannot access bios after SSD upgrade
Thread Forum
Cannot access BIOS General Discussion
How To Access BIOS (Win 7, 64 bit) General Discussion
BIOS Upgrade Help Drivers
Can't access BIOS General Discussion
Solved BIOS: Can access BIOS utility, but cannot change settings. General Discussion
How To Access BIOS Chillout Room
Bios Access Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:35 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33