Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Wireless adapter doesn´t activate at windows startup

04 Jun 2012   #1
spettow

Windows 7 64 bits
 
 
Wireless adapter doesn´t activate at windows startup

Hey guys.

I just bought a Sager notebook, model np9170, with ivy bridge 3610qm, amd 7970m. The other components are standard. The wireless card is a Realtek RTL8723AE.

I've installed windows 7 64 bits and the drivers from sager DVD.

The wireless card is not working correctly. After installation, the adapter works correctly, but when I restart windows, the wireless adapter is not enabled, despite the wireless LED remains lit.

The function keys (fn + f11) does not work. I can only use the wireless by following these steps: by going into Device Manager, deactivating and reactivating the wireless realtek. After doing this, it works normally and the function keys return to work.


However, after restarting Windows, the wireless stops working again, and I have to repeat the steps: deactivate and reactivate the card realtek in device manager.


I made a small fix that works around the problem: I created a batch file with the following lines: "netsh interface set interface NameOfAdapter disable; netsh interface set interface NameOfAdapter enable" and put this batch to run on windows startup... Now when entering the windows, the network is disconnected and connected, and works normally... It´s a small hack, but works...


Does anyone have any idea how to resolve this issue definitively? Thanks!


My System SpecsSystem Spec
.

04 Jun 2012   #2
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

The link below shows two possible fixes for this problem. One is to uninstall which ever anti virus is being used and reinstall drivers. The other goes into services to make sure that “WLAN AutoConfig” is set to start automatically.

There are more details provided in the link below.
Can't enable my wireless adapter in Windows 7 - Microsoft Answers
My System SpecsSystem Spec
04 Jun 2012   #3
spettow

Windows 7 64 bits
 
 

Thanks for the answer.

I do not use any antivirus or firewall.

And i have checked the settings in WLAN AutoConfig on services.msc, it's marked to start automatically.

I think my problem is different =(
My System SpecsSystem Spec
.


04 Jun 2012   #4
spettow

Windows 7 64 bits
 
 

small update: I realized that when i enter windows in safe mode with network support, the wireless adpater runs fine, without problems...

So it's a problem that affects the normal version of windows, but does not affect the safe mode.

Any ideas?
My System SpecsSystem Spec
05 Jun 2012   #5
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

Sounds like a driver issue then. Are you using the absolute latest drivers for the wireless card? The driver discs that ship with systems are usually good for only one thing...drink coasters for when you do the clean install. The drivers on disc are often outdated by the time you get the computer delivered.
My System SpecsSystem Spec
05 Jun 2012   #6
spettow

Windows 7 64 bits
 
 

Quote   Quote: Originally Posted by DeaconFrost View Post
Sounds like a driver issue then. Are you using the absolute latest drivers for the wireless card? The driver discs that ship with systems are usually good for only one thing...drink coasters for when you do the clean install. The drivers on disc are often outdated by the time you get the computer delivered.
At the site of SAGER had a newer driver. I uninstalled the drivers that came on the DVD and installed the new driver but did not solve the problem.
Is there any chance the problem is caused by a non-legitimate copy of windows?
My System SpecsSystem Spec
05 Jun 2012   #7
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

With any non-legit copy of Windows, it's always possible to have strange issues. There's no telling how the files have been tampered with or what kind of malware has been tucked into the OS.
My System SpecsSystem Spec
06 Jun 2012   #8
spettow

Windows 7 64 bits
 
 

Hey guys. Problem solved here.
The problem was a bugged copy of windows.

Thank you everyone who helped
My System SpecsSystem Spec
Reply

 Wireless adapter doesn´t activate at windows startup




Thread Tools





Similar help and support threads
Thread Forum
Turn Windows 7 Laptop into Wireless Repeater with One Wireless Adapter
Nowadays, wireless router is a basic device at home because wireless access point (AP) is required. Sometime, a wireless repeater is also needed in a big house especially that with a big yard. Actually, without wireless router, only a Windows 7 laptop can be turned into a WiFi hotpot or a wireless...
Network & Sharing
Wireless Network Adapter doesn't work anymore
Hello, i have an ASUS X55VD and the wireless adapter isn't working anymore. I tried troubleshooting, reinstalling the ASUS drivers (Ralink and Atheros drivers), uninstalling and uninstalling & deleting the driver from device manager. I tried uninstalling the antivirus (ESET SS 8). The wired...
Network & Sharing
PCI-E intel 5300 wireless doesn't work. Then the USB wireless adapter
Dear all, I thought I have met this problem before before my two wireless adapters both stopped working. PCI-E INTEL 5300 TP-LINK WN821N My case is a little different from those I found on this forum. 1. When I upgraded my thinkpad x200 to win7 64bit, I don't have "Wireless Network...
Network & Sharing
Marvell Libertas Wireless LAN Client Adapter Doesn't work
Marvell Libertas 802.11 b/g Wireless LAN Client Adapter Doesn’t Start My PCI card.http://cdn.sevenforums.com/images/smilies/mad.png I have installed a Rosewill RNX-G300E Wireless PCI card. I have attempted to install the drivers for it but keep getting ‘This device cannot start. (Code 10)’. As...
Drivers
Windows 7 doesn't detect wireless network adapter
nvm.. solved
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App