Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Network Adapter Not in Device Manager

17 Jan 2009   #1
yobeske

vista / windows 7
 
 
Network Adapter Not in Device Manager

I've installed windows 7 as upgrade to vista home premium in my Toshiba Satellite P205D-7802 laptop. Most everything seems to be running fine. My big problem is my network adapters (for wired and wireless - they are different) don't show up at all in the device manager?

I understand the whole installing a driver with compatibility mode but that seem quite impossible if the system does not even find the devices?

System was bought new 1 year ago with visa home premium and everything was working fine before the install. I have the drivers to install if I need the old vista drivers but it does not good.

I can install the drivers and when it gets done it says they are no good until the device is attached?

Any and all help is appreciated.


My System SpecsSystem Spec
.

18 Jan 2009   #2
doubleoseven

Windows 7
 
 
same problem here

same problem here! any ideas anyone?
My System SpecsSystem Spec
18 Jan 2009   #3
davehc
Microsoft MVP

Vista and now 7 in 32 and 64 bit.
 
 

"I understand the whole installing a driver with compatibility mode but that seem quite impossible if the system does not even find the devices?"
Does that mean you have tried it? It should not be neccessary to find the devices, in order to install the drivers.
Just in case, right click the setup.exe for the driver (atheros?) and under the compatibility mode select Vista RTM. Also select run in Admin mode. It is rare that the Vista drivers do not work for 7.
My System SpecsSystem Spec
.


18 Jan 2009   #4
yobeske

vista / windows 7
 
 
yes davehc

I've tried it and all of your suggestions. I seems that windows 7 for some reason is seeing the network adapters here as just plain pci-e devices. windows 7 just is not seeing the devices for what they are. Oh well...think i'll have to wait for toshiba to actually decide to support this - may take a while.
My System SpecsSystem Spec
18 Jan 2009   #5
anykey

Dual boot XP Pro and Seven/7127
 
 

Same here.
I use Netgear WG111T adapter.
It keeps cutting out.
I have no suitable icon in NotifTray to reconnect.

If I switch to allowing windows to do the connection work would that help do you think?

Is there a Netgear driver for Win7.
My System SpecsSystem Spec
18 Jan 2009   #6
davehc
Microsoft MVP

Vista and now 7 in 32 and 64 bit.
 
 

Have you looked here, yobeske. Latest Vista drivers for your laptop, including the wireless and LAN
My System SpecsSystem Spec
18 Jan 2009   #7
yobeske

vista / windows 7
 
 
where davehc

I don't see any links in your post?
My System SpecsSystem Spec
18 Jan 2009   #8
davehc
Microsoft MVP

Vista and now 7 in 32 and 64 bit.
 
 

LOL. I bet that confused you! Sorry:
Model Content Page#
My System SpecsSystem Spec
19 Jan 2009   #9
yobeske

vista / windows 7
 
 
yup

I tried the current drivers from their site. The problem lies in the fact that windows 7 does not correctly identify the pci-e drivers for the motherboard. It sees what they are but the drivers are sitting there in device manager with the yellow symbol. Until that is fixed I think i'm stuck.
My System SpecsSystem Spec
19 Jan 2009   #10
ebartolon

Windows 7, Windows Vista
 
 

me too. Please Someone fix
My System SpecsSystem Spec
Reply

 Network Adapter Not in Device Manager




Thread Tools





Similar help and support threads
Thread Forum
How do I reinstall 'network adapter' from device manager?
So, I just deleted (including from my computer) this 'atheros' thing which is under the network adapter.. now. I can only use broadband but not wireless.. what do i do? so there is basically i cannot see the network adapter section anymore. however whenever I plug in the broadband it came out like...
Network & Sharing
network adapter missing from device manager
my power flickered off and on really quick and when my pc came back up, the internet would not work. after investigating i found out that the network adapter is missing from the device manager. i have tried to re-download drivers for my network adapter/mobo and this has not solved my problem. i...
Network & Sharing
Network adapter not showing on device manager
Hi, yesterday i got my friend to download windows 7 on my mac via bootcamp. i got it back today and i tried my wireless at home but didn't work. so i tried LAN line as well, which didn't work either. i went through few sites, they all told me to go on device manager and update my drives. The...
Network & Sharing
Missing network adapter, but device manager OK
Hi all. A very weird problem just happens to my desktop, I hope anyone could help me to avoid a complete reinstall. It was working fine, I didn't install or change nothing (mostly is used as MediaCenter). It was working perfectly without any change for months. Then I shutdown one day as always,...
Network & Sharing
network adapter not showing up in device manager
http://cdn.sevenforums.com/images/styles/window7/statusicon/user_online.gif http://cdn.sevenforums.com/images/styles/window7/buttons/reputation.gif http://cdn.sevenforums.com/images/styles/window7/buttons/report.gif Marvell...
Hardware & Devices
No network adapter in Device manager
Hello, After using system restore my internet connection has a red x. I have seen this before so I went into device manager so see what's up. There is no network adapter listed. I did a scan for hardware changed and nothing. I have an Atheros network driver folder on my desktop so I ran the...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App