Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: AHCI Issue

25 Jun 2012   #11
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

If you didn't format it, then there shouldn't be any partitions showing on the drive, at all. Use the DISKPART option to clean the drive first, and then try installing. You mentioned in an above post that you formatted your C drive....so that's where I was getting it from.


My System SpecsSystem Spec
.
25 Jun 2012   #12
Night Hawk

W7 Ultimate x64/W10 Pro x64 dual boot main build-remote pc W10 Pro x64 Insider Preview/W7 Pro x64
 
 

If the drive is "raw" to begin with why you would need to clean it? The drive tools on the 7 dvd will tend to partitioning and formatting the drive for use. Other options would be used if he didn't want the 100mb System Reserved partition created to see the drive made ready.

With the latest 7 install here that was with the Native ide setting. Later when changing it to AHCI 7 went to work configuring the two OS drives as SCSI devices and prompted to restart on the first desktop upon re-detection of the other two storage drives.

One way to find out if the drive you are trying to see 7 installed on is working would be booting from a GParted live cd or flash drive and the first shown should be the target drive for 7. Then you simply go to the menu bar>Devices and click on the "Create new partition table" option. Click the apply button and watch if that works.

Then you click on new and select primary and afterward NTFS in lower case from the dropdown menu and click the apply button. A last click to format and again select NTFS from the list of files systems as well as labeling the new volume created will be seen by the 7 installer.

The trick is to get something on the drive first when any Windows installer is not playing well. I ran into that with a 98 VM project where simply getting a few setup files onto the VHD then allowed that old installer to recognize the virtual disk and proceed with the install. This will also see a single primary if you are not interested in seeing the 100mb boot partition on the drive once 7 is on.
My System SpecsSystem Spec
Reply

 AHCI Issue




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
cloned C:, installed AHCI drivers, changed BIOS to AHCI, D:'s GPT gone
see second post. I have a 3TB drive D: for data formatted with GPT. Had BIOS OnChip SATA Type set as "RAID" "As SATA Type" from back in the day. When I took out the RAID, I forgot to change this to AHCI when I reformatted and got rid of RAID drives! Changing to "AHCI" "As SATA Type" as...
Installation & Setup
HP Pavilion DV6 AHCI issue
I have an issue with a HP laptop that I find annoying. The laptop belongs to a customer's Son and he brought it to me because it ran rather slow and so, I looked at it and told him that some more memory and a nice SSD would be good for him, anyway, the main issue here is the silly Setup in the...
Hardware & Devices
No AHCI option in BIOS, is my computer default in AHCI or IDE?
I bought a brand new SSD, installed it in Windows 7, and there is no option in my BIOS for the SATA controller (to switch between IDE and AHCI Mode). How do I determine whether my computer's sata controller is using IDE or AHCI? I want to make sure that my AHCI controller is enabled and not IDE...
Hardware & Devices
Is AHCI necessary with SSD?
I just built a machine with a 120gb SSD and a 1 tb standard Sata drive. Is it necessary to have AHCI turned on? I can't seem to get a solid answer from anyone. One says turn it on, and another says don't use it. What's right? Many thanks to all.
Hardware & Devices
Ssd & ahci
I don't understand AHCE but was told to make sure when I put in my SSD to put it in AHCE. I don't even know what that is but I think you set it up in the BIOS. However my drive is fast. I can bring up Word or Excel in less than one second so maybe this is something I shouldn't worry about?
Installation & Setup
Intel Sata controler ICH10R AHCI + Jmicron AHCI error
Hi. I have the GA-EX58-Extreme Board and have just installed the pre release of Win7 7600 64 bit. Normally i have experience to get the BSOD when in staling with AHCI active in bios so i change to IDE mode. Installation went flawless and also the change to AHCI mode on Intel ICH10R controler...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App