Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Help: Repeated "USB Device Not Recognised"


29 Jun 2012   #1

OS: Lots
 
 
Help: Repeated "USB Device Not Recognised"

My HTPC is repeatedly showing a "USB Device Not Recognised" from the system tray around every 45 seconds. It is accompanied by the USB with duh-duh sound that usually happens when you plug in a new device (low note followed by high note).

It doesn't always happen all of the time but it does occur quite regularly. I think it happens after waking from sleep but I am not 100% sure. Rebooting the PC works most of the time but not always. Sometimes several reboots are necessary before the problem goes away.

I have no idea which USB device (if any) is causing a problem. The Device Manager shows no problem devices even with hidden devices shown.

In my advanced power settings, I have "USB selective suspend setting" disabled. In fact I've disabled most things that sound like they could potentially cause devices not to wake properly.

When the message starts appearing, I have even tried removing all USB devices, including the internal ones connected to the motherboard USB headers to see if it would stop but no luck.

I can't find anything helpful in the windows event log although admittedly I am not sure exactly where to look in it.

I am at a loss so I'd really appreciate some suggestions for tracking down the problem.

Thanks in advance.

P.S: Some hardware/OS info:

Windows 7 x64 Ultimate
ASRock Z68 Pro3-M
Intel C
ore i3-2120
Antec MicroFusion Remote 350 (With iMON front panel).

EDIT: I've also tried:
sfc /scannow
did not find any violations

My System SpecsSystem Spec
.

02 Jul 2012   #2

OS: Lots
 
 

I have now managed to solve this issue but since nobody had any suggestions I thought I'd share what I found for others to find.

In the end, the problem hardware was a TeVii S480 dual DVB-S2 tuner. I didn't originally list it in my hardware info as it is a PCIe device and not a USB device. However, the card still seems to be registering itself as 2 USB devices.

To solve the issue, I waited until the annoying messages started appearing and then I went through each "USB Root Hub" in the device manager. I looked at the power tab of the properties of each one, which lists the devices connected to that hub. There were two problem hubs which did indeed have "USB Device not recognised" showing in the power tab. When I disabled these two hubs, the messages and beeps stopped.

I then left them disabled and rebooted the machine. When it came back up I found the disabled USB hubs again and re-enabled them. They then showed:

TeVii S480 BDA DVB-S2 (LNB1)
TeVii S480 BDA DVB-S2 (LNB2)

Ah ha!

Anyway, I updated the firmware and the device drivers for this card and since then, I have not had any issues. That was two days ago so things are looking good.

In any case, at least I know what device is causing the problems now. To be honest I have had nothing but trouble with this card in both Windows and Linux and already have a TBS6891 running in another slot which is much more reliable. If it starts beeping at me again it's going through the window!
My System SpecsSystem Spec
Reply

 Help: Repeated "USB Device Not Recognised"




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:22 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33