Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB3.0 Issue


30 Jun 2012   #1

Windows 7 Home Premium 64bit
 
 
USB3.0 Issue

Hi there, I'm not too sure where to post this and this is my first time posting on windows forum so if I did anything wrong please excuse me. Nevertheless here's my problem:

My USB ports at the rear aren't working, when I try to plug any device into rear USB 3.0 ports it would not work. Every time I repair USB3_ASMedia(v1.10.1.0) (Asrock USB3.0 driver) it would say either "Generic USB Hub (X)Device unplugged" or "Unknown Device (X)Device unplugged". I am using my GOFLEX 2TB (with usb3.0 connection) and MBEAT 7port USB3.0/2.0 hub , both don't work. Even USB2.0 thumbdrive don't work. All drivers are up to date, only BIOS has NOT been updated. Also, devices connected to the HUB works during boot and is detected in BOIS but does not work in windows. However, MBeat Hub/goflex works in USB2.0 port. Please Help

MOBO: AsRock Fatal1ty z68 professional gen3
CPU: i7 2600k

Many Thanks


My System SpecsSystem Spec
.

30 Jun 2012   #2
Microsoft MVP

 

Read on the available BIOS update download page what it is for, or download it and read the included ReadMe file to see if it affects this issue.

Normally as a rule I keep the BIOS updated, especially if the update can be run from Windows 7.
My System SpecsSystem Spec
30 Jun 2012   #3
mjf

Windows 7x64 Home Premium SP1
 
 

Also, what do you see when you go into Device Manager?
Under Universal Serial Bus Controllers do you see: USB 3 Host Controller and USB 3 Root Hub.
My System SpecsSystem Spec
.


30 Jun 2012   #4

Windows 7 Home Premium 64bit
 
 

Hi, thx for the replies
@gregrocker - The BIOS updates does not affect USB3.0 or my computer/setup
@mjf - Ive attached a screen shot of my device manager (The one with the black background is Windows 7 and the one with flowers is win8)

It should also be noted that after installing windows 8 (and in win8), there does not seem to be an issue. I can use all USB3.0 ports, devices work perfectly. Therefore it isn't a hardware issue


Attached Thumbnails
USB3.0 Issue-device-manager-windows-7.jpg   USB3.0 Issue-device-manager.jpg  
My System SpecsSystem Spec
01 Jul 2012   #5
mjf

Windows 7x64 Home Premium SP1
 
 

This suggests to me that for Windows 7 you need to specifically install the USB 3 drivers. I have never used W8 but it is my understanding that this OS automatically handles USB 3 as you appear to have found out.
My System SpecsSystem Spec
01 Jul 2012   #6

Windows 7 Home Premium 64bit
 
 

Yeah, I've heard that Win8 handles USB3 on its own.
I've already installed the ASRock USB3 drivers as shown (ASMedia XHCI Controller). The ports used to work, but ever since I bought and plugged my MBeat 7 Port USB hub it just doesn't want to work
My System SpecsSystem Spec
Reply

 USB3.0 Issue




Thread Tools



Similar help and support threads for2: USB3.0 Issue
Thread Forum
Solved ASUS M4A89GTD Pro/USB3: USB3 driver issues Drivers
Solved USB3 card - USB2 Iomega HD - autoplay issue from sleep mode Hardware & Devices
Solved USB3 to USB 3 on a PCIE card Hardware & Devices
2TB USB3 HDDS acceptable? Hardware & Devices
Solved Memory issue GA-790XT USB3 kingston Hyper x KHX1600C9D3K4 /16GX Hardware & Devices
USB3 Problem Drivers
Solved usb3 compatibility Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:56 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33