Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WD External HDD Lost initialization not detected as accesable volume

07 Jul 2012   #1

Windows 7 ultimate x64
 
 
WD External HDD Lost initialization not detected as accesable volume

Hello guys,seriously the geek ones!

My HDD Properties:
*Western Digital MyBook Essential 1TB USB 3
*HDD has only 1 partition with size of 1TB
*I have very Important data and want them all back


I have an external Western Digital 1TB HDD.Full of incredibly amazingly important data.I bought the HDD about 10 months ago and the device was working properly.But after 7 months it started acting strange like the HDD was not being recognized And I should have unpluged it few times to be detected , or it being undetected minutes after being detected & I should again unplug/plug it to work. and by the time It get worst & worst.
Till last month , the HDD became fully Undetectable.

At technical point of view , it is showing NOT INITIALIZED under Windows Disc Management panel.When I plug the HDD in I hear the "DING" sound that means some thing has pluged in. But NO DRIVE is shown In my computer window.
the HDD lamp is powered that means the power connection is OK.
I have tested This drive in 2 Other computer All on windows 7 And unfortunately nothing happened.The HDD Uses USB3 Cable/port compatible with USB2.Tha cable is Ok and I tested with other cables as well and no change.I tested the HDD with a USB Hub with additional power cable and well nothing happened.
I tried some of famous recovery apps but they even do not detect the hdd partition.
there is also no problem with my usb ports cuz other devices are working properly.

Ohhh... Please some one help me .
thanks


My System SpecsSystem Spec
.

Reply

 WD External HDD Lost initialization not detected as accesable volume




Thread Tools



Similar help and support threads for2: WD External HDD Lost initialization not detected as accesable volume
Thread Forum
Suddenly lost volume from You-Tube...... Sound & Audio
i have an initialization problem with my lg external 1 tb hard drive Hardware & Devices
Solved I lost my volume control Sound & Audio
External HDD not detected Hardware & Devices
Solved External HDD not detected Hardware & Devices
Corrupt System Volume - HDD not detected BSOD Help and Support
Volume Mixer lost IE sound... Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:39 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33