Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Services not running (svchost.exe isn't starting)

12 Jul 2012   #1
alebcay

Windows 7 x86
 
 
Services not running/working!

Hello everyone,

Today, my computer just finished installing updates, and was waiting for me at the user selection/log in screen when I checked on it. I powered it off by holding the power button down to change some BIOS settings. (In the end, I did not save any changes to the BIOS, so I can rule that out) After rebooting and logging in, MSE and avast both tell me that their respective services have been stopped, and WiFi is not working either (its stuck as connected, but has the small yellow triangle in the icon, it says its identifying, but its been stuck like that). Other services, such as Dropbox and RocketDock have also been stopped on my computer.

I then rebooted into Safe Mode with Networking. WiFi is still not working, and now, audio service is also stopped. From here, I uninstalled all of the updates that had been installed today. I then rebooted normally.

Finally, RocketDock and Audio Service are running again, avast!, MSE, Dropbox, and WiFi are not still. I'm using Malwarebytes' and avast! to scan for crap that might be doing stuff (Malwarebytes' has already picked up four positives, both scans are still underway).

Does anybody know how to fix this?


My System SpecsSystem Spec
.

13 Jul 2012   #2
UsernameIssues

W7 Pro SP1 64bit
 
 

Quote   Quote: Originally Posted by alebcay View Post
.....I powered it off by holding the power button down...
Did you press the power button and patiently wait for the operating system to shut down gracefully or did you hold the power button in long enough to force the computer to shutdown? Forcing a shutdown should only be done if the computer is hung up and will not shutdown gracefully.

[This other post of yours seems to indicate that you forced the computer to turn off.]

Quote   Quote: Originally Posted by alebcay View Post
MSE and avast both tell me...
AVAST makes more products than just antivirus software - so I cannot be sure what you are saying that you have installed. If you have MSE antivirus and AVAST antivirus installed at the same time - then you might have been lucky in the past and had those two tools appear to get along, but an update to either one could cause them to start fighting each other. Pick one. Uninstall the other.

By now, your malware scan should have completed, but please try this one too:
(if you have not already done so)
What is Windows Defender Offline?
My System SpecsSystem Spec
14 Jul 2012   #3
alebcay

Windows 7 x86
 
 

I was using avast! Free Antivirus and MSE. I'll be updating the other post that you linked to from now on...
My System SpecsSystem Spec
.


Reply

 Services not running (svchost.exe isn't starting)




Thread Tools





Similar help and support threads
Thread Forum
svchost.exe problem - not running any services
I am running 32-bit Windows 7 Professional on my laptop and everything was going smoothly up until yesterday when suddenly, the fan started to ramp up and continue blowing at startup (usually, when I press the power button, the fan will start, but then it'll die down by the time the OS boots up). ...
General Discussion
No svchost running at all
Yesterday, I installed Foxit Reader, then decided I didn't like it. When I attempted to re-install, I received the error message that "the windows installer service could not be accessed." It was listed as running in the services applet of administrator tools, but would not work. While then...
General Discussion
Many svchost.exe running, plz help soon.
Hi to all,, the installed windows seven is much older and sick, that's why I install a fresh copy of windows seven today, its work fine,, but when I open the task manager and its Process tab, its full of services specially svchost.exe. although I didn't install too many applications. I just...
Performance & Maintenance
16+ svchost.exe processes running
I have recently noticed that my computer is running from 16 to 18 different processes of svchost at once, and without running any programs uses 30% of my RAM. http://i453.photobucket.com/albums/qq260/manypopes/svchost.png?t=1287308628 That screenshot was taken when running nothing but Opera....
Performance & Maintenance
A lot of svchost.exe running on process tab on Task Man
Hi! There are a lot of svchost.exe running on process tab on Task Manager and a high cpu + memory usage. What happened to my computer or is it normal to be so? A image view of it is also uploaded.
General Discussion
Task Manager - Show Services Running under svchost.exe
How to See Services Running Under svchost.exe Process in Windows 7 Microsoft defines svchost.exe as a generic host process name for services that run from dynamic link libraries. This will show you how to identify what services are running under a single process of svchost.exe. Here's...
Tutorials

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App