Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: USB Ports not working after upgrading Windows

16 Aug 2012   #1

MS Windows 7 Home Premium 64-bit SP1
 
 
USB Ports not working after upgrading Windows

Hi I recently upgraded my Windows PC from 32bit to Windows 7 Home Premium 64bit. The only problem is, all of the USB ports on the back of the computer don't work at all, while the ones on the front work fine. I've upgraded my BIOS, and installed drivers, but still nothing. What else can I do?

My System SpecsSystem Spec
.

16 Aug 2012   #2
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Hi ozza Welcome to Seven Forums.
To help all of us would you please add your systems specs? Here's how: System Info - See Your System Specs
Under System Manufacturer/Model Number add desktop or laptop and whether self built.

You can easily copy/paste from within the app, no install required.

You could try uninstalling all USB drivers, reboot and see if Windows Update will fix them. This is odd since the back ports are attached to the motherboard.
My System SpecsSystem Spec
16 Aug 2012   #3

MS Windows 7 Home Premium 64-bit SP1
 
 

Its a custom built computer with a core 2 duo 3.17 ghz, 4gb Ram and has a nvidia gt240 graphics card. The motherboard of the computer is a gigabyte ep45-ud3l. I've gone into the device manager and its got a code 45 error. I've tried uninstalling the drivers and rebooting the computer and it still doesnt work. It works for about the first minute and then just stops. I've also did a clean install of windows 7 32 bit and its now doing the same thing there.
My System SpecsSystem Spec
.


17 Aug 2012   #4
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Check your BIOS and see that USB is enabled, including Legacy support.
My System SpecsSystem Spec
17 Aug 2012   #5

MS Windows 7 Home Premium 64-bit SP1
 
 

Ive tried tht as well and it's still not working. It sometimes works for the first minute or so then stops or sometimes it doesnt work at all.
My System SpecsSystem Spec
17 Aug 2012   #6
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

You could try re-flashing the BIOS and see if that helps.
You may have some bent/bad USB ports too, that's the only other thing I can think of.
My System SpecsSystem Spec
17 Aug 2012   #7

MS Windows 7 Ultimate SP1 64-bit
 
 

Ozza,
Please help us to help you by actually filling out your system specs.

This write-up will walk you through what is required and give you a "how to".

Update your SevenForums System Specs
User CP (located on the top menu bar) |
Your Profile | Edit System Spec
(left-hand column)

To gather info, use Speccy (my favorite) or SIW or System Info

In the System Manufacturer Block, enter:
Manufacturer and Model and
ADD the word laptop, desktop, netbook or tablet.
For example:
Toshiba Satellite L305D notebook.

Provide full windows version info, for example:
MS Windows 7 Ultimate SP1 64-bit

Use the “Other Info” block for Optical Reader,
Mouse, touchpad, wifi adapter, speakers, monitor, etc

Scroll down and click on SAVE CHANGES.

You will find that in Speccy, you can select info from the display
using your mouse/touchpad and then paste that info into your specs.

SIW is a marvelous program, but the free version does not offer
this capability.
My System SpecsSystem Spec
17 Aug 2012   #8

MS Windows 7 Home Premium 64-bit SP1
 
 

Hi These are my specs. Not really sure of the brand of the computer but it says Antec on the front.

Operating System
MS Windows 7 Home Premium 64-bit SP1
CPU
Intel Core 2 Duo E8500 @ 3.16GHz 43 °C
Wolfdale 45nm Technology
RAM
4.00 GB Dual-Channel DDR2 @ 399MHz (5-5-5-18)
Motherboard
Gigabyte Technology Co., Ltd. EP45-UD3L (Socket 775) 29 °C
Graphics
SAMSUNG (1360x768@60Hz)
1024MB GeForce GT 240 (nVidia) 34 °C
Hard Drives
466GB SAMSUNG SAMSUNG HD502HI ATA Device (SATA) 25 °C
Optical Drives
PIONEER DVD-RW DVR-216 ATA Device
Audio
High Definition Audio Device
My System SpecsSystem Spec
17 Aug 2012   #9

MS Windows 7 Ultimate SP1 64-bit
 
 

read post #7. Follow the procedure given there.
My System SpecsSystem Spec
17 Aug 2012   #10

MS Windows 7 Home Premium 64-bit SP1
 
 

Just fixed it now. It was just the mouse crashing the usb ports. Spent 4 days on it and didnt try a different mouse lol.
My System SpecsSystem Spec
Reply

 USB Ports not working after upgrading Windows




Thread Tools



Similar help and support threads for2: USB Ports not working after upgrading Windows
Thread Forum
Solved Front USB ports not working, but rear USB ports work… Hardware & Devices
USB ports (3.0) no longer working after Windows 7 Re-Install. Hardware & Devices
USB ports/devices stop Working when Windows 7 Boots Hardware & Devices
USB ports not working in windows Hardware & Devices
HP webcam stopped working after upgrading to Windows 7 Drivers
none of my USB ports are working Hardware & Devices
USB Ports are not working in Windows 7 Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:14 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33