Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Internal disk not correctly recognised - WD velociraptor, Gigabyte

27 Aug 2012   #1

Windows 7 Enterprise SP1 64-bit
 
 
Internal disk not correctly recognised - WD velociraptor, Gigabyte

i'm having problems configuring a disk in a brand new, clean windows-7 install. here are some system specifics-

. disk- western digital velociraptor wd6000hlhx
. mobo- gigabyte z77x-ud3h
. bios sata-mode set to ahci [not raid], w/disk connected to sata0 [6gb/s hi-speed sata].
. windows 7 enterprise sp1 x64

the disk is recognized by bios and correctly identified [name & size ok].

the disk is also recognized by windows on a h/w level, but it won't show up in the explorer. windows reports the device is working correctly.

windows disk manager shows the drive, but says it's uninitialized and has no partitions [which is incorrect]. if i try to initialize the drive, windows throws an error saying that it "cannot find the file specified". [which file???]

before connecting the drive to the new machine, i partitioned and formatted the disk under windows xp sp2, giving it 2 partitions [mbr, not gpt] and copying over a boatload of data. obviously none of this appears under windows 7. removing the disk from the new machine and replacing it back in the windows xp machine shows the disk and all data are intact and functional.

i'd like to have windows 7 recognize the disk w/o having to lose the data and start over. is this possible? if so, how would i do that?

[i checked several posts -- e.g., here -- but even though the problem seems identical, the information didn't help.]

any help appreciated.

thanks!

My System SpecsSystem Spec
.

28 Aug 2012   #2
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello david0077, welcome to Seven Forums.


Using an elevated command window see in the disk will initilaize in Windows diskpart.
diskpart

list disk

select disk ? | ? = your disk number

online

exit

exit
My System SpecsSystem Spec
28 Aug 2012   #3

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate X64 SP1
 
 

Though ti shouldn't be necessary, put your OS drive on the SATA_0 port and the Raptor on another SATA 5Gbs port.
My System SpecsSystem Spec
.


29 Aug 2012   #4

Windows 7 Enterprise SP1 64-bit
 
 

thanks for the help, guys.

ok, i've got some new info.

calling diskpart in an elevated window shows me that the drive is already online.
just for kix, i tried to offline it. i got the same error msg that i got when i tried to initialize it using the disk mgt interface from 'manage computer' -- "cannot find the file specified".

if i list the details of the disk within diskpart, it shows me the disk as read-only, and the disk type is set to 'raid' [which is odd, because i haven't selected raid in the bios].

if i swap the disks, i.e., put the boot disk on the high-speed [6gb/s] controller and the unrecognized disk on the 3gb/s controller, the disk still appears as wonky as ever from the disk mgt widget. HOWEVER, it no longer even appears in diskpart.

one of the utilities included on the mobo driver install disk is 'intel rapid store technology'. when i run this, it's able to get all the info from the disk [serial number, model number, correct disk size, etc.] and shows the disk as being in working order. it also shows the usage as 'unknown'.

i d/l'd the western digital diagnostic tool and ran it against the disk. it says the disk is fine. however, it doesn't list the model number in its list of disk drives.

this situation really has me scratching my head... at this point, i'm even ready to repartition and reformat the disk from scratch [as long as i can end up w/a readable mbr-based partition table in order to put it back into the other machine and copy the files over again] -- but i can't seem to be able to access the disk even to do that.

any other ideas?

thanks
dave
My System SpecsSystem Spec
29 Aug 2012   #5
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello Dave.


Though it's a lot of trouble and as you still have the data saved on another PC, perhaps you could try a wipe " clean " of the HDD and format it using the intended PC and see if it is then recognized after that, have a look through the info below and be sure to post back to keep us informed.

information   Information

To rule out format errors, boot the Windows 7 installation media to diskpart and run the clean command, once the clean finishes, exit diskpart and use the Windows 7 installer to create and format a single 100GB partition to install to.

If that does't work, after another clean, use diskpart to create, format and mark Active a single 100GB partition to see if that works, use Step #2 in the SSD/HDD tutorial for reference.
DISKPART : At PC Startup

SSD / HDD : Optimize for Windows Reinstallation
My System SpecsSystem Spec
29 Aug 2012   #6

Windows 7 Enterprise SP1 64-bit
 
 
SOLVED: Internal disk not recognised - velociraptor, GA-z77x-ud3h

well, the solution to this problem turned out to be fairly simple, but a little counter-intuitive [at least to me...]. the bios config was at fault.

i was poking around in the bios and, remembering that the intel utility said the disk was a raid disk, set the sata device type to 'raid' [it was set to ahci]. this allowed the raid menu to come up on boot, which allowed me to see the disk as part of a raid set and reset it to standard disk, instead of raid. once i did that, everything worked fine -- both partitions visible, no data lost.

i have no clue why the mobo defaulted to setting this disk as a raid disk. seems a little presumptuous to me...

anyway, problem solved now, thanks much for all your help.

cheers
dave
My System SpecsSystem Spec
30 Aug 2012   #7

Microsoft Community Contributor Award Recipient

Windows 7 Ultimate X64 SP1
 
 

Very odd thing there, but glad you figured it out!
My System SpecsSystem Spec
Reply

 Internal disk not correctly recognised - WD velociraptor, Gigabyte





Thread Tools



Similar help and support threads for2: Internal disk not correctly recognised - WD velociraptor, Gigabyte
Thread Forum
Internal HD not recognised. Hardware & Devices
Solved Old Hard Disk now fitted into a caddy but it is not being recognised Hardware & Devices
Solved Help in formatting ext hard disk ( actually internal with casing) Hardware & Devices
how can i put password on (internal) hard disk?? Hardware & Devices
3TB internal HD not installing correctly Hardware & Devices
USB external hard disk shows up as internal fixed disk Hardware & Devices
XPMode USB mouse not recognised correctly Virtualization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:09 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33