Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot Secure Erase an SSD drive


18 Sep 2009   #1

Windows 7 Ultimate x64
 
 
Cannot Secure Erase an SSD drive

So, after reading a ton about SSD drives and finally getting one (Intel X25-M G2), I played around with it for a while today and figured that I would just do a secure erase to get it back to factory defaults before really getting it setup on my machine.

Turns out the Secure Erase app (3.3 or 4.0) won't work as the BIOS of my machine sends a "freeze lock" command thus these tools cannot touch the drive.

I've tried the Linux bootable CD with hdparm tool as well and it to shows that the device is locked...thus it cannot proceed.

I've tried the Secure Erase tool from several machines and all result in same thing. Secure Erase gets to welcome screen where it would display the attached hard drives and that is as far as it goes.

So, anybody got any suggestions. According to people who make Secure Erase, a least desirable workaround is to boot the machine with no power attached to the drive and then connect power while the machine is running. Well, obviously with a brand new hard drive, I don't want to do that.


My System SpecsSystem Spec
.

18 Sep 2009   #2

Windows 7 Ultimate x64
 
 

Nevermind. I found a computer at my house where this functionality works as it should. I was able to successfully secure erase my drive on my Intel X25-M G2 drive.
My System SpecsSystem Spec
30 Apr 2010   #3

W7 Prof 64 bit
 
 

Quote   Quote: Originally Posted by pparks1 View Post
Nevermind. I found a computer at my house where this functionality works as it should. I was able to successfully secure erase my drive on my Intel X25-M G2 drive.

May I ask why you had to do a secure erase? I have a problem with my new drive too, it's the same model as yours.
My System SpecsSystem Spec
.


30 Apr 2010   #4

Windows 7 Home Premium 64bit
 
 

I had the same issue.
The solution for me was:
I had to switch to IDE mode in Bios, then Enable Leagacy Mode.
It then required a complete power down of the MOBO and restart to take effect.
Just restarting wouldnt work, even tho it was set correctly.

Same when setting it back to Legacy disabled and AHCI mode.
My System SpecsSystem Spec
30 Apr 2010   #5

Windows 7 Ultimate x64
 
 

Yeah, that was pretty much what I recall having to do.
My System SpecsSystem Spec
Reply

 Cannot Secure Erase an SSD drive




Thread Tools



Similar help and support threads for2: Cannot Secure Erase an SSD drive
Thread Forum
Solved Additional Secure Erase / Wipe Information Installation & Setup
Secure erase on a ssd Hardware & Devices
SSD OCZ Vertex 2 / Secure Erase Installation & Setup
Secure Erase / Wipe : Definition and Methods Tutorials
Solved Secure Erase / Wipe : Definition and Methods - Tutorial Chillout Room
question RE: secure erase Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:35 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33